Upstream information

CVE-2004-0906 at MITRE

Description

The XPInstall installer in Mozilla Firefox before the Preview Release, Mozilla before 1.7.3, and Thunderbird before 0.8 sets insecure permissions for certain installed files within xpi packages, which could allow local users to overwrite arbitrary files or execute arbitrary code.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 60640 [RESOLVED], 74445 [RESOLVED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SuSE Linux Desktop 1.0
  • galeon >= 1.2.13-17
  • mozilla >= 1.4.1-23
  • mozilla-deat >= 1.4.1-8
  • mozilla-irc >= 1.4.1-23
  • mozilla-mail >= 1.4.1-23
Builds
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • mozilla >= 1.4.1-21
  • mozilla-calendar >= 1.4.1-21
  • mozilla-dom-inspector >= 1.4.1-21
  • mozilla-irc >= 1.4.1-21
  • mozilla-mail >= 1.4.1-21
  • mozilla-spellchecker >= 1.4.1-21
  • mozilla-venkman >= 1.4.1-21
  • mozilla-xmlterm >= 1.4.1-21
ul1.ia64
slox4,2.x86
ul1.s390
ul1.x86-64
ul1.s390x
ul1.ppc
YOU Patch Nr: 9390