Upstream information

CVE-2023-4785 at MITRE

Description

Lack of error handling in the TCP server in Google's gRPC starting version 1.23 on posix-compatible platforms (ex. Linux) allows an attacker to cause a denial of service by initiating a significant number of connections with the server. Note that gRPC C++ Python, and Ruby are affected, but gRPC Java, and Go are NOT affected. 

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1215334 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 15 SP4-LTSS
  • abseil-cpp-devel >= 20230802.1-150400.10.4.1
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libgrpc++1_60 >= 1.60.0-150400.8.3.2
  • libgrpc1_60 >= 1.60.0-150400.8.3.2
  • libgrpc37 >= 1.60.0-150400.8.3.2
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
  • libprotobuf25_1_0 >= 25.1-150400.9.3.1
  • libprotoc25_1_0 >= 25.1-150400.9.3.1
  • libre2-11 >= 20240201-150400.9.3.1
  • libupb37 >= 1.60.0-150400.8.3.2
  • protobuf-devel >= 25.1-150400.9.3.1
Patchnames:
SUSE-SLE-Product-SLED-15-SP4-LTSS-2024-573
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Installer Updates 15 SP4
SUSE Linux Enterprise Server 15 SP4
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
Patchnames:
SUSE-SLE-INSTALLER-15-SP4-2024-573
SUSE Linux Enterprise Desktop 15 SP5
  • abseil-cpp-devel >= 20230802.1-150400.10.4.1
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libgrpc++1_60 >= 1.60.0-150400.8.3.2
  • libgrpc1_60 >= 1.60.0-150400.8.3.2
  • libgrpc37 >= 1.60.0-150400.8.3.2
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
  • libprotobuf25_1_0 >= 25.1-150400.9.3.1
  • libprotoc25_1_0 >= 25.1-150400.9.3.1
  • libre2-11 >= 20240201-150400.9.3.1
  • libupb37 >= 1.60.0-150400.8.3.2
  • protobuf-devel >= 25.1-150400.9.3.1
  • python311-abseil >= 1.4.0-150400.9.3.1
  • python311-grpcio >= 1.60.0-150400.9.3.2
  • python311-protobuf >= 4.25.1-150400.9.3.1
Patchnames:
SUSE-SLE-INSTALLER-15-SP5-2024-573
SUSE-SLE-Module-Basesystem-15-SP5-2024-573
SUSE-SLE-Module-Development-Tools-15-SP5-2024-573
SUSE-SLE-Module-Python3-15-SP5-2024-573
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS
  • abseil-cpp-devel >= 20230802.1-150400.10.4.1
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libgrpc++1_60 >= 1.60.0-150400.8.3.2
  • libgrpc1_60 >= 1.60.0-150400.8.3.2
  • libgrpc37 >= 1.60.0-150400.8.3.2
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
  • libprotobuf25_1_0 >= 25.1-150400.9.3.1
  • libprotoc25_1_0 >= 25.1-150400.9.3.1
  • libre2-11 >= 20240201-150400.9.3.1
  • libupb37 >= 1.60.0-150400.8.3.2
  • protobuf-devel >= 25.1-150400.9.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP4-ESPOS-2024-573
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS
  • abseil-cpp-devel >= 20230802.1-150400.10.4.1
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libgrpc++1_60 >= 1.60.0-150400.8.3.2
  • libgrpc1_60 >= 1.60.0-150400.8.3.2
  • libgrpc37 >= 1.60.0-150400.8.3.2
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
  • libprotobuf25_1_0 >= 25.1-150400.9.3.1
  • libprotoc25_1_0 >= 25.1-150400.9.3.1
  • libre2-11 >= 20240201-150400.9.3.1
  • libupb37 >= 1.60.0-150400.8.3.2
  • protobuf-devel >= 25.1-150400.9.3.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP4-LTSS-2024-573
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • abseil-cpp-devel >= 20230802.1-150400.10.4.1
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libgrpc++1_60 >= 1.60.0-150400.8.3.2
  • libgrpc1_60 >= 1.60.0-150400.8.3.2
  • libgrpc37 >= 1.60.0-150400.8.3.2
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
  • libprotobuf25_1_0 >= 25.1-150400.9.3.1
  • libprotoc25_1_0 >= 25.1-150400.9.3.1
  • libre2-11 >= 20240201-150400.9.3.1
  • libupb37 >= 1.60.0-150400.8.3.2
  • protobuf-devel >= 25.1-150400.9.3.1
  • python311-abseil >= 1.4.0-150400.9.3.1
  • python311-grpcio >= 1.60.0-150400.9.3.2
  • python311-protobuf >= 4.25.1-150400.9.3.1
Patchnames:
SUSE-SLE-INSTALLER-15-SP5-2024-573
SUSE-SLE-Module-Basesystem-15-SP5-2024-573
SUSE-SLE-Module-Development-Tools-15-SP5-2024-573
SUSE-SLE-Module-Public-Cloud-15-SP5-2024-573
SUSE-SLE-Module-Python3-15-SP5-2024-573
SUSE Linux Enterprise Installer Updates 15 SP5
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
Patchnames:
SUSE-SLE-INSTALLER-15-SP5-2024-573
SUSE Linux Enterprise Micro 5.3
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
Patchnames:
SUSE-SLE-Micro-5.3-2024-573
SUSE Linux Enterprise Micro 5.4
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
Patchnames:
SUSE-SLE-Micro-5.4-2024-573
SUSE Linux Enterprise Micro 5.5
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
Patchnames:
SUSE-SLE-Micro-5.5-2024-573
SUSE Linux Enterprise Module for Basesystem 15 SP5
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libgrpc++1_60 >= 1.60.0-150400.8.3.2
  • libgrpc1_60 >= 1.60.0-150400.8.3.2
  • libgrpc37 >= 1.60.0-150400.8.3.2
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
  • libprotobuf25_1_0 >= 25.1-150400.9.3.1
  • libprotoc25_1_0 >= 25.1-150400.9.3.1
  • libre2-11 >= 20240201-150400.9.3.1
  • libupb37 >= 1.60.0-150400.8.3.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2024-573
SUSE Linux Enterprise Module for Development Tools 15 SP5
  • abseil-cpp-devel >= 20230802.1-150400.10.4.1
  • libprotoc25_1_0 >= 25.1-150400.9.3.1
  • protobuf-devel >= 25.1-150400.9.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP5-2024-573
SUSE Linux Enterprise Module for Public Cloud 15 SP5
  • libgrpc1_60 >= 1.60.0-150400.8.3.2
  • libgrpc37 >= 1.60.0-150400.8.3.2
  • libprotoc25_1_0 >= 25.1-150400.9.3.1
  • libre2-11 >= 20240201-150400.9.3.1
  • libupb37 >= 1.60.0-150400.8.3.2
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-SP5-2024-573
SUSE Linux Enterprise Module for Python 3 15 SP5
  • python311-abseil >= 1.4.0-150400.9.3.1
  • python311-grpcio >= 1.60.0-150400.9.3.2
  • python311-protobuf >= 4.25.1-150400.9.3.1
Patchnames:
SUSE-SLE-Module-Python3-15-SP5-2024-573
SUSE Linux Enterprise Server 15 SP4-LTSS
  • abseil-cpp-devel >= 20230802.1-150400.10.4.1
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libgrpc++1_60 >= 1.60.0-150400.8.3.2
  • libgrpc1_60 >= 1.60.0-150400.8.3.2
  • libgrpc37 >= 1.60.0-150400.8.3.2
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
  • libprotobuf25_1_0 >= 25.1-150400.9.3.1
  • libprotoc25_1_0 >= 25.1-150400.9.3.1
  • libre2-11 >= 20240201-150400.9.3.1
  • libupb37 >= 1.60.0-150400.8.3.2
  • protobuf-devel >= 25.1-150400.9.3.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP4-LTSS-2024-573
SUSE Linux Enterprise Server for SAP Applications 15 SP4
  • abseil-cpp-devel >= 20230802.1-150400.10.4.1
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libgrpc++1_60 >= 1.60.0-150400.8.3.2
  • libgrpc1_60 >= 1.60.0-150400.8.3.2
  • libgrpc37 >= 1.60.0-150400.8.3.2
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
  • libprotobuf25_1_0 >= 25.1-150400.9.3.1
  • libprotoc25_1_0 >= 25.1-150400.9.3.1
  • libre2-11 >= 20240201-150400.9.3.1
  • libupb37 >= 1.60.0-150400.8.3.2
  • protobuf-devel >= 25.1-150400.9.3.1
Patchnames:
SUSE-SLE-INSTALLER-15-SP4-2024-573
SUSE-SLE-Product-SLES_SAP-15-SP4-2024-573
SUSE Manager Proxy 4.3
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libgrpc++1_60 >= 1.60.0-150400.8.3.2
  • libgrpc1_60 >= 1.60.0-150400.8.3.2
  • libgrpc37 >= 1.60.0-150400.8.3.2
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
  • libprotobuf25_1_0 >= 25.1-150400.9.3.1
  • libprotoc25_1_0 >= 25.1-150400.9.3.1
  • libre2-11 >= 20240201-150400.9.3.1
  • libupb37 >= 1.60.0-150400.8.3.2
Patchnames:
SUSE-SLE-INSTALLER-15-SP4-2024-573
SUSE-SLE-Product-SUSE-Manager-Proxy-4.3-2024-573
SUSE Manager Retail Branch Server 4.3
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libgrpc++1_60 >= 1.60.0-150400.8.3.2
  • libgrpc1_60 >= 1.60.0-150400.8.3.2
  • libgrpc37 >= 1.60.0-150400.8.3.2
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
  • libprotobuf25_1_0 >= 25.1-150400.9.3.1
  • libprotoc25_1_0 >= 25.1-150400.9.3.1
  • libre2-11 >= 20240201-150400.9.3.1
  • libupb37 >= 1.60.0-150400.8.3.2
Patchnames:
SUSE-SLE-INSTALLER-15-SP4-2024-573
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.3-2024-573
SUSE Manager Server 4.3
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libgrpc++1_60 >= 1.60.0-150400.8.3.2
  • libgrpc1_60 >= 1.60.0-150400.8.3.2
  • libgrpc37 >= 1.60.0-150400.8.3.2
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
  • libprotobuf25_1_0 >= 25.1-150400.9.3.1
  • libprotoc25_1_0 >= 25.1-150400.9.3.1
  • libre2-11 >= 20240201-150400.9.3.1
  • libupb37 >= 1.60.0-150400.8.3.2
Patchnames:
SUSE-SLE-INSTALLER-15-SP4-2024-573
SUSE-SLE-Product-SUSE-Manager-Server-4.3-2024-573
openSUSE Leap 15.5
  • abseil-cpp-devel >= 20230802.1-150400.10.4.1
  • grpc-devel >= 1.60.0-150400.8.3.2
  • grpc-source >= 1.60.0-150400.8.3.2
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libabsl2308_0_0-32bit >= 20230802.1-150400.10.4.1
  • libgrpc++1_60 >= 1.60.0-150400.8.3.2
  • libgrpc1_60 >= 1.60.0-150400.8.3.2
  • libgrpc37 >= 1.60.0-150400.8.3.2
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
  • libprotobuf-lite25_1_0-32bit >= 25.1-150400.9.3.1
  • libprotobuf25_1_0 >= 25.1-150400.9.3.1
  • libprotobuf25_1_0-32bit >= 25.1-150400.9.3.1
  • libprotoc25_1_0 >= 25.1-150400.9.3.1
  • libprotoc25_1_0-32bit >= 25.1-150400.9.3.1
  • libre2-11 >= 20240201-150400.9.3.1
  • libre2-11-32bit >= 20240201-150400.9.3.1
  • libupb37 >= 1.60.0-150400.8.3.2
  • opencensus-proto-source >= 0.3.0+git.20200721-150400.9.3.1
  • protobuf-devel >= 25.1-150400.9.3.1
  • protobuf-java >= 25.1-150400.9.3.1
  • python311-abseil >= 1.4.0-150400.9.3.1
  • python311-grpcio >= 1.60.0-150400.9.3.2
  • python311-protobuf >= 4.25.1-150400.9.3.1
  • re2-devel >= 20240201-150400.9.3.1
  • upb-devel >= 1.60.0-150400.8.3.2
Patchnames:
openSUSE-SLE-15.5-2024-573
openSUSE Leap Micro 5.3
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
Patchnames:
openSUSE-Leap-Micro-5.3-2024-573
openSUSE Leap Micro 5.4
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
Patchnames:
openSUSE-Leap-Micro-5.4-2024-573
openSUSE Leap Micro 5.5
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
Patchnames:
openSUSE-Leap-Micro-5.5-2024-573
openSUSE Tumbleweed
  • grpc-devel >= 1.60.0-3.1
  • grpc-source >= 1.60.0-3.1
  • libgrpc++1_60 >= 1.60.0-3.1
  • libgrpc1_60 >= 1.60.0-3.1
  • libgrpc37 >= 1.60.0-3.1
  • libupb37 >= 1.60.0-3.1
  • python310-grpcio >= 1.60.0-2.1
  • python311-grpcio >= 1.60.0-2.1
  • python39-grpcio >= 1.60.0-2.1
  • upb-devel >= 1.60.0-3.1
Patchnames:
openSUSE Tumbleweed GA grpc-devel-1.60.0-3.1
openSUSE Tumbleweed GA python310-grpcio-1.60.0-2.1

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Installer Updates 15 SP4
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
SUSE Linux Enterprise Server 15 SP4
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
SUSE Linux Enterprise Desktop 15 SP4
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
SUSE Linux Enterprise Server for SAP Applications 15 SP4
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
SUSE Linux Enterprise High Performance Computing 15 SP4
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
SUSE Manager Server 4.3
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
SUSE Manager Proxy 4.3
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
SUSE Manager Retail Branch Server 4.3
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
SUSE Linux Enterprise Installer Updates 15 SP5
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
SUSE Linux Enterprise Server 15 SP5
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
SUSE Linux Enterprise Desktop 15 SP5
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1
SUSE Linux Enterprise High Performance Computing 15 SP5
  • libabsl2308_0_0 >= 20230802.1-150400.10.4.1
  • libprotobuf-lite25_1_0 >= 25.1-150400.9.3.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 grpc Affected
SUSE Linux Enterprise Desktop 15 SP5 abseil-cpp In progress
SUSE Linux Enterprise Desktop 15 SP5 grpc Released
SUSE Linux Enterprise Desktop 15 SP5 protobuf In progress
SUSE Linux Enterprise Desktop 15 SP5 python-abseil Released
SUSE Linux Enterprise Desktop 15 SP5 python-grpcio Released
SUSE Linux Enterprise Desktop 15 SP5 re2 Released
SUSE Linux Enterprise High Performance Computing 15 SP5 abseil-cpp In progress
SUSE Linux Enterprise High Performance Computing 15 SP5 grpc Released
SUSE Linux Enterprise High Performance Computing 15 SP5 protobuf In progress
SUSE Linux Enterprise High Performance Computing 15 SP5 python-abseil Released
SUSE Linux Enterprise High Performance Computing 15 SP5 python-grpcio Released
SUSE Linux Enterprise High Performance Computing 15 SP5 re2 Released
SUSE Linux Enterprise Installer Updates 15 SP5 abseil-cpp In progress
SUSE Linux Enterprise Installer Updates 15 SP5 protobuf In progress
SUSE Linux Enterprise Micro 5.3 abseil-cpp Released
SUSE Linux Enterprise Micro 5.3 protobuf Released
SUSE Linux Enterprise Micro 5.4 abseil-cpp Released
SUSE Linux Enterprise Micro 5.4 protobuf Released
SUSE Linux Enterprise Micro 5.5 abseil-cpp Released
SUSE Linux Enterprise Micro 5.5 protobuf Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 abseil-cpp Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 grpc Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 protobuf Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 re2 Released
SUSE Linux Enterprise Module for Development Tools 15 SP5 abseil-cpp Released
SUSE Linux Enterprise Module for Development Tools 15 SP5 protobuf Released
SUSE Linux Enterprise Module for Public Cloud 15 SP5 grpc Released
SUSE Linux Enterprise Module for Public Cloud 15 SP5 protobuf Released
SUSE Linux Enterprise Module for Public Cloud 15 SP5 re2 Released
SUSE Linux Enterprise Module for Python 3 15 SP5 protobuf Released
SUSE Linux Enterprise Module for Python 3 15 SP5 python-abseil Released
SUSE Linux Enterprise Module for Python 3 15 SP5 python-grpcio Released
SUSE Linux Enterprise Real Time 15 SP3 grpc Affected
SUSE Linux Enterprise Server 15 SP5 abseil-cpp In progress
SUSE Linux Enterprise Server 15 SP5 grpc Released
SUSE Linux Enterprise Server 15 SP5 protobuf In progress
SUSE Linux Enterprise Server 15 SP5 python-abseil Released
SUSE Linux Enterprise Server 15 SP5 python-grpcio Released
SUSE Linux Enterprise Server 15 SP5 re2 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 abseil-cpp In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP4 grpc Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 protobuf In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP4 re2 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 abseil-cpp In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP5 grpc Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 protobuf In progress
SUSE Linux Enterprise Server for SAP Applications 15 SP5 python-abseil Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 python-grpcio Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 re2 Released
SUSE Manager Proxy 4.3 abseil-cpp In progress
SUSE Manager Proxy 4.3 grpc Released
SUSE Manager Proxy 4.3 protobuf In progress
SUSE Manager Proxy 4.3 re2 Released
SUSE Manager Retail Branch Server 4.3 abseil-cpp In progress
SUSE Manager Retail Branch Server 4.3 grpc Released
SUSE Manager Retail Branch Server 4.3 protobuf In progress
SUSE Manager Retail Branch Server 4.3 re2 Released
SUSE Manager Server 4.3 abseil-cpp In progress
SUSE Manager Server 4.3 grpc Released
SUSE Manager Server 4.3 protobuf In progress
SUSE Manager Server 4.3 re2 Released
openSUSE Leap 15.5 grpc Released
openSUSE Leap 15.5 python-grpcio Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 abseil-cpp In progress
SUSE Linux Enterprise Desktop 15 SP4 grpc Affected
SUSE Linux Enterprise Desktop 15 SP4 protobuf In progress
SUSE Linux Enterprise Desktop 15 SP4 LTSS grpc Released
SUSE Linux Enterprise High Performance Computing 15 SP1 grpc Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 grpc Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 grpc Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS grpc Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS grpc Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 abseil-cpp In progress
SUSE Linux Enterprise High Performance Computing 15 SP4 grpc Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 protobuf In progress
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS abseil-cpp Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS grpc Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS protobuf Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS re2 Released
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS abseil-cpp Released
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS grpc Released
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS protobuf Released
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS re2 Released
SUSE Linux Enterprise Installer Updates 15 SP4 abseil-cpp In progress
SUSE Linux Enterprise Installer Updates 15 SP4 protobuf In progress
SUSE Linux Enterprise Module for Basesystem 15 SP4 grpc Affected
SUSE Linux Enterprise Module for Public Cloud 15 SP4 grpc Released
SUSE Linux Enterprise Module for Server Applications 15 SP3 grpc Affected
SUSE Linux Enterprise Module for Server Applications 15 SP4 grpc Affected
SUSE Linux Enterprise Server 15 SP2 grpc Affected
SUSE Linux Enterprise Server 15 SP3 grpc Affected
SUSE Linux Enterprise Server 15 SP3-LTSS grpc Affected
SUSE Linux Enterprise Server 15 SP4 abseil-cpp In progress
SUSE Linux Enterprise Server 15 SP4 grpc Affected
SUSE Linux Enterprise Server 15 SP4 protobuf In progress
SUSE Linux Enterprise Server 15 SP4-LTSS abseil-cpp Released
SUSE Linux Enterprise Server 15 SP4-LTSS grpc Released
SUSE Linux Enterprise Server 15 SP4-LTSS protobuf Released
SUSE Linux Enterprise Server 15 SP4-LTSS re2 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 grpc Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 grpc Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 grpc Affected
Products past their end of life and not receiving proactive updates anymore.
SUSE Enterprise Storage 6 grpc Affected
SUSE Enterprise Storage 7 grpc Affected
SUSE Linux Enterprise Module for Public Cloud 15 SP1 grpc Affected
SUSE Linux Enterprise Module for Public Cloud 15 SP2 grpc Affected
SUSE Linux Enterprise Module for Public Cloud 15 SP3 grpc Affected
SUSE Linux Enterprise Real Time 15 SP4 grpc Affected
SUSE Linux Enterprise Server 15 SP1 grpc Affected
SUSE Linux Enterprise Server 15 SP3-BCL grpc Affected
SUSE Manager Proxy 4.0 grpc Affected
SUSE Manager Proxy 4.1 grpc Affected
SUSE Manager Proxy 4.2 grpc Affected
SUSE Manager Retail Branch Server 4.0 grpc Affected
SUSE Manager Retail Branch Server 4.1 grpc Affected
SUSE Manager Retail Branch Server 4.2 grpc Affected
SUSE Manager Server 4.0 grpc Affected
SUSE Manager Server 4.1 grpc Affected
SUSE Manager Server 4.2 grpc Affected
openSUSE Leap 15.4 grpc Released
openSUSE Leap 15.4 python-grpcio Released
Products at an unknown state of their lifecycle.
SUSE Linux Enterprise Desktop 15 SP4-LTSS abseil-cpp Released
SUSE Linux Enterprise Desktop 15 SP4-LTSS grpc Released
SUSE Linux Enterprise Desktop 15 SP4-LTSS protobuf Released
SUSE Linux Enterprise Desktop 15 SP4-LTSS re2 Released


SUSE Timeline for this CVE

CVE page created: Wed Sep 13 20:02:58 2023
CVE page last modified: Wed Feb 21 15:38:35 2024