Upstream information

CVE-2023-4751 at MITRE

Description

Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1331.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1214921 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • gvim >= 9.0.1894-1.1
  • vim >= 9.0.1894-1.1
  • vim-data >= 9.0.1894-1.1
  • vim-data-common >= 9.0.1894-1.1
  • vim-small >= 9.0.1894-1.1
  • xxd >= 9.0.1894-1.1
Patchnames:
openSUSE Tumbleweed GA gvim-9.0.1894-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SLES15-SP5-CHOST-BYOS-Aliyun vim Already fixed
SLES15-SP5-CHOST-BYOS-Azure vim Already fixed
SLES15-SP5-CHOST-BYOS-EC2 vim Already fixed
SLES15-SP5-CHOST-BYOS-GCE vim Already fixed
SLES15-SP5-CHOST-BYOS-SAP-CCloud vim Already fixed
SUSE Enterprise Storage 7.1 vim Already fixed
SUSE Linux Enterprise Desktop 15 SP5 vim Already fixed
SUSE Linux Enterprise High Performance Computing 12 SP5 vim Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP5 vim Already fixed
SUSE Linux Enterprise Micro 5.1 vim Already fixed
SUSE Linux Enterprise Micro 5.2 vim Already fixed
SUSE Linux Enterprise Micro 5.3 vim Already fixed
SUSE Linux Enterprise Micro 5.4 vim Already fixed
SUSE Linux Enterprise Micro 5.5 vim Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP5 vim Already fixed
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 vim Already fixed
SUSE Linux Enterprise Real Time 15 SP3 vim Already fixed
SUSE Linux Enterprise Server 12 SP5 vim Already fixed
SUSE Linux Enterprise Server 12-LTSS vim Already fixed
SUSE Linux Enterprise Server 15 SP5 vim Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 vim Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP4 vim Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP5 vim Already fixed
SUSE Manager Proxy 4.3 vim Already fixed
SUSE Manager Retail Branch Server 4.3 vim Already fixed
SUSE Manager Server 4.3 vim Already fixed
Products under Long Term Service Pack support and receiving important and critical security fixes.
SLES15-EC2-CHOST-HVM-BYOS vim Already fixed
SLES15-SP1-CHOST-BYOS-Azure vim Already fixed
SLES15-SP1-CHOST-BYOS-EC2 vim Already fixed
SLES15-SP1-CHOST-BYOS-GCE vim Already fixed
SLES15-SP2-CHOST-BYOS-Aliyun vim Already fixed
SLES15-SP2-CHOST-BYOS-Azure vim Already fixed
SLES15-SP2-CHOST-BYOS-EC2 vim Already fixed
SLES15-SP2-CHOST-BYOS-GCE vim Already fixed
SLES15-SP3-CHOST-BYOS-Aliyun vim Already fixed
SLES15-SP3-CHOST-BYOS-Azure vim Already fixed
SLES15-SP3-CHOST-BYOS-EC2 vim Already fixed
SLES15-SP3-CHOST-BYOS-GCE vim Already fixed
SLES15-SP3-CHOST-BYOS-SAP-CCloud vim Already fixed
SLES15-SP4-CHOST-BYOS vim Already fixed
SLES15-SP4-CHOST-BYOS-Aliyun vim Already fixed
SLES15-SP4-CHOST-BYOS-Azure vim Already fixed
SLES15-SP4-CHOST-BYOS-EC2 vim Already fixed
SLES15-SP4-CHOST-BYOS-GCE vim Already fixed
SLES15-SP4-CHOST-BYOS-SAP-CCloud vim Already fixed
SUSE Linux Enterprise Desktop 15 SP4 vim Already fixed
SUSE Linux Enterprise High Performance Computing 15 vim Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1 vim Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS vim Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS vim Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2 vim Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS vim Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS vim Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3 vim Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS vim Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS vim Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4 vim Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS vim Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS vim Already fixed
SUSE Linux Enterprise High Performance Computing 15-ESPOS vim Already fixed
SUSE Linux Enterprise High Performance Computing 15-LTSS vim Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP2 vim Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP3 vim Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP4 vim Already fixed
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 vim Already fixed
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 vim Already fixed
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 vim Already fixed
SUSE Linux Enterprise Server 12 SP2-BCL vim Already fixed
SUSE Linux Enterprise Server 15 SP2 vim Already fixed
SUSE Linux Enterprise Server 15 SP2-LTSS vim Already fixed
SUSE Linux Enterprise Server 15 SP3 vim Already fixed
SUSE Linux Enterprise Server 15 SP3-LTSS vim Already fixed
SUSE Linux Enterprise Server 15 SP4 vim Already fixed
SUSE Linux Enterprise Server 15 SP4-LTSS vim Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 vim Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP1 vim Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP2 vim Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP3 vim Already fixed
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 vim Already fixed
SUSE CaaS Platform 3.0 vim Already fixed
SUSE CaaS Platform 4.0 vim Already fixed
SUSE Enterprise Storage 6 vim Already fixed
SUSE Enterprise Storage 7 vim Already fixed
SUSE Linux Enterprise Desktop 12 vim Already fixed
SUSE Linux Enterprise Desktop 12 SP1 vim Already fixed
SUSE Linux Enterprise Desktop 12 SP2 vim Already fixed
SUSE Linux Enterprise Desktop 12 SP3 vim Already fixed
SUSE Linux Enterprise Desktop 12 SP4 vim Already fixed
SUSE Linux Enterprise Desktop 15 vim Already fixed
SUSE Linux Enterprise Desktop 15 SP1 vim Already fixed
SUSE Linux Enterprise Desktop 15 SP2 vim Already fixed
SUSE Linux Enterprise Desktop 15 SP3 vim Already fixed
SUSE Linux Enterprise Micro 5.0 vim Already fixed
SUSE Linux Enterprise Module for Basesystem 15 vim Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP1 vim Already fixed
SUSE Linux Enterprise Module for Desktop Applications 15 vim Already fixed
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 vim Already fixed
SUSE Linux Enterprise Real Time 15 SP2 vim Already fixed
SUSE Linux Enterprise Real Time 15 SP4 vim Already fixed
SUSE Linux Enterprise Server 11 SP3 vim Affected
SUSE Linux Enterprise Server 11 SP3-LTSS vim Affected
SUSE Linux Enterprise Server 11 SP4 vim Affected
SUSE Linux Enterprise Server 11 SP4 LTSS vim Affected
SUSE Linux Enterprise Server 11 SP4-LTSS vim Affected
SUSE Linux Enterprise Server 12 vim Already fixed
SUSE Linux Enterprise Server 12 SP1 vim Already fixed
SUSE Linux Enterprise Server 12 SP1-LTSS vim Already fixed
SUSE Linux Enterprise Server 12 SP2 vim Already fixed
SUSE Linux Enterprise Server 12 SP2-ESPOS vim Already fixed
SUSE Linux Enterprise Server 12 SP2-LTSS vim Already fixed
SUSE Linux Enterprise Server 12 SP3 vim Already fixed
SUSE Linux Enterprise Server 12 SP3-BCL vim Already fixed
SUSE Linux Enterprise Server 12 SP3-ESPOS vim Already fixed
SUSE Linux Enterprise Server 12 SP3-LTSS vim Already fixed
SUSE Linux Enterprise Server 12 SP4 vim Already fixed
SUSE Linux Enterprise Server 12 SP4-ESPOS vim Already fixed
SUSE Linux Enterprise Server 12 SP4-LTSS vim Already fixed
SUSE Linux Enterprise Server 15 vim Already fixed
SUSE Linux Enterprise Server 15 SP1 vim Already fixed
SUSE Linux Enterprise Server 15 SP1-BCL vim Already fixed
SUSE Linux Enterprise Server 15 SP1-LTSS vim Already fixed
SUSE Linux Enterprise Server 15 SP2-BCL vim Already fixed
SUSE Linux Enterprise Server 15 SP3-BCL vim Already fixed
SUSE Linux Enterprise Server 15-LTSS vim Already fixed
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 vim Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP1 vim Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP2 vim Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP3 vim Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP4 vim Already fixed
SUSE Manager Proxy 4.0 vim Already fixed
SUSE Manager Proxy 4.1 vim Already fixed
SUSE Manager Proxy 4.2 vim Already fixed
SUSE Manager Retail Branch Server 4.0 vim Already fixed
SUSE Manager Retail Branch Server 4.1 vim Already fixed
SUSE Manager Retail Branch Server 4.2 vim Already fixed
SUSE Manager Server 4.0 vim Already fixed
SUSE Manager Server 4.1 vim Already fixed
SUSE Manager Server 4.2 vim Already fixed
SUSE OpenStack Cloud 7 vim Already fixed
SUSE OpenStack Cloud 8 vim Already fixed
SUSE OpenStack Cloud 9 vim Already fixed
SUSE OpenStack Cloud Crowbar 8 vim Already fixed
SUSE OpenStack Cloud Crowbar 9 vim Already fixed
Container Status
bci/dotnet-aspnet:5.0
bci/dotnet-runtime:5.0
bci/dotnet-sdk:5.0
ses/7.1/ceph/haproxy
suse/sle-micro/5.0/toolbox
suse/sle-micro/5.1/toolbox
suse/sle-micro/5.2/toolbox
suse/sle-micro/5.3/toolbox
suse/sle-micro/5.4/toolbox
suse/sle-micro/5.5/toolbox
suse/sles/15.2/virt-launcher:0.38.1
suse/sles/15.3/virt-launcher:0.45.0
suse/sles/15.4/virt-launcher:0.49.0
vimAlready fixed


SUSE Timeline for this CVE

CVE page created: Sun Sep 3 22:00:07 2023
CVE page last modified: Thu Feb 22 17:22:54 2024