Upstream information

CVE-2022-25883 at MITRE

Description

Versions of the package semver before 7.5.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the function new Range, when untrusted user data is provided as a range.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.3 4
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Attack Vector Network Local
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Low Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1212565 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Liberty Linux 8
  • nodejs >= 18.17.1-1.module+el8.8.0+19757+8ca87034
  • nodejs-devel >= 18.17.1-1.module+el8.8.0+19757+8ca87034
  • nodejs-docs >= 18.17.1-1.module+el8.8.0+19757+8ca87034
  • nodejs-full-i18n >= 18.17.1-1.module+el8.8.0+19757+8ca87034
  • nodejs-nodemon >= 3.0.1-1.module+el8.8.0+19764+7eed1ca3
  • nodejs-packaging >= 2021.06-4.module+el8.7.0+15582+19c314fa
  • nodejs-packaging-bundler >= 2021.06-4.module+el8.7.0+15582+19c314fa
  • npm >= 9.6.7-1.18.17.1.1.module+el8.8.0+19757+8ca87034
Patchnames:
RHSA-2023:5360
RHSA-2023:5362
SUSE Liberty Linux 9
  • nodejs >= 18.17.1-1.module+el9.2.0.z+19753+58118bc0
  • nodejs-devel >= 18.17.1-1.module+el9.2.0.z+19753+58118bc0
  • nodejs-docs >= 18.17.1-1.module+el9.2.0.z+19753+58118bc0
  • nodejs-full-i18n >= 18.17.1-1.module+el9.2.0.z+19753+58118bc0
  • nodejs-nodemon >= 3.0.1-1.module+el9.2.0.z+19753+58118bc0
  • nodejs-packaging >= 2021.06-4.module+el9.1.0+15718+e52ec601
  • nodejs-packaging-bundler >= 2021.06-4.module+el9.1.0+15718+e52ec601
  • npm >= 9.6.7-1.18.17.1.1.module+el9.2.0.z+19753+58118bc0
Patchnames:
RHSA-2023:5363


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 nodejs12 Not affected
SUSE Enterprise Storage 7.1 nodejs14 Not affected
SUSE Enterprise Storage 7.1 nodejs16 Not affected
SUSE Linux Enterprise High Performance Computing 12 nodejs10 Unsupported
SUSE Linux Enterprise High Performance Computing 12 nodejs12 Unsupported
SUSE Linux Enterprise High Performance Computing 12 nodejs14 Unsupported
SUSE Linux Enterprise High Performance Computing 12 nodejs16 Unsupported
SUSE Linux Enterprise High Performance Computing 12 nodejs18 Not affected
SUSE Linux Enterprise High Performance Computing 12 nodejs4 Unsupported
SUSE Linux Enterprise High Performance Computing 12 nodejs6 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP5 nodejs18 Not affected
SUSE Linux Enterprise Micro 5.1 cockpit Not affected
SUSE Linux Enterprise Micro 5.1 cockpit-podman Not affected
SUSE Linux Enterprise Micro 5.2 cockpit Not affected
SUSE Linux Enterprise Micro 5.2 cockpit-machines Not affected
SUSE Linux Enterprise Micro 5.2 cockpit-podman Not affected
SUSE Linux Enterprise Micro 5.2 cockpit-tukit Not affected
SUSE Linux Enterprise Micro 5.3 cockpit Not affected
SUSE Linux Enterprise Micro 5.3 cockpit-machines Not affected
SUSE Linux Enterprise Micro 5.3 cockpit-podman Not affected
SUSE Linux Enterprise Micro 5.3 cockpit-tukit Not affected
SUSE Linux Enterprise Micro 5.4 cockpit Not affected
SUSE Linux Enterprise Micro 5.4 cockpit-machines Not affected
SUSE Linux Enterprise Micro 5.4 cockpit-podman Not affected
SUSE Linux Enterprise Micro 5.4 cockpit-tukit Not affected
SUSE Linux Enterprise Micro 5.5 cockpit Ignore
SUSE Linux Enterprise Micro 5.5 cockpit-machines Ignore
SUSE Linux Enterprise Micro 5.5 cockpit-podman Ignore
SUSE Linux Enterprise Micro 5.5 cockpit-tukit Ignore
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs10 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs12 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs14 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs16 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs18 Not affected
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs4 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs6 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 15 SP5 nodejs18 Not affected
SUSE Linux Enterprise Server 12 SP5 nodejs10 Unsupported
SUSE Linux Enterprise Server 12 SP5 nodejs12 Unsupported
SUSE Linux Enterprise Server 12 SP5 nodejs14 Unsupported
SUSE Linux Enterprise Server 12 SP5 nodejs16 Unsupported
SUSE Linux Enterprise Server 12 SP5 nodejs18 Not affected
SUSE Linux Enterprise Server 12 SP5 nodejs4 Unsupported
SUSE Linux Enterprise Server 12 SP5 nodejs6 Unsupported
SUSE Linux Enterprise Server 15 SP5 nodejs18 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 nodejs10 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP5 nodejs12 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP5 nodejs14 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP5 nodejs16 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP5 nodejs18 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 nodejs4 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP5 nodejs6 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP4 nodejs16 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 nodejs18 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 nodejs18 Not affected
SUSE Manager Proxy 4.3 nodejs16 Not affected
SUSE Manager Proxy 4.3 nodejs18 Not affected
SUSE Manager Retail Branch Server 4.3 nodejs16 Not affected
SUSE Manager Retail Branch Server 4.3 nodejs18 Not affected
SUSE Manager Server 4.3 nodejs16 Not affected
SUSE Manager Server 4.3 nodejs18 Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 nodejs10 Unsupported
SUSE Linux Enterprise High Performance Computing 15 nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1 nodejs10 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1 nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS nodejs10 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS nodejs10 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2 nodejs10 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2 nodejs12 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 nodejs14 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS nodejs10 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS nodejs12 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS nodejs14 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS nodejs10 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS nodejs12 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS nodejs14 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3 nodejs12 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 nodejs14 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 nodejs16 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS nodejs12 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS nodejs14 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS nodejs16 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS nodejs12 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS nodejs14 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS nodejs16 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 nodejs16 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 nodejs18 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS nodejs16 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS nodejs18 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS nodejs16 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS nodejs18 Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS nodejs10 Unsupported
SUSE Linux Enterprise High Performance Computing 15-ESPOS nodejs8 Unsupported
SUSE Linux Enterprise High Performance Computing 15-LTSS nodejs10 Unsupported
SUSE Linux Enterprise High Performance Computing 15-LTSS nodejs8 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 nodejs10 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 nodejs12 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 nodejs14 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP2 nodejs8 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 15 SP3 nodejs12 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP3 nodejs14 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP3 nodejs16 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP4 nodejs16 Not affected
SUSE Linux Enterprise Module for Web and Scripting 15 SP4 nodejs18 Not affected
SUSE Linux Enterprise Server 15 SP2 nodejs10 Unsupported
SUSE Linux Enterprise Server 15 SP2 nodejs12 Not affected
SUSE Linux Enterprise Server 15 SP2 nodejs14 Not affected
SUSE Linux Enterprise Server 15 SP2 nodejs8 Unsupported
SUSE Linux Enterprise Server 15 SP2-LTSS nodejs10 Unsupported
SUSE Linux Enterprise Server 15 SP2-LTSS nodejs12 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS nodejs14 Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS nodejs8 Unsupported
SUSE Linux Enterprise Server 15 SP3 nodejs12 Not affected
SUSE Linux Enterprise Server 15 SP3 nodejs14 Not affected
SUSE Linux Enterprise Server 15 SP3 nodejs16 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS nodejs12 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS nodejs14 Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS nodejs16 Not affected
SUSE Linux Enterprise Server 15 SP4 nodejs16 Not affected
SUSE Linux Enterprise Server 15 SP4 nodejs18 Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS nodejs16 Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS nodejs18 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 nodejs10 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 nodejs8 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP1 nodejs10 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP1 nodejs8 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 nodejs10 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 nodejs12 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 nodejs14 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 nodejs8 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP3 nodejs12 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 nodejs14 Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 nodejs16 Not affected
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 nodejs10 Unsupported
SUSE CaaS Platform 4.0 nodejs8 Unsupported
SUSE Enterprise Storage 4 nodejs4 Unsupported
SUSE Enterprise Storage 4 nodejs6 Unsupported
SUSE Enterprise Storage 6 nodejs10 Unsupported
SUSE Enterprise Storage 6 nodejs8 Unsupported
SUSE Enterprise Storage 7 nodejs10 Unsupported
SUSE Enterprise Storage 7 nodejs12 Not affected
SUSE Enterprise Storage 7 nodejs14 Not affected
SUSE Enterprise Storage 7 nodejs8 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 15 nodejs10 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 15 nodejs8 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 15 SP1 nodejs10 Unsupported
SUSE Linux Enterprise Module for Web and Scripting 15 SP1 nodejs8 Unsupported
SUSE Linux Enterprise Server 12 nodejs10 Unsupported
SUSE Linux Enterprise Server 12 nodejs12 Unsupported
SUSE Linux Enterprise Server 12 nodejs14 Unsupported
SUSE Linux Enterprise Server 12 nodejs16 Unsupported
SUSE Linux Enterprise Server 12 nodejs18 Not affected
SUSE Linux Enterprise Server 12 nodejs4 Unsupported
SUSE Linux Enterprise Server 12 nodejs6 Unsupported
SUSE Linux Enterprise Server 12 SP3 nodejs10 Unsupported
SUSE Linux Enterprise Server 12 SP3 nodejs12 Unsupported
SUSE Linux Enterprise Server 12 SP3 nodejs14 Unsupported
SUSE Linux Enterprise Server 12 SP3 nodejs16 Unsupported
SUSE Linux Enterprise Server 12 SP3 nodejs18 Not affected
SUSE Linux Enterprise Server 12 SP3 nodejs4 Unsupported
SUSE Linux Enterprise Server 12 SP3 nodejs6 Unsupported
SUSE Linux Enterprise Server 12 SP4 nodejs10 Unsupported
SUSE Linux Enterprise Server 12 SP4 nodejs12 Unsupported
SUSE Linux Enterprise Server 12 SP4 nodejs14 Unsupported
SUSE Linux Enterprise Server 12 SP4 nodejs16 Unsupported
SUSE Linux Enterprise Server 12 SP4 nodejs18 Not affected
SUSE Linux Enterprise Server 12 SP4 nodejs4 Unsupported
SUSE Linux Enterprise Server 12 SP4 nodejs6 Unsupported
SUSE Linux Enterprise Server 15 nodejs10 Unsupported
SUSE Linux Enterprise Server 15 nodejs8 Unsupported
SUSE Linux Enterprise Server 15 SP1 nodejs10 Unsupported
SUSE Linux Enterprise Server 15 SP1 nodejs8 Unsupported
SUSE Linux Enterprise Server 15 SP1-BCL nodejs10 Unsupported
SUSE Linux Enterprise Server 15 SP1-BCL nodejs8 Unsupported
SUSE Linux Enterprise Server 15 SP1-LTSS nodejs10 Unsupported
SUSE Linux Enterprise Server 15 SP1-LTSS nodejs8 Unsupported
SUSE Linux Enterprise Server 15 SP2-BCL nodejs10 Unsupported
SUSE Linux Enterprise Server 15 SP2-BCL nodejs12 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL nodejs14 Not affected
SUSE Linux Enterprise Server 15 SP2-BCL nodejs8 Unsupported
SUSE Linux Enterprise Server 15 SP3-BCL nodejs12 Not affected
SUSE Linux Enterprise Server 15 SP3-BCL nodejs14 Not affected
SUSE Linux Enterprise Server 15 SP3-BCL nodejs16 Not affected
SUSE Linux Enterprise Server 15-LTSS nodejs10 Unsupported
SUSE Linux Enterprise Server 15-LTSS nodejs8 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 nodejs10 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 nodejs12 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 nodejs14 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 nodejs16 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 nodejs18 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 nodejs4 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 nodejs6 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nodejs10 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nodejs12 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nodejs14 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nodejs16 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nodejs18 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nodejs4 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nodejs6 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nodejs10 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nodejs12 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nodejs14 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nodejs16 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nodejs18 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nodejs4 Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nodejs6 Unsupported
SUSE Manager Proxy 4.0 nodejs10 Unsupported
SUSE Manager Proxy 4.0 nodejs8 Unsupported
SUSE Manager Proxy 4.1 nodejs10 Unsupported
SUSE Manager Proxy 4.1 nodejs12 Not affected
SUSE Manager Proxy 4.1 nodejs14 Not affected
SUSE Manager Proxy 4.1 nodejs8 Unsupported
SUSE Manager Proxy 4.2 nodejs12 Not affected
SUSE Manager Proxy 4.2 nodejs14 Not affected
SUSE Manager Proxy 4.2 nodejs16 Not affected
SUSE Manager Retail Branch Server 4.0 nodejs10 Unsupported
SUSE Manager Retail Branch Server 4.0 nodejs8 Unsupported
SUSE Manager Retail Branch Server 4.1 nodejs10 Unsupported
SUSE Manager Retail Branch Server 4.1 nodejs12 Not affected
SUSE Manager Retail Branch Server 4.1 nodejs14 Not affected
SUSE Manager Retail Branch Server 4.1 nodejs8 Unsupported
SUSE Manager Retail Branch Server 4.2 nodejs12 Not affected
SUSE Manager Retail Branch Server 4.2 nodejs14 Not affected
SUSE Manager Retail Branch Server 4.2 nodejs16 Not affected
SUSE Manager Server 4.0 nodejs10 Unsupported
SUSE Manager Server 4.0 nodejs8 Unsupported
SUSE Manager Server 4.1 nodejs10 Unsupported
SUSE Manager Server 4.1 nodejs12 Not affected
SUSE Manager Server 4.1 nodejs14 Not affected
SUSE Manager Server 4.1 nodejs8 Unsupported
SUSE Manager Server 4.2 nodejs12 Not affected
SUSE Manager Server 4.2 nodejs14 Not affected
SUSE Manager Server 4.2 nodejs16 Not affected
SUSE OpenStack Cloud 7 nodejs6 Unsupported
SUSE OpenStack Cloud Crowbar 8 nodejs6 Unsupported
SUSE OpenStack Cloud Crowbar 9 nodejs6 Unsupported
Container Status
bci/node:12 nodejs12Not affected
bci/node:14 nodejs14Not affected
bci/node:16
bci/nodejs
nodejs16Not affected
bci/node:18
bci/nodejs
nodejs18Not affected


SUSE Timeline for this CVE

CVE page created: Wed Jun 21 08:00:20 2023
CVE page last modified: Fri Apr 19 19:01:21 2024