Upstream information

CVE-2021-32618 at MITRE

Description

The Python "Flask-Security-Too" package is used for adding security features to your Flask application. It is an is an independently maintained version of Flask-Security based on the 3.0.0 version of Flask-Security. All versions of Flask-Security-Too allow redirects after many successful views (e.g. /login) by honoring the ?next query param. There is code in FS to validate that the url specified in the next parameter is either relative OR has the same netloc (network location) as the requesting URL. This check utilizes Pythons urlsplit library. However many browsers are very lenient on the kind of URL they accept and 'fill in the blanks' when presented with a possibly incomplete URL. As a concrete example - setting http://login?next=\\\github.com will pass FS's relative URL check however many browsers will gladly convert this to http://github.com. Thus an attacker could send such a link to an unwitting user, using a legitimate site and have it redirect to whatever site they want. This is considered a low severity due to the fact that if Werkzeug is used (which is very common with Flask applications) as the WSGI layer, it by default ALWAYS ensures that the Location header is absolute - thus making this attack vector mute. It is possible for application writers to modify this default behavior by setting the 'autocorrect_location_header=False`.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.1 5.4
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Changed Unchanged
Confidentiality Impact Low Low
Integrity Impact Low Low
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1186190 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7 python-Flask-Security-Too Released
SUSE Enterprise Storage 7.1 python-Flask-Security-Too Released
SUSE Linux Enterprise Desktop 15 SP4 python-Flask-Security-Too Released
SUSE Linux Enterprise Desktop 15 SP5 python-Flask-Security-Too Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 python-Flask-Security-Too Released
SUSE Linux Enterprise High Performance Computing 15 SP5 python-Flask-Security-Too Affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 python-Flask-Security-Too Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 python-Flask-Security-Too Affected
SUSE Linux Enterprise Real Time 15 SP3 python-Flask-Security-Too Affected
SUSE Linux Enterprise Server 15 SP4 python-Flask-Security-Too Released
SUSE Linux Enterprise Server 15 SP5 python-Flask-Security-Too Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 python-Flask-Security-Too Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 python-Flask-Security-Too Affected
SUSE Manager Proxy 4.2 python-Flask-Security-Too Released
SUSE Manager Proxy 4.3 python-Flask-Security-Too Released
SUSE Manager Retail Branch Server 4.2 python-Flask-Security-Too Released
SUSE Manager Retail Branch Server 4.3 python-Flask-Security-Too Released
SUSE Manager Server 4.2 python-Flask-Security-Too Released
SUSE Manager Server 4.3 python-Flask-Security-Too Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP1 python-Flask-Security Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS python-Flask-Security Released
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS python-Flask-Security Released
SUSE Linux Enterprise High Performance Computing 15 SP2 python-Flask-Security-Too Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS python-Flask-Security-Too Released
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS python-Flask-Security-Too Released
SUSE Linux Enterprise High Performance Computing 15 SP3 python-Flask-Security-Too Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS python-Flask-Security-Too Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS python-Flask-Security-Too Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 python-Flask-Security Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 python-Flask-Security-Too Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 python-Flask-Security-Too Released
SUSE Linux Enterprise Server 15 SP1 python-Flask-Security Affected
SUSE Linux Enterprise Server 15 SP1-LTSS python-Flask-Security Released
SUSE Linux Enterprise Server 15 SP2 python-Flask-Security-Too Affected
SUSE Linux Enterprise Server 15 SP2-LTSS python-Flask-Security-Too Released
SUSE Linux Enterprise Server 15 SP3 python-Flask-Security-Too Released
SUSE Linux Enterprise Server 15 SP3-LTSS python-Flask-Security-Too Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 python-Flask-Security Released
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 python-Flask-Security-Too Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 python-Flask-Security Released
SUSE Linux Enterprise Server for SAP Applications 15 SP2 python-Flask-Security-Too Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 python-Flask-Security-Too Released
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 python-Flask-Security Released
SUSE CaaS Platform 4.5 python-Flask-Security-Too Affected
SUSE Enterprise Storage 6 python-Flask-Security Released
SUSE Linux Enterprise Desktop 15 SP1 python-Flask-Security Affected
SUSE Linux Enterprise Desktop 15 SP2 python-Flask-Security-Too Affected
SUSE Linux Enterprise Desktop 15 SP3 python-Flask-Security-Too Released
SUSE Linux Enterprise Real Time 15 SP2 python-Flask-Security-Too Affected
SUSE Linux Enterprise Server 15 SP1-BCL python-Flask-Security Affected
SUSE Linux Enterprise Server 15 SP2-BCL python-Flask-Security-Too Affected
SUSE Linux Enterprise Server 15 SP3-BCL python-Flask-Security-Too Affected
SUSE Manager Proxy 4.0 python-Flask-Security Affected
SUSE Manager Proxy 4.1 python-Flask-Security-Too Affected
SUSE Manager Retail Branch Server 4.0 python-Flask-Security Affected
SUSE Manager Retail Branch Server 4.1 python-Flask-Security-Too Affected
SUSE Manager Server 4.0 python-Flask-Security Affected
SUSE Manager Server 4.1 python-Flask-Security-Too Affected


SUSE Timeline for this CVE

CVE page created: Tue May 18 03:04:35 2021
CVE page last modified: Wed May 17 18:43:27 2023