Upstream information

CVE-2021-27918 at MITRE

Description

encoding/xml in Go before 1.15.9 and 1.16.x before 1.16.1 has an infinite loop if a custom TokenReader (for xml.NewTokenDecoder) returns EOF in the middle of an element. This can occur in the Decode, DecodeElement, or Skip method.

SUSE information

Overall state of this security issue: Analysis

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1183333 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform 4.0
  • go1.15 >= 1.15.10-1.25.1
  • go1.15-doc >= 1.15.10-1.25.1
  • go1.15-race >= 1.15.10-1.25.1
Patchnames:
SUSE-SUSE-CAASP-4.0-2021-938
SUSE Enterprise Storage 6
  • go1.15 >= 1.15.10-1.25.1
  • go1.15-doc >= 1.15.10-1.25.1
  • go1.15-race >= 1.15.10-1.25.1
Patchnames:
SUSE-Storage-6-2021-938
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS
  • go1.15 >= 1.15.10-1.25.1
  • go1.15-doc >= 1.15.10-1.25.1
  • go1.15-race >= 1.15.10-1.25.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-938
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS
  • go1.15 >= 1.15.10-1.25.1
  • go1.15-doc >= 1.15.10-1.25.1
  • go1.15-race >= 1.15.10-1.25.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-938
SUSE Linux Enterprise Module for Development Tools 15 SP2
  • go1.15 >= 1.15.10-1.25.1
  • go1.15-doc >= 1.15.10-1.25.1
  • go1.15-race >= 1.15.10-1.25.1
  • go1.16 >= 1.16.2-1.8.1
  • go1.16-doc >= 1.16.2-1.8.1
  • go1.16-race >= 1.16.2-1.8.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP2-2021-937
SUSE-SLE-Module-Development-Tools-15-SP2-2021-938
SUSE Linux Enterprise Server 15 SP1-BCL
  • go1.15 >= 1.15.10-1.25.1
  • go1.15-doc >= 1.15.10-1.25.1
  • go1.15-race >= 1.15.10-1.25.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-BCL-2021-938
SUSE Linux Enterprise Server 15 SP1-LTSS
  • go1.15 >= 1.15.10-1.25.1
  • go1.15-doc >= 1.15.10-1.25.1
  • go1.15-race >= 1.15.10-1.25.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-938
SUSE Linux Enterprise Server for SAP Applications 15 SP1
  • go1.15 >= 1.15.10-1.25.1
  • go1.15-doc >= 1.15.10-1.25.1
  • go1.15-race >= 1.15.10-1.25.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP1-2021-938
SUSE Manager Proxy 4.0
  • go1.15 >= 1.15.10-1.25.1
  • go1.15-doc >= 1.15.10-1.25.1
  • go1.15-race >= 1.15.10-1.25.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-938
SUSE Manager Retail Branch Server 4.0
  • go1.15 >= 1.15.10-1.25.1
  • go1.15-doc >= 1.15.10-1.25.1
  • go1.15-race >= 1.15.10-1.25.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-938
SUSE Manager Server 4.0
  • go1.15 >= 1.15.10-1.25.1
  • go1.15-doc >= 1.15.10-1.25.1
  • go1.15-race >= 1.15.10-1.25.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-938
openSUSE Leap 15.2
  • go1.15 >= 1.15.10-lp152.14.1
  • go1.15-doc >= 1.15.10-lp152.14.1
  • go1.15-race >= 1.15.10-lp152.14.1
Patchnames:
openSUSE-2021-480


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE CaaS Platform 4.0 docker Affected
SUSE CaaS Platform 4.0 go1.14 Affected
SUSE CaaS Platform 4.0 go1.15 Released
SUSE Enterprise Storage 6 docker Affected
SUSE Enterprise Storage 6 go1.14 Affected
SUSE Enterprise Storage 6 go1.15 Released
SUSE Linux Enterprise High Performance Computing 15 LTSS docker Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS docker Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS go1.14 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 LTSS go1.15 Released
SUSE Linux Enterprise Module for Containers 12 docker Affected
SUSE Linux Enterprise Module for Containers 15 SP2 docker Affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 go1.14 Affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 go1.15 Released
SUSE Linux Enterprise Module for Development Tools 15 SP2 go1.16 Released
SUSE Linux Enterprise Server 15 LTSS docker Affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux docker Affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux go1.14 Affected
SUSE Linux Enterprise Server 15 SP1 Business Critical Linux go1.15 Released
SUSE Linux Enterprise Server 15 SP1 LTSS docker Affected
SUSE Linux Enterprise Server 15 SP1 LTSS go1.14 Affected
SUSE Linux Enterprise Server 15 SP1 LTSS go1.15 Released
SUSE Linux Enterprise Server ESPOS 15 docker Affected
SUSE Linux Enterprise Server for SAP Applications 15 docker Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 docker Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 go1.14 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 go1.15 Released
SUSE Manager Proxy 4.0 docker Affected
SUSE Manager Proxy 4.0 go1.14 Affected
SUSE Manager Proxy 4.0 go1.15 Released
SUSE Manager Retail Branch Server 4.0 docker Affected
SUSE Manager Retail Branch Server 4.0 go1.14 Affected
SUSE Manager Retail Branch Server 4.0 go1.15 Released
SUSE Manager Server 4.0 docker Affected
SUSE Manager Server 4.0 go1.14 Affected
SUSE Manager Server 4.0 go1.15 Released