Upstream information

CVE-2020-8185 at MITRE

Description

A denial of service vulnerability exists in Rails <6.0.3.2 that allowed an untrusted user to run any pending migrations on a Rails app running in production.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1173564 [RESOLVED / WORKSFORME]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 6
SUSE Linux Enterprise High Performance Computing 15 SP1
SUSE Linux Enterprise Server 15 SP1
SUSE Linux Enterprise Server for SAP Applications 15 SP1
SUSE Manager Proxy 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Server 4.0
  • rmt-server >= 2.6.5-3.18.1
  • rmt-server-config >= 2.6.5-3.18.1
  • rmt-server-pubcloud >= 2.6.5-3.18.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-SP1-2020-3160
SUSE-SLE-Module-Server-Applications-15-SP1-2020-3160
SUSE Enterprise Storage 7.1
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Linux Enterprise Server for SAP Applications 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • rmt-server >= 2.6.8-1.2
  • rmt-server-config >= 2.6.8-1.2
  • rmt-server-pubcloud >= 2.6.8-1.2
Patchnames:
SUSE Linux Enterprise Module for Public Cloud 15 SP3 GA rmt-server-pubcloud-2.6.8-1.2
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA rmt-server-2.6.8-1.2
SUSE Enterprise Storage 7
SUSE Linux Enterprise High Performance Computing 15 SP2
SUSE Linux Enterprise Server 15 SP2
SUSE Linux Enterprise Server for SAP Applications 15 SP2
SUSE Manager Proxy 4.1
SUSE Manager Retail Branch Server 4.1
SUSE Manager Server 4.1
  • rmt-server >= 2.6.5-3.3.1
  • rmt-server-config >= 2.6.5-3.3.1
  • rmt-server-pubcloud >= 2.6.5-3.3.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-SP2-2020-3036
SUSE-SLE-Module-Server-Applications-15-SP2-2020-3036
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • rmt-server >= 2.7.1-150400.1.7
  • rmt-server-config >= 2.7.1-150400.1.7
  • rmt-server-pubcloud >= 2.7.1-150400.1.7
Patchnames:
SUSE Linux Enterprise Module for Public Cloud 15 SP4 GA rmt-server-pubcloud-2.7.1-150400.1.7
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA rmt-server-2.7.1-150400.1.7
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Public Cloud 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • rmt-server-pubcloud >= 2.9-150500.1.4
Patchnames:
SUSE Linux Enterprise Module for Public Cloud 15 SP5 GA rmt-server-pubcloud-2.9-150500.1.4
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
  • rmt-server >= 2.6.5-3.34.1
  • rmt-server-config >= 2.6.5-3.34.1
Patchnames:
SUSE-SLE-Product-HPC-15-2020-3147
SUSE Linux Enterprise Module for Public Cloud 15 SP1
  • rmt-server-pubcloud >= 2.6.5-3.18.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-SP1-2020-3160
SUSE Linux Enterprise Module for Public Cloud 15 SP2
  • rmt-server-pubcloud >= 2.6.5-3.3.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-SP2-2020-3036
SUSE Linux Enterprise Module for Public Cloud 15 SP3
  • rmt-server-pubcloud >= 2.6.8-1.2
Patchnames:
SUSE Linux Enterprise Module for Public Cloud 15 SP3 GA rmt-server-pubcloud-2.6.8-1.2
SUSE Linux Enterprise Module for Public Cloud 15 SP4
  • rmt-server-pubcloud >= 2.7.1-150400.1.7
Patchnames:
SUSE Linux Enterprise Module for Public Cloud 15 SP4 GA rmt-server-pubcloud-2.7.1-150400.1.7
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • rmt-server >= 2.6.5-3.18.1
  • rmt-server-config >= 2.6.5-3.18.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP1-2020-3160
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • rmt-server >= 2.6.5-3.3.1
  • rmt-server-config >= 2.6.5-3.3.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP2-2020-3036
SUSE Linux Enterprise Module for Server Applications 15 SP3
  • rmt-server >= 2.6.8-1.2
  • rmt-server-config >= 2.6.8-1.2
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP3 GA rmt-server-2.6.8-1.2
SUSE Linux Enterprise Module for Server Applications 15 SP4
  • rmt-server >= 2.7.1-150400.1.7
  • rmt-server-config >= 2.7.1-150400.1.7
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP4 GA rmt-server-2.7.1-150400.1.7
SUSE Linux Enterprise Server 15-LTSS
  • rmt-server >= 2.6.5-3.34.1
  • rmt-server-config >= 2.6.5-3.34.1
Patchnames:
SUSE-SLE-Product-SLES-15-2020-3147
SUSE Linux Enterprise Server for SAP Applications 15
  • rmt-server >= 2.6.5-3.34.1
  • rmt-server-config >= 2.6.5-3.34.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-2020-3147
openSUSE Leap 15.1
  • rmt-server >= 2.6.5-lp151.2.18.2
  • rmt-server-config >= 2.6.5-lp151.2.18.2
  • rmt-server-pubcloud >= 2.6.5-lp151.2.18.2
Patchnames:
openSUSE-2020-2000
openSUSE Leap 15.2
  • rmt-server >= 2.6.5-lp152.2.3.1
  • rmt-server-config >= 2.6.5-lp152.2.3.1
  • rmt-server-pubcloud >= 2.6.5-lp152.2.3.1
Patchnames:
openSUSE-2020-1993
openSUSE Tumbleweed
  • rmt-server >= 2.6.13-1.1
  • rmt-server-config >= 2.6.13-1.1
  • rmt-server-pubcloud >= 2.6.13-1.1
  • ruby2.7-rubygem-actionpack-6.0 >= 6.0.4-1.2
  • ruby2.7-rubygem-actionview-6.0 >= 6.0.4-1.2
  • ruby3.0-rubygem-actionpack-6.0 >= 6.0.4-1.2
  • ruby3.0-rubygem-actionview-6.0 >= 6.0.4-1.2
  • ruby3.1-rubygem-actionpack-6.0 >= 6.0.4.4-1.1
  • ruby3.1-rubygem-actionview-6.0 >= 6.0.4.4-1.1
Patchnames:
openSUSE-Tumbleweed-2024-10589
openSUSE-Tumbleweed-2024-11318
openSUSE-Tumbleweed-2024-11321
openSUSE-Tumbleweed-2024-11821
openSUSE-Tumbleweed-2024-11823


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise High Availability Extension 15 SP5 rubygem-rails-5_1 Not affected
SUSE Linux Enterprise High Availability Extension 15 SP6 rubygem-rails-5_1 Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Availability Extension 15 SP2 rubygem-rails-5_1 Not affected
SUSE Linux Enterprise High Availability Extension 15 SP3 rubygem-rails-5_1 Not affected
SUSE Linux Enterprise High Availability Extension 15 SP4 rubygem-rails-5_1 Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 rmt-server Released
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS rmt-server Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS rmt-server Affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 rmt-server Released
SUSE Linux Enterprise Server 15 SP2 rmt-server Released
SUSE Linux Enterprise Server 15 SP2-LTSS rmt-server Affected
SUSE Linux Enterprise Server 15-ESPOS rmt-server Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 rmt-server Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 rmt-server Released
Products past their end of life and not receiving proactive updates anymore.
SUSE CaaS Platform 4.0 rmt-server Affected
SUSE Enterprise Storage 2.1 rubygem-rails-4_2 Not affected
SUSE Enterprise Storage 3 rubygem-rails-4_2 Not affected
SUSE Enterprise Storage 4 rubygem-rails-4_2 Not affected
SUSE Enterprise Storage 6 rmt-server Released
SUSE Enterprise Storage 7 rmt-server Released
SUSE Linux Enterprise High Availability Extension 15 rubygem-rails-5_1 Not affected
SUSE Linux Enterprise High Availability Extension 15 SP1 rubygem-rails-5_1 Not affected
SUSE Linux Enterprise High Performance Computing 15 rmt-server Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 rmt-server Released
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS rmt-server Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS rmt-server Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS rmt-server Released
SUSE Linux Enterprise High Performance Computing 15-LTSS rmt-server Released
SUSE Linux Enterprise Module for Public Cloud 15 SP1 rmt-server Released
SUSE Linux Enterprise Module for Public Cloud 15 SP2 rmt-server Released
SUSE Linux Enterprise Module for Server Applications 15 rmt-server Affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 rmt-server Released
SUSE Linux Enterprise Real Time 15 SP2 rmt-server Affected
SUSE Linux Enterprise Server 15 rmt-server Affected
SUSE Linux Enterprise Server 15 SP1 rmt-server Released
SUSE Linux Enterprise Server 15 SP1-BCL rmt-server Affected
SUSE Linux Enterprise Server 15 SP1-LTSS rmt-server Affected
SUSE Linux Enterprise Server 15 SP2-BCL rmt-server Affected
SUSE Linux Enterprise Server 15-LTSS rmt-server Released
SUSE Linux Enterprise Server for SAP Applications 15 rmt-server Released
SUSE Linux Enterprise Server for SAP Applications 15 SP1 rmt-server Released
SUSE Manager Proxy 4.0 rmt-server Released
SUSE Manager Proxy 4.1 rmt-server Released
SUSE Manager Retail Branch Server 4.0 rmt-server Released
SUSE Manager Retail Branch Server 4.1 rmt-server Released
SUSE Manager Server 4.0 rmt-server Released
SUSE Manager Server 4.1 rmt-server Released
SUSE OpenStack Cloud 6 rubygem-rails-4_2 Not affected
SUSE OpenStack Cloud 6-LTSS rubygem-rails-4_2 Not affected
SUSE OpenStack Cloud 7 rubygem-rails-4_2 Not affected
SUSE OpenStack Cloud Crowbar 8 rubygem-rails-4_2 Not affected
SUSE OpenStack Cloud Crowbar 9 rubygem-rails-4_2 Not affected


SUSE Timeline for this CVE

CVE page created: Tue Jun 30 12:24:00 2020
CVE page last modified: Mon Jun 17 11:30:36 2024