Upstream information

CVE-2020-27829 at MITRE

Description

A heap based buffer overflow in coders/tiff.c may result in program crash and denial of service in ImageMagick before 7.0.10-45.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Attack Vector Local
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1181697 [RESOLVED / UPSTREAM]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 ImageMagick Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 ImageMagick Not affected
SUSE Linux Enterprise Real Time 15 SP3 ImageMagick Not affected
SUSE Linux Enterprise Server 12 SP5 ImageMagick Not affected
SUSE Linux Enterprise Server 12-LTSS ImageMagick Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ImageMagick Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 ImageMagick Not affected
SUSE Linux Enterprise Workstation Extension 12 SP5 ImageMagick Not affected
SUSE Manager Proxy 4.2 ImageMagick Not affected
SUSE Manager Retail Branch Server 4.2 ImageMagick Not affected
SUSE Manager Server 4.2 ImageMagick Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 ImageMagick Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1 ImageMagick Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS ImageMagick Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS ImageMagick Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2 ImageMagick Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS ImageMagick Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS ImageMagick Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 ImageMagick Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS ImageMagick Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS ImageMagick Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS ImageMagick Unsupported
SUSE Linux Enterprise High Performance Computing 15-LTSS ImageMagick Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 ImageMagick Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP2 ImageMagick Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP3 ImageMagick Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP1 ImageMagick Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 ImageMagick Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 ImageMagick Not affected
SUSE Linux Enterprise Server 12 SP2-BCL ImageMagick Not affected
SUSE Linux Enterprise Server 15 SP1 ImageMagick Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS ImageMagick Unsupported
SUSE Linux Enterprise Server 15 SP2 ImageMagick Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS ImageMagick Not affected
SUSE Linux Enterprise Server 15 SP3 ImageMagick Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS ImageMagick Not affected
SUSE Linux Enterprise Server 15-ESPOS ImageMagick Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 ImageMagick Not affected
SUSE Linux Enterprise Server for SAP Applications 15 ImageMagick Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 ImageMagick Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 ImageMagick Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 ImageMagick Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 ImageMagick Not affected
SUSE CaaS Platform 4.0 ImageMagick Unsupported
SUSE Enterprise Storage 5 ImageMagick Not affected
SUSE Enterprise Storage 6 ImageMagick Not affected
SUSE Enterprise Storage 7 ImageMagick Not affected
SUSE Linux Enterprise Desktop 11 SP4 ImageMagick Not affected
SUSE Linux Enterprise Desktop 12 ImageMagick Not affected
SUSE Linux Enterprise Desktop 12 SP1 ImageMagick Not affected
SUSE Linux Enterprise Desktop 12 SP2 ImageMagick Not affected
SUSE Linux Enterprise Desktop 12 SP3 ImageMagick Not affected
SUSE Linux Enterprise Desktop 12 SP4 ImageMagick Not affected
SUSE Linux Enterprise Desktop 15 ImageMagick Unsupported
SUSE Linux Enterprise Desktop 15 SP1 ImageMagick Not affected
SUSE Linux Enterprise Desktop 15 SP2 ImageMagick Not affected
SUSE Linux Enterprise Desktop 15 SP3 ImageMagick Not affected
SUSE Linux Enterprise Module for Desktop Applications 15 ImageMagick Unsupported
SUSE Linux Enterprise Module for Development Tools 15 ImageMagick Unsupported
SUSE Linux Enterprise Point of Service 11 SP3 ImageMagick Not affected
SUSE Linux Enterprise Point of Service Image Server 12 SP2 ImageMagick Not affected
SUSE Linux Enterprise Real Time 15 SP2 ImageMagick Not affected
SUSE Linux Enterprise Server 11 SP3 ImageMagick Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS ImageMagick Not affected
SUSE Linux Enterprise Server 11 SP4 ImageMagick Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS ImageMagick Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS ImageMagick Not affected
SUSE Linux Enterprise Server 12 ImageMagick Not affected
SUSE Linux Enterprise Server 12 SP1 ImageMagick Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS ImageMagick Not affected
SUSE Linux Enterprise Server 12 SP2 ImageMagick Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS ImageMagick Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS ImageMagick Not affected
SUSE Linux Enterprise Server 12 SP3 ImageMagick Not affected
SUSE Linux Enterprise Server 12 SP3-BCL ImageMagick Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS ImageMagick Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS ImageMagick Not affected
SUSE Linux Enterprise Server 12 SP4 ImageMagick Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS ImageMagick Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS ImageMagick Not affected
SUSE Linux Enterprise Server 15 ImageMagick Unsupported
SUSE Linux Enterprise Server 15 SP1-BCL ImageMagick Unsupported
SUSE Linux Enterprise Server 15 SP2-BCL ImageMagick Not affected
SUSE Linux Enterprise Server 15 SP3-BCL ImageMagick Not affected
SUSE Linux Enterprise Server 15-LTSS ImageMagick Unsupported
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 ImageMagick Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 ImageMagick Not affected
SUSE Linux Enterprise Server for SAP Applications 12 ImageMagick Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 ImageMagick Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ImageMagick Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 ImageMagick Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ImageMagick Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 ImageMagick Not affected
SUSE Linux Enterprise Software Development Kit 12 ImageMagick Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 ImageMagick Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 ImageMagick Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 ImageMagick Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 ImageMagick Not affected
SUSE Linux Enterprise Workstation Extension 12 ImageMagick Not affected
SUSE Linux Enterprise Workstation Extension 12 SP1 ImageMagick Not affected
SUSE Linux Enterprise Workstation Extension 12 SP2 ImageMagick Not affected
SUSE Linux Enterprise Workstation Extension 12 SP3 ImageMagick Not affected
SUSE Linux Enterprise Workstation Extension 12 SP4 ImageMagick Not affected
SUSE Manager Proxy 4.0 ImageMagick Not affected
SUSE Manager Proxy 4.1 ImageMagick Not affected
SUSE Manager Retail Branch Server 4.0 ImageMagick Not affected
SUSE Manager Retail Branch Server 4.1 ImageMagick Not affected
SUSE Manager Server 4.0 ImageMagick Not affected
SUSE Manager Server 4.1 ImageMagick Not affected
SUSE OpenStack Cloud 7 ImageMagick Not affected
SUSE OpenStack Cloud 8 ImageMagick Not affected
SUSE OpenStack Cloud 9 ImageMagick Not affected
SUSE OpenStack Cloud Crowbar 8 ImageMagick Not affected
SUSE OpenStack Cloud Crowbar 9 ImageMagick Not affected


SUSE Timeline for this CVE

CVE page created: Sat Jan 30 02:07:40 2021
CVE page last modified: Mon Sep 11 20:49:37 2023