Upstream information

CVE-2019-7443 at MITRE

Description

KDE KAuth before 5.55 allows the passing of parameters with arbitrary types to helpers running as root over DBus via DBusHelperProxy.cpp. Certain types can cause crashes, and trigger the decoding of arbitrary images with dynamically loaded plugins. In other words, KAuth unintentionally causes this plugin code to run as root, which increases the severity of any possible exploitation of a plugin vulnerability.

SUSE information

SUSE Bugzilla entries: 1124863 [REOPENED], 1170293 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 12 SP1
  • kauth >= 5.20.0-11.2
  • kauth-debugsource >= 5.45.0-lp150.5.2
  • kauth-devel >= 5.20.0-11.2
  • kauth-devel-32bit >= 5.45.0-lp150.5.2
  • kcoreaddons >= 5.20.0-9.2
  • kcoreaddons-debugsource >= 5.20.0-9.2
  • kcoreaddons-devel >= 5.20.0-9.2
  • kcoreaddons-devel-debuginfo >= 5.20.0-9.2
  • kcoreaddons-lang >= 5.20.0-9.1
  • libKF5Auth5 >= 5.20.0-11.2
  • libKF5Auth5-32bit >= 5.45.0-lp150.5.2
  • libKF5Auth5-32bit-debuginfo >= 5.45.0-lp150.5.2
  • libKF5Auth5-debuginfo >= 5.45.0-lp150.5.2
  • libKF5Auth5-debuginfo-32bit >= 5.32.0-5.2
  • libKF5Auth5-lang >= 5.20.0-11.2
  • libKF5CoreAddons5 >= 5.20.0-9.2
  • libKF5CoreAddons5-debuginfo >= 5.20.0-9.2
  • libpolkit-qt5-1-1 >= 0.112.0-6.2
  • libpolkit-qt5-1-1-debuginfo >= 0.112.0-6.2
  • libpolkit-qt5-1-devel >= 0.112.0-6.2
  • polkit-qt5-1 >= 0.112.0-6.1
  • polkit-qt5-1-debugsource >= 0.112.0-6.2
SUSE Package Hub for SUSE Linux Enterprise 12 SP2
  • kauth >= 5.26.0-10.2
  • kauth-debugsource >= 5.26.0-10.2
  • kauth-devel >= 5.26.0-10.2
  • kauth-devel-32bit >= 5.45.0-lp150.5.2
  • kauth-devel-64bit >= 5.26.0-10.2
  • kcoreaddons >= 5.26.0-6.4
  • kcoreaddons-debugsource >= 5.26.0-6.4
  • kcoreaddons-devel >= 5.26.0-6.4
  • kcoreaddons-devel-64bit >= 5.26.0-6.4
  • kcoreaddons-devel-debuginfo >= 5.26.0-6.4
  • kcoreaddons-devel-debuginfo-64bit >= 5.26.0-6.4
  • kcoreaddons-lang >= 5.26.0-6.4
  • libKF5Auth5 >= 5.26.0-10.2
  • libKF5Auth5-32bit >= 5.45.0-lp150.5.2
  • libKF5Auth5-32bit-debuginfo >= 5.45.0-lp150.5.2
  • libKF5Auth5-64bit >= 5.26.0-10.2
  • libKF5Auth5-debuginfo >= 5.26.0-10.2
  • libKF5Auth5-debuginfo-32bit >= 5.32.0-5.2
  • libKF5Auth5-debuginfo-64bit >= 5.26.0-10.2
  • libKF5Auth5-lang >= 5.26.0-10.2
  • libKF5CoreAddons5 >= 5.26.0-6.4
  • libKF5CoreAddons5-64bit >= 5.26.0-6.4
  • libKF5CoreAddons5-debuginfo >= 5.26.0-6.4
  • libKF5CoreAddons5-debuginfo-64bit >= 5.26.0-6.4
  • libpolkit-qt5-1-1 >= 0.112.0-3.4
  • libpolkit-qt5-1-1-64bit >= 0.112.0-3.6
  • libpolkit-qt5-1-1-debuginfo >= 0.112.0-3.4
  • libpolkit-qt5-1-1-debuginfo-64bit >= 0.112.0-3.6
  • libpolkit-qt5-1-devel >= 0.112.0-3.4
  • libpolkit-qt5-1-devel-64bit >= 0.112.0-3.6
  • polkit-qt5-1 >= 0.112.0-3.6
  • polkit-qt5-1-debugsource >= 0.112.0-3.4
SUSE Package Hub for SUSE Linux Enterprise 12 SP3
  • extra-cmake-modules >= 5.32.0-7.2
  • kauth >= 5.32.0-6.2
  • kauth-debugsource >= 5.32.0-6.2
  • kauth-devel >= 5.32.0-6.2
  • kauth-devel-32bit >= 5.45.0-lp150.5.2
  • kauth-devel-64bit >= 5.32.0-6.2
  • kcoreaddons >= 5.32.0-8.2
  • kcoreaddons-debugsource >= 5.32.0-8.2
  • kcoreaddons-devel >= 5.32.0-8.2
  • kcoreaddons-devel-64bit >= 5.32.0-8.2
  • kcoreaddons-devel-debuginfo >= 5.32.0-8.2
  • kcoreaddons-devel-debuginfo-64bit >= 5.32.0-8.2
  • kcoreaddons-lang >= 5.32.0-8.2
  • libKF5Auth5 >= 5.32.0-6.2
  • libKF5Auth5-32bit >= 5.45.0-lp150.5.2
  • libKF5Auth5-32bit-debuginfo >= 5.45.0-lp150.5.2
  • libKF5Auth5-64bit >= 5.32.0-6.2
  • libKF5Auth5-debuginfo >= 5.32.0-6.2
  • libKF5Auth5-debuginfo-32bit >= 5.32.0-5.2
  • libKF5Auth5-debuginfo-64bit >= 5.32.0-6.2
  • libKF5Auth5-lang >= 5.32.0-6.2
  • libKF5CoreAddons5 >= 5.32.0-8.2
  • libKF5CoreAddons5-64bit >= 5.32.0-8.2
  • libKF5CoreAddons5-debuginfo >= 5.32.0-8.2
  • libKF5CoreAddons5-debuginfo-64bit >= 5.32.0-8.2
  • libpolkit-qt5-1-1 >= 0.112.0-5.2
  • libpolkit-qt5-1-1-64bit >= 0.112.0-5.2
  • libpolkit-qt5-1-1-debuginfo >= 0.112.0-5.2
  • libpolkit-qt5-1-1-debuginfo-64bit >= 0.112.0-5.2
  • libpolkit-qt5-1-devel >= 0.112.0-5.2
  • libpolkit-qt5-1-devel-64bit >= 0.112.0-5.2
  • polkit-qt5-1 >= 0.112.0-5.2
  • polkit-qt5-1-debugsource >= 0.112.0-5.2
openSUSE Leap 15.0
  • kauth >= 5.45.0-lp150.5.2
  • kauth-debugsource >= 5.45.0-lp150.5.2
  • kauth-devel >= 5.45.0-lp150.5.2
  • kauth-devel-32bit >= 5.45.0-lp150.5.2
  • libKF5Auth5 >= 5.45.0-lp150.5.2
  • libKF5Auth5-32bit >= 5.45.0-lp150.5.2
  • libKF5Auth5-32bit-debuginfo >= 5.45.0-lp150.5.2
  • libKF5Auth5-debuginfo >= 5.45.0-lp150.5.2
  • libKF5Auth5-debuginfo-32bit >= 5.32.0-5.2
  • libKF5Auth5-lang >= 5.45.0-lp150.5.2
Patchnames:
openSUSE-2019-242
openSUSE Leap 42.3
  • kauth >= 5.32.0-5.2
  • kauth-debugsource >= 5.32.0-5.2
  • kauth-devel >= 5.32.0-5.2
  • kauth-devel-32bit >= 5.32.0-5.2
  • libKF5Auth5 >= 5.32.0-5.2
  • libKF5Auth5-32bit >= 5.32.0-5.2
  • libKF5Auth5-debuginfo >= 5.32.0-5.2
  • libKF5Auth5-debuginfo-32bit >= 5.32.0-5.2
  • libKF5Auth5-lang >= 5.32.0-5.2
Patchnames:
openSUSE-2019-242