Upstream information

CVE-2019-3821 at MITRE

Description

A flaw was found in the way civetweb frontend was handling requests for ceph RGW server with SSL enabled. An unauthenticated attacker could create multiple connections to ceph RADOS gateway to exhaust file descriptors for ceph-radosgw service resulting in a remote denial of service.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1125080 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container caasp/v4/hyperkube:v1.17.4
Image caasp-hyperkube-image
  • ceph-common >= 14.2.1.468+g994fd9e0cc-3.3.2
  • libcephfs2 >= 14.2.1.468+g994fd9e0cc-3.3.2
  • librados2 >= 14.2.1.468+g994fd9e0cc-3.3.2
  • librbd1 >= 14.2.1.468+g994fd9e0cc-3.3.2
  • librgw2 >= 14.2.1.468+g994fd9e0cc-3.3.2
  • python3-ceph-argparse >= 14.2.1.468+g994fd9e0cc-3.3.2
  • python3-cephfs >= 14.2.1.468+g994fd9e0cc-3.3.2
  • python3-rados >= 14.2.1.468+g994fd9e0cc-3.3.2
  • python3-rbd >= 14.2.1.468+g994fd9e0cc-3.3.2
  • python3-rgw >= 14.2.1.468+g994fd9e0cc-3.3.2
SUSE Enterprise Storage 6
  • ceph >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-base >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-common >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-fuse >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-grafana-dashboards >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-mds >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-mgr >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-mgr-dashboard >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-mgr-diskprediction-local >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-mgr-rook >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-mon >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-osd >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-prometheus-alerts >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-radosgw >= 14.2.1.468+g994fd9e0cc-3.3.2
  • cephfs-shell >= 14.2.1.468+g994fd9e0cc-3.3.2
  • libcephfs2 >= 14.2.1.468+g994fd9e0cc-3.3.2
  • librados2 >= 14.2.1.468+g994fd9e0cc-3.3.2
  • librbd1 >= 14.2.1.468+g994fd9e0cc-3.3.2
  • librgw2 >= 14.2.1.468+g994fd9e0cc-3.3.2
  • python3-ceph-argparse >= 14.2.1.468+g994fd9e0cc-3.3.2
  • python3-cephfs >= 14.2.1.468+g994fd9e0cc-3.3.2
  • python3-rados >= 14.2.1.468+g994fd9e0cc-3.3.2
  • python3-rbd >= 14.2.1.468+g994fd9e0cc-3.3.2
  • python3-rgw >= 14.2.1.468+g994fd9e0cc-3.3.2
  • rbd-fuse >= 14.2.1.468+g994fd9e0cc-3.3.2
  • rbd-mirror >= 14.2.1.468+g994fd9e0cc-3.3.2
  • rbd-nbd >= 14.2.1.468+g994fd9e0cc-3.3.2
Patchnames:
SUSE-Storage-6-2019-2049
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • ceph >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-common >= 14.2.1.468+g994fd9e0cc-3.3.2
  • libcephfs-devel >= 14.2.1.468+g994fd9e0cc-3.3.2
  • libcephfs2 >= 14.2.1.468+g994fd9e0cc-3.3.2
  • librados-devel >= 14.2.1.468+g994fd9e0cc-3.3.2
  • librados2 >= 14.2.1.468+g994fd9e0cc-3.3.2
  • libradospp-devel >= 14.2.1.468+g994fd9e0cc-3.3.2
  • librbd-devel >= 14.2.1.468+g994fd9e0cc-3.3.2
  • librbd1 >= 14.2.1.468+g994fd9e0cc-3.3.2
  • librgw-devel >= 14.2.1.468+g994fd9e0cc-3.3.2
  • librgw2 >= 14.2.1.468+g994fd9e0cc-3.3.2
  • python3-ceph-argparse >= 14.2.1.468+g994fd9e0cc-3.3.2
  • python3-cephfs >= 14.2.1.468+g994fd9e0cc-3.3.2
  • python3-rados >= 14.2.1.468+g994fd9e0cc-3.3.2
  • python3-rbd >= 14.2.1.468+g994fd9e0cc-3.3.2
  • python3-rgw >= 14.2.1.468+g994fd9e0cc-3.3.2
  • rados-objclass-devel >= 14.2.1.468+g994fd9e0cc-3.3.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2049
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • ceph >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-base >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-fuse >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-grafana-dashboards >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-mds >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-mgr >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-mgr-dashboard >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-mgr-diskprediction-cloud >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-mgr-diskprediction-local >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-mgr-rook >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-mgr-ssh >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-mon >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-osd >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-radosgw >= 14.2.1.468+g994fd9e0cc-3.3.2
  • ceph-test >= 14.2.1.468+g994fd9e0cc-3.3.2
  • cephfs-shell >= 14.2.1.468+g994fd9e0cc-3.3.2
  • rbd-fuse >= 14.2.1.468+g994fd9e0cc-3.3.2
  • rbd-mirror >= 14.2.1.468+g994fd9e0cc-3.3.2
  • rbd-nbd >= 14.2.1.468+g994fd9e0cc-3.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2049


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications ceph Not affected
SUSE CaaS Platform 3.0 ceph Not affected
SUSE Container as a Service Platform 1.0 ceph Affected
SUSE Container as a Service Platform 2.0 ceph Not affected
SUSE Enterprise Storage 4 ceph Not affected
SUSE Enterprise Storage 5 ceph Not affected
SUSE Enterprise Storage 6 ceph Released
SUSE Linux Enterprise 15 Module for Basesystem ceph Not affected
SUSE Linux Enterprise 15-SP1 Module for Basesystem ceph Released
SUSE Linux Enterprise Desktop 12 SP3 ceph Not affected
SUSE Linux Enterprise Desktop 12 SP4 ceph Not affected
SUSE Linux Enterprise High Performance Computing 12 SP4 ceph Not affected
SUSE Linux Enterprise Server 11 SP3 ceph Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS ceph Not affected
SUSE Linux Enterprise Server 11 SP4 ceph Not affected
SUSE Linux Enterprise Server 12 LTSS ceph Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS ceph Not affected
SUSE Linux Enterprise Server 12 SP3 ceph Not affected
SUSE Linux Enterprise Server 12 SP4 ceph Not affected
SUSE Linux Enterprise Server for SAP Applications 12 ceph Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 ceph Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ceph Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 ceph Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 ceph Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 ceph Not affected