Upstream information

CVE-2018-14036 at MITRE

Description

Directory Traversal with ../ sequences occurs in AccountsService before 0.6.50 because of an insufficient path check in user_change_icon_file_authorized_cb() in user.c.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 4
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Access Vector Network Local
Access Complexity Low Low
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact None Low
Availability Impact None None
SUSE Bugzilla entries: 1099699 [NEW], 1101332 [RESOLVED / DUPLICATE], 1112694 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15
  • accountsservice >= 0.6.45-6.7.6
  • accountsservice-devel >= 0.6.45-6.7.6
  • accountsservice-lang >= 0.6.45-6.7.6
  • libaccountsservice0 >= 0.6.45-6.7.6
  • typelib-1_0-AccountsService-1_0 >= 0.6.45-6.7.6
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2018-2579
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • accountsservice >= 0.6.45-6.10.1
  • accountsservice-devel >= 0.6.45-6.10.1
  • accountsservice-lang >= 0.6.45-6.10.1
  • libaccountsservice0 >= 0.6.45-6.10.1
  • typelib-1_0-AccountsService-1_0 >= 0.6.45-6.10.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA accountsservice
openSUSE Leap 15.0
  • accountsservice >= 0.6.45-lp150.3.3.1
  • accountsservice-debuginfo >= 0.6.45-lp150.3.3.1
  • accountsservice-debugsource >= 0.6.45-lp150.3.3.1
  • accountsservice-devel >= 0.6.45-lp150.3.3.1
  • accountsservice-lang >= 0.6.45-lp150.3.3.1
  • libaccountsservice0 >= 0.6.45-lp150.3.3.1
  • libaccountsservice0-debuginfo >= 0.6.45-lp150.3.3.1
  • typelib-1_0-AccountsService-1_0 >= 0.6.45-lp150.3.3.1
Patchnames:
openSUSE-2019-902


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP3 accountsservice In progress
SUSE Linux Enterprise Desktop 12 SP4 accountsservice In progress
SUSE Linux Enterprise High Performance Computing 12 accountsservice In progress
SUSE Linux Enterprise Module for Desktop Applications 15 GA accountsservice Released
SUSE Linux Enterprise SDK 12 SP3 accountsservice In progress
SUSE Linux Enterprise SDK 12 SP4 accountsservice In progress
SUSE Linux Enterprise Server 12 SP2 LTSS accountsservice Affected
SUSE Linux Enterprise Server 12 SP3 accountsservice In progress
SUSE Linux Enterprise Server 12 SP4 accountsservice In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP3 accountsservice In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP4 accountsservice In progress