Upstream information

CVE-2016-1857 at MITRE

Description

WebKit, as used in Apple iOS before 9.3.2, Safari before 9.1.1, and tvOS before 9.2.1, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted web site, a different vulnerability than CVE-2016-1854, CVE-2016-1855, and CVE-2016-1856.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
No SUSE Bugzilla entries cross referenced.

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libjavascriptcoregtk-4_0-18 >= 2.12.5-1.12
  • libwebkit2gtk-4_0-37 >= 2.12.5-1.12
  • libwebkit2gtk3-lang >= 2.12.5-1.12
  • typelib-1_0-JavaScriptCore-4_0 >= 2.12.5-1.12
  • typelib-1_0-WebKit2-4_0 >= 2.12.5-1.12
  • webkit2gtk-4_0-injected-bundles >= 2.12.5-1.12
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Desktop 12 SP3
  • libjavascriptcoregtk-4_0-18 >= 2.12.5-1.12
  • libwebkit2gtk-4_0-37 >= 2.12.5-1.12
  • libwebkit2gtk3-lang >= 2.12.5-1.12
  • typelib-1_0-JavaScriptCore-4_0 >= 2.12.5-1.12
  • typelib-1_0-WebKit2-4_0 >= 2.12.5-1.12
  • webkit2gtk-4_0-injected-bundles >= 2.12.5-1.12
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Desktop 12 SP4
  • libjavascriptcoregtk-4_0-18 >= 2.20.3-2.23.8
  • libwebkit2gtk-4_0-37 >= 2.20.3-2.23.8
  • libwebkit2gtk3-lang >= 2.20.3-2.23.8
  • typelib-1_0-JavaScriptCore-4_0 >= 2.20.3-2.23.8
  • typelib-1_0-WebKit2-4_0 >= 2.20.3-2.23.8
  • webkit2gtk-4_0-injected-bundles >= 2.20.3-2.23.8
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise High Performance Computing 12 SP5
  • libjavascriptcoregtk-4_0-18 >= 2.24.4-2.47.1
  • libwebkit2gtk-4_0-37 >= 2.24.4-2.47.1
  • libwebkit2gtk3-lang >= 2.24.4-2.47.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.24.4-2.47.1
  • typelib-1_0-WebKit2-4_0 >= 2.24.4-2.47.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.24.4-2.47.1
  • webkit2gtk-4_0-injected-bundles >= 2.24.4-2.47.1
Patchnames:
SUSE Linux Enterprise High Performance Computing 12 SP5 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Module for Basesystem 15
  • libjavascriptcoregtk-4_0-18 >= 2.20.2-1.14
  • libwebkit2gtk-4_0-37 >= 2.20.2-1.14
  • libwebkit2gtk3-lang >= 2.20.2-1.14
  • webkit2gtk-4_0-injected-bundles >= 2.20.2-1.14
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libjavascriptcoregtk-4_0-18 >= 2.24.1-3.24.1
  • libwebkit2gtk-4_0-37 >= 2.24.1-3.24.1
  • libwebkit2gtk3-lang >= 2.24.1-3.24.1
  • webkit2gtk-4_0-injected-bundles >= 2.24.1-3.24.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Module for Desktop Applications 15
  • typelib-1_0-JavaScriptCore-4_0 >= 2.20.2-1.14
  • typelib-1_0-WebKit2-4_0 >= 2.20.2-1.14
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.20.2-1.14
  • webkit2gtk3-devel >= 2.20.2-1.14
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA typelib-1_0-JavaScriptCore-4_0
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.24.1-3.24.1
  • typelib-1_0-WebKit2-4_0 >= 2.24.1-3.24.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.24.1-3.24.1
  • webkit2gtk3-devel >= 2.24.1-3.24.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP1 GA typelib-1_0-JavaScriptCore-4_0
SUSE Linux Enterprise Server 12 SP2
  • libjavascriptcoregtk-4_0-18 >= 2.12.5-1.12
  • libwebkit2gtk-4_0-37 >= 2.12.5-1.12
  • typelib-1_0-JavaScriptCore-4_0 >= 2.12.5-1.12
  • typelib-1_0-WebKit2-4_0 >= 2.12.5-1.12
  • webkit2gtk-4_0-injected-bundles >= 2.12.5-1.12
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Server 12 SP3
  • libjavascriptcoregtk-4_0-18 >= 2.12.5-1.12
  • libwebkit2gtk-4_0-37 >= 2.12.5-1.12
  • typelib-1_0-JavaScriptCore-4_0 >= 2.12.5-1.12
  • typelib-1_0-WebKit2-4_0 >= 2.12.5-1.12
  • webkit2gtk-4_0-injected-bundles >= 2.12.5-1.12
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Server 12 SP4
  • libjavascriptcoregtk-4_0-18 >= 2.20.3-2.23.8
  • libwebkit2gtk-4_0-37 >= 2.20.3-2.23.8
  • typelib-1_0-JavaScriptCore-4_0 >= 2.20.3-2.23.8
  • typelib-1_0-WebKit2-4_0 >= 2.20.3-2.23.8
  • webkit2gtk-4_0-injected-bundles >= 2.20.3-2.23.8
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Server 12 SP5
  • libjavascriptcoregtk-4_0-18 >= 2.24.4-2.47.1
  • libwebkit2gtk-4_0-37 >= 2.24.4-2.47.1
  • libwebkit2gtk3-lang >= 2.24.4-2.47.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.24.4-2.47.1
  • typelib-1_0-WebKit2-4_0 >= 2.24.4-2.47.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.24.4-2.47.1
  • webkit2gtk-4_0-injected-bundles >= 2.24.4-2.47.1
Patchnames:
SUSE Linux Enterprise Server 12 SP5 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libjavascriptcoregtk-4_0-18 >= 2.12.5-1.12
  • libwebkit2gtk-4_0-37 >= 2.12.5-1.12
  • typelib-1_0-JavaScriptCore-4_0 >= 2.12.5-1.12
  • typelib-1_0-WebKit2-4_0 >= 2.12.5-1.12
  • webkit2gtk-4_0-injected-bundles >= 2.12.5-1.12
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libjavascriptcoregtk-4_0-18
SUSE Linux Enterprise Software Development Kit 12 SP2
  • webkit2gtk3-devel >= 2.12.5-1.12
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA webkit2gtk3-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • webkit2gtk3-devel >= 2.12.5-1.12
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA webkit2gtk3-devel
SUSE Linux Enterprise Software Development Kit 12 SP4
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.20.3-2.23.8
  • webkit2gtk3-devel >= 2.20.3-2.23.8
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA typelib-1_0-WebKit2WebExtension-4_0
SUSE Linux Enterprise Software Development Kit 12 SP5
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.24.4-2.47.1
  • webkit2gtk3-devel >= 2.24.4-2.47.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP5 GA typelib-1_0-WebKit2WebExtension-4_0
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libwebkit2gtk3-lang >= 2.12.5-1.12
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA libwebkit2gtk3-lang
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libwebkit2gtk3-lang >= 2.12.5-1.12
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA libwebkit2gtk3-lang
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libwebkit2gtk3-lang >= 2.20.3-2.23.8
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libwebkit2gtk3-lang
openSUSE Leap 15.0
  • libjavascriptcoregtk-4_0-18 >= 2.20.2-lp150.1.1
  • libwebkit2gtk-4_0-37 >= 2.20.2-lp150.1.1
  • libwebkit2gtk3-lang >= 2.20.2-lp150.1.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.20.2-lp150.1.1
  • typelib-1_0-WebKit2-4_0 >= 2.20.2-lp150.1.1
  • webkit2gtk-4_0-injected-bundles >= 2.20.2-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libjavascriptcoregtk-4_0-18
openSUSE Leap 42.2
  • libjavascriptcoregtk-4_0-18 >= 2.12.5-1.6
  • libwebkit2gtk-4_0-37 >= 2.12.5-1.6
  • libwebkit2gtk3-lang >= 2.12.5-1.6
  • typelib-1_0-JavaScriptCore-4_0 >= 2.12.5-1.6
  • typelib-1_0-WebKit2-4_0 >= 2.12.5-1.6
  • webkit2gtk-4_0-injected-bundles >= 2.12.5-1.6
Patchnames:
openSUSE Leap 42.2 GA libjavascriptcoregtk-4_0-18
openSUSE Leap 42.3
  • libjavascriptcoregtk-4_0-18 >= 2.12.5-3.26
  • libwebkit2gtk-4_0-37 >= 2.12.5-3.26
  • libwebkit2gtk3-lang >= 2.12.5-3.26
  • typelib-1_0-JavaScriptCore-4_0 >= 2.12.5-3.26
  • typelib-1_0-WebKit2-4_0 >= 2.12.5-3.26
  • webkit2gtk-4_0-injected-bundles >= 2.12.5-3.26
Patchnames:
openSUSE Leap 42.3 GA libjavascriptcoregtk-4_0-18
openSUSE Tumbleweed
  • libjavascriptcoregtk-4_0-18 >= 2.14.2-2.1
  • libjavascriptcoregtk-4_0-18-32bit >= 2.14.2-2.1
  • libwebkit2gtk-4_0-37 >= 2.14.2-2.1
  • libwebkit2gtk-4_0-37-32bit >= 2.14.2-2.1
  • libwebkit2gtk3-lang >= 2.14.2-2.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.14.2-2.1
  • typelib-1_0-WebKit2-4_0 >= 2.14.2-2.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.14.2-2.1
  • webkit-jsc-4 >= 2.14.2-2.1
  • webkit2gtk-4_0-injected-bundles >= 2.14.2-2.1
  • webkit2gtk3-devel >= 2.14.2-2.1
  • webkit2gtk3-plugin-process-gtk2 >= 2.14.2-2.1
Patchnames:
openSUSE Tumbleweed GA libjavascriptcoregtk-4_0-18