Upstream information

CVE-2015-7578 at MITRE

Description

Cross-site scripting (XSS) vulnerability in the rails-html-sanitizer gem before 1.0.3 for Ruby on Rails 4.2.x and 5.x allows remote attackers to inject arbitrary web script or HTML via crafted tag attributes.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.1
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Changed
Confidentiality Impact Low
Integrity Impact Low
Availability Impact None
CVSSv3 Version 3
SUSE Bugzilla entry: 963326 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 2.1
  • ruby2.1-rubygem-rails-html-sanitizer >= 1.0.2-7.1
  • rubygem-rails-html-sanitizer >= 1.0.2-7.1
Patchnames:
SUSE-Storage-2.1-2016-228
SUSE Linux Enterprise High Availability 15
SUSE Linux Enterprise High Availability 15 SP1
  • ruby2.5-rubygem-rails-html-sanitizer >= 1.0.4-2.11
SUSE Linux Enterprise Module for Containers 12
  • portus >= 2.0.3-2.4
Patchnames:
SUSE-SLE-Module-Containers-12-2016-672
SUSE OpenStack Cloud 6
  • ruby2.1-rubygem-rails-html-sanitizer >= 1.0.2-7.1
openSUSE Leap 42.1
  • ruby2.1-rubygem-rails-html-sanitizer >= 1.0.2-5.1
  • ruby2.1-rubygem-rails-html-sanitizer-doc >= 1.0.2-5.1
  • ruby2.1-rubygem-rails-html-sanitizer-testsuite >= 1.0.2-5.1
  • rubygem-rails-html-sanitizer >= 1.0.2-5.1
Patchnames:
openSUSE-2016-148
openSUSE Tumbleweed
  • ruby2.2-rubygem-rails-html-sanitizer >= 1.0.3-1.2
  • ruby2.2-rubygem-rails-html-sanitizer-doc >= 1.0.3-1.2
  • ruby2.2-rubygem-rails-html-sanitizer-testsuite >= 1.0.3-1.2
  • ruby2.3-rubygem-rails-html-sanitizer >= 1.0.3-1.2
  • ruby2.3-rubygem-rails-html-sanitizer-doc >= 1.0.3-1.2
  • ruby2.3-rubygem-rails-html-sanitizer-testsuite >= 1.0.3-1.2
Patchnames:
openSUSE Tumbleweed GA ruby2.2-rubygem-rails-html-sanitizer


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Enterprise Storage 2.1 rubygem-rails-html-sanitizer Released
SUSE Enterprise Storage 3 rubygem-rails-html-sanitizer In progress
SUSE OpenStack Cloud 6 rubygem-rails-html-sanitizer In progress