Upstream information

CVE-2015-5343 at MITRE

Description

Integer overflow in util.c in mod_dav_svn in Apache Subversion 1.7.x, 1.8.x before 1.8.15, and 1.9.x before 1.9.3 allows remote authenticated users to cause a denial of service (subversion server crash or memory consumption) and possibly execute arbitrary code via a skel-encoded request body, which triggers an out-of-bounds read and heap-based buffer overflow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 8
Vector AV:N/AC:L/Au:S/C:P/I:P/A:C
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.6
Vector CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 958300 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • subversion >= 1.10.0-3.3.1
  • subversion-devel >= 1.10.0-3.3.1
SUSE Linux Enterprise Module for Basesystem 15
  • subversion >= 1.10.0-1.24
  • subversion-devel >= 1.10.0-1.24
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • subversion-bash-completion >= 1.10.0-3.3.1
  • subversion-perl >= 1.10.0-3.3.1
  • subversion-python >= 1.10.0-3.3.1
  • subversion-tools >= 1.10.0-3.3.1
SUSE Linux Enterprise Module for Development Tools 15
  • subversion-bash-completion >= 1.10.0-1.24
  • subversion-perl >= 1.10.0-1.24
  • subversion-python >= 1.10.0-1.24
  • subversion-tools >= 1.10.0-1.24
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • subversion-server >= 1.10.0-3.3.1
SUSE Linux Enterprise Module for Server Applications 15
  • subversion-server >= 1.10.0-1.24
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.19-25.3.1
  • libsvn_auth_kwallet-1-0 >= 1.8.10-24.1
  • subversion >= 1.8.19-25.3.1
  • subversion-bash-completion >= 1.8.19-25.3.1
  • subversion-devel >= 1.8.19-25.3.1
  • subversion-perl >= 1.8.19-25.3.1
  • subversion-python >= 1.8.19-25.3.1
  • subversion-server >= 1.8.19-25.3.1
  • subversion-tools >= 1.8.19-25.3.1
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libsvn_auth_gnome_keyring-1-0 >= 1.10.6-1.12
  • libsvn_auth_kwallet-1-0 >= 1.8.10-24.1
  • subversion >= 1.10.6-1.12
  • subversion-bash-completion >= 1.10.6-1.12
  • subversion-devel >= 1.10.6-1.12
  • subversion-perl >= 1.10.6-1.12
  • subversion-python >= 1.10.6-1.12
  • subversion-server >= 1.10.6-1.12
  • subversion-tools >= 1.10.6-1.12
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.10-18.2
  • libsvn_auth_kwallet-1-0 >= 1.8.10-18.2
  • subversion >= 1.8.10-18.2
  • subversion-bash-completion >= 1.8.10-18.2
  • subversion-devel >= 1.8.10-18.2
  • subversion-perl >= 1.8.10-18.2
  • subversion-python >= 1.8.10-18.2
  • subversion-server >= 1.8.10-18.2
  • subversion-tools >= 1.8.10-18.2
openSUSE 13.1
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.15-2.42.1
  • libsvn_auth_gnome_keyring-1-0-debuginfo >= 1.8.15-2.42.1
  • libsvn_auth_kwallet-1-0 >= 1.8.15-2.42.1
  • libsvn_auth_kwallet-1-0-debuginfo >= 1.8.15-2.42.1
  • subversion >= 1.8.15-2.42.1
  • subversion-bash-completion >= 1.8.15-2.42.1
  • subversion-debuginfo >= 1.8.15-2.42.1
  • subversion-debugsource >= 1.8.15-2.42.1
  • subversion-devel >= 1.8.15-2.42.1
  • subversion-perl >= 1.8.15-2.42.1
  • subversion-perl-debuginfo >= 1.8.15-2.42.1
  • subversion-python >= 1.8.15-2.42.1
  • subversion-python-debuginfo >= 1.8.15-2.42.1
  • subversion-ruby >= 1.8.15-2.42.1
  • subversion-ruby-debuginfo >= 1.8.15-2.42.1
  • subversion-server >= 1.8.15-2.42.1
  • subversion-server-debuginfo >= 1.8.15-2.42.1
  • subversion-tools >= 1.8.15-2.42.1
  • subversion-tools-debuginfo >= 1.8.15-2.42.1
Patchnames:
openSUSE-2015-948
openSUSE Leap 42.1
  • libsvn_auth_gnome_keyring-1-0 >= 1.8.10-6.1
  • libsvn_auth_gnome_keyring-1-0-debuginfo >= 1.8.10-6.1
  • libsvn_auth_kwallet-1-0 >= 1.8.10-6.1
  • libsvn_auth_kwallet-1-0-debuginfo >= 1.8.10-6.1
  • subversion >= 1.8.10-6.1
  • subversion-bash-completion >= 1.8.10-6.1
  • subversion-debuginfo >= 1.8.10-6.1
  • subversion-debugsource >= 1.8.10-6.1
  • subversion-devel >= 1.8.10-6.1
  • subversion-perl >= 1.8.10-6.1
  • subversion-perl-debuginfo >= 1.8.10-6.1
  • subversion-python >= 1.8.10-6.1
  • subversion-python-debuginfo >= 1.8.10-6.1
  • subversion-ruby >= 1.8.10-6.1
  • subversion-ruby-debuginfo >= 1.8.10-6.1
  • subversion-server >= 1.8.10-6.1
  • subversion-server-debuginfo >= 1.8.10-6.1
  • subversion-tools >= 1.8.10-6.1
  • subversion-tools-debuginfo >= 1.8.10-6.1
Patchnames:
openSUSE-2015-949
openSUSE Leap 42.2
  • libsvn_auth_gnome_keyring-1-0 >= 1.9.4-1.1
  • libsvn_auth_kwallet-1-0 >= 1.9.4-1.1
  • subversion >= 1.9.4-1.1
  • subversion-bash-completion >= 1.9.4-1.1
  • subversion-devel >= 1.9.4-1.1
  • subversion-perl >= 1.9.4-1.1
  • subversion-python >= 1.9.4-1.1
  • subversion-server >= 1.9.4-1.1
  • subversion-tools >= 1.9.4-1.1
Patchnames:
openSUSE Leap 42.2 GA libsvn_auth_gnome_keyring-1-0
openSUSE Leap 42.3
  • libsvn_auth_gnome_keyring-1-0 >= 1.9.5-6.3
  • libsvn_auth_kwallet-1-0 >= 1.9.5-6.3
  • subversion >= 1.9.5-6.3
  • subversion-bash-completion >= 1.9.5-6.3
  • subversion-devel >= 1.9.5-6.3
  • subversion-perl >= 1.9.5-6.3
  • subversion-python >= 1.9.5-6.3
  • subversion-server >= 1.9.5-6.3
  • subversion-tools >= 1.9.5-6.3
Patchnames:
openSUSE Leap 42.3 GA libsvn_auth_gnome_keyring-1-0
openSUSE Tumbleweed
  • libsvn_auth_gnome_keyring-1-0 >= 1.9.5-1.1
  • libsvn_auth_kwallet-1-0 >= 1.9.5-1.1
  • subversion >= 1.9.5-1.1
  • subversion-bash-completion >= 1.9.5-1.1
  • subversion-devel >= 1.9.5-1.1
  • subversion-perl >= 1.9.5-1.1
  • subversion-python >= 1.9.5-1.1
  • subversion-python-ctypes >= 1.9.5-1.1
  • subversion-ruby >= 1.9.5-1.1
  • subversion-server >= 1.9.5-1.1
  • subversion-tools >= 1.9.5-1.1
Patchnames:
openSUSE Tumbleweed GA libsvn_auth_gnome_keyring-1-0


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP3 subversion Not affected
SUSE Linux Enterprise SDK 11 SP4 subversion Not affected
SUSE Linux Enterprise SDK 12 GA subversion Released
SUSE Linux Enterprise SDK 12 SP1 subversion Released
SUSE Linux Enterprise SDK 12 SP2 subversion Released
SUSE Linux Enterprise SDK 12 SP3 subversion Released