Upstream information

CVE-2007-0104 at MITRE

Description

The Adobe PDF specification 1.3, as implemented by (a) xpdf 3.0.1 patch 2, (b) kpdf in KDE before 3.5.5, (c) poppler before 0.5.4, and other products, allows remote attackers to have an unknown impact, possibly including denial of service (infinite loop), arbitrary code execution, or memory corruption, via a PDF file with a (1) crafted catalog dictionary or (2) a crafted Pages attribute that references an invalid page tree node.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 233113 [RESOLVED / FIXED], 234492 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • cups >= 1.3.9-8.30.1
  • cups-client >= 1.3.9-8.30.1
  • cups-libs >= 1.3.9-8.30.1
  • cups-libs-32bit >= 1.3.9-8.30.1
  • cups-libs-x86 >= 1.3.9-8.30.1
  • libpoppler-glib4 >= 0.12.3-1.2.44
  • libpoppler-qt4-3 >= 0.12.3-1.2.44
  • libpoppler5 >= 0.12.3-1.2.44
  • poppler-tools >= 0.12.3-1.2.44
  • xpdf-tools >= 3.02-138.26.1
SUSE Linux Enterprise Server 11 SP2
  • cups >= 1.3.9-8.44.1
  • cups-client >= 1.3.9-8.44.1
  • cups-libs >= 1.3.9-8.44.1
  • cups-libs-32bit >= 1.3.9-8.44.1
  • cups-libs-x86 >= 1.3.9-8.44.1
  • libpoppler-glib4 >= 0.12.3-1.3.1
  • libpoppler-qt4-3 >= 0.12.3-1.3.1
  • libpoppler5 >= 0.12.3-1.3.1
  • poppler-tools >= 0.12.3-1.3.1
SUSE Linux Enterprise Server 11 SP3
  • cups >= 1.3.9-8.46.46.1
  • cups-client >= 1.3.9-8.46.46.1
  • cups-libs >= 1.3.9-8.46.46.1
  • cups-libs-32bit >= 1.3.9-8.46.46.1
  • cups-libs-x86 >= 1.3.9-8.46.46.1
  • libpoppler-glib4 >= 0.12.3-1.8.1
  • libpoppler-qt4-3 >= 0.12.3-1.8.1
  • libpoppler5 >= 0.12.3-1.8.1
  • poppler-tools >= 0.12.3-1.8.1
SUSE Linux Enterprise Server 11 SP4
  • cups >= 1.3.9-8.46.56.1
  • cups-client >= 1.3.9-8.46.56.1
  • cups-libs >= 1.3.9-8.46.56.1
  • cups-libs-32bit >= 1.3.9-8.46.56.1
  • cups-libs-x86 >= 1.3.9-8.46.56.1
  • libpoppler-glib4 >= 0.12.3-1.10.1
  • libpoppler-qt4-3 >= 0.12.3-1.10.1
  • libpoppler5 >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • cups-devel >= 1.3.9-8.46.56.1
  • libpoppler-devel >= 0.12.3-1.10.1
  • libpoppler-glib-devel >= 0.12.3-1.10.1
  • libpoppler-qt2 >= 0.12.3-1.10.1
  • libpoppler-qt3-devel >= 0.12.3-1.10.1
  • libpoppler-qt4-devel >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Legacy 12 cups154 Already fixed