Upstream information

CVE-2024-28757 at MITRE

Description

libexpat through 2.6.1 allows an XML Entity Expansion attack when there is isolated use of external parsers (created via XML_ExternalEntityParserCreate).

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v3 Scores
  SUSE
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1221289 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container bci/bci-init:15.5.15.8
Container bci/bci-init:15.6.7.20
Container bci/bci-sle15-kernel-module-devel:15.5.8.7
Container bci/golang:oldstable-2.2.46
Container bci/golang:oldstable-openssl-12.42
Container bci/golang:stable-openssl-12.43
Container bci/nodejs:18-16.44
Container bci/nodejs:20-6.45
Container bci/openjdk-devel:11-14.90
Container bci/openjdk-devel:17-16.90
Container bci/openjdk:11-15.40
Container bci/openjdk:17-16.39
Container bci/openjdk:21-5.23
Container bci/php-apache:8-12.40
Container bci/python:3.11-17.38
Container bci/python:3.6-18.39
Container bci/ruby:2.5-16.38
Container suse/389-ds:2.2-20.47
Container suse/git:2.35-9.15
Container suse/manager/4.3/proxy-httpd:4.3.11.9.49.22
Container suse/manager/4.3/proxy-salt-broker:4.3.11.9.39.23
Container suse/manager/4.3/proxy-ssh:4.3.11.9.39.17
Container suse/manager/4.3/proxy-tftpd:4.3.11.9.39.15
Container suse/nginx:1.21-10.45
Container suse/pcp:5.2.5-22.82
Container suse/registry:2.8-21.6
Container suse/rmt-mariadb:10.6-20.8
Container suse/sle-micro-rancher/5.3:latest
Container suse/sle-micro-rancher/5.4:latest
Container suse/sle-micro/5.3/toolbox:13.2-6.8.5
Container suse/sle-micro/5.4/toolbox:13.2-5.15.5
Container suse/sle-micro/5.5/toolbox:13.2-2.2.197
Container suse/sle-micro/5.5:2.0.2-4.2.70
Container suse/sle-micro/kvm-5.5:2.0.2-2.2.85
Container suse/sle-micro/rt-5.5:2.0.2-3.2.86
Container suse/sle15:15.6.46.2.3
  • libexpat1 >= 2.4.4-150400.3.17.1
Image SLES15-SP4-SAP-Azure-LI-BYOS
Image SLES15-SP4-SAP-Azure-LI-BYOS-Production
Image SLES15-SP4-SAP-Azure-VLI-BYOS
Image SLES15-SP4-SAP-Azure-VLI-BYOS-Production
  • expat >= 2.4.4-150400.3.17.1
  • libexpat1 >= 2.4.4-150400.3.17.1
SUSE Liberty Linux 9
  • expat >= 2.5.0-1.el9_3.1
  • expat-devel >= 2.5.0-1.el9_3.1
Patchnames:
RHSA-2024:1530
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Basesystem 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • expat >= 2.4.4-150400.3.17.1
  • libexpat-devel >= 2.4.4-150400.3.17.1
  • libexpat1 >= 2.4.4-150400.3.17.1
  • libexpat1-32bit >= 2.4.4-150400.3.17.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2024-1129
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS
  • expat >= 2.4.4-150400.3.17.1
  • libexpat-devel >= 2.4.4-150400.3.17.1
  • libexpat1 >= 2.4.4-150400.3.17.1
  • libexpat1-32bit >= 2.4.4-150400.3.17.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP4-ESPOS-2024-1129
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS
  • expat >= 2.4.4-150400.3.17.1
  • libexpat-devel >= 2.4.4-150400.3.17.1
  • libexpat1 >= 2.4.4-150400.3.17.1
  • libexpat1-32bit >= 2.4.4-150400.3.17.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP4-LTSS-2024-1129
SUSE Linux Enterprise Micro 5.3
  • libexpat1 >= 2.4.4-150400.3.17.1
Patchnames:
SUSE-SLE-Micro-5.3-2024-1129
SUSE Linux Enterprise Micro 5.4
  • libexpat1 >= 2.4.4-150400.3.17.1
Patchnames:
SUSE-SLE-Micro-5.4-2024-1129
SUSE Linux Enterprise Micro 5.5
  • libexpat1 >= 2.4.4-150400.3.17.1
Patchnames:
SUSE-SLE-Micro-5.5-2024-1129
SUSE Linux Enterprise Server 15 SP4-LTSS
  • expat >= 2.4.4-150400.3.17.1
  • libexpat-devel >= 2.4.4-150400.3.17.1
  • libexpat1 >= 2.4.4-150400.3.17.1
  • libexpat1-32bit >= 2.4.4-150400.3.17.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP4-LTSS-2024-1129
SUSE Linux Enterprise Server for SAP Applications 15 SP4
  • expat >= 2.4.4-150400.3.17.1
  • libexpat-devel >= 2.4.4-150400.3.17.1
  • libexpat1 >= 2.4.4-150400.3.17.1
  • libexpat1-32bit >= 2.4.4-150400.3.17.1
Patchnames:
SUSE-SLE-Product-SLES_SAP-15-SP4-2024-1129
SUSE Manager Proxy 4.3
  • expat >= 2.4.4-150400.3.17.1
  • libexpat-devel >= 2.4.4-150400.3.17.1
  • libexpat1 >= 2.4.4-150400.3.17.1
  • libexpat1-32bit >= 2.4.4-150400.3.17.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Proxy-4.3-2024-1129
SUSE Manager Retail Branch Server 4.3
  • expat >= 2.4.4-150400.3.17.1
  • libexpat-devel >= 2.4.4-150400.3.17.1
  • libexpat1 >= 2.4.4-150400.3.17.1
  • libexpat1-32bit >= 2.4.4-150400.3.17.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.3-2024-1129
SUSE Manager Server 4.3
  • expat >= 2.4.4-150400.3.17.1
  • libexpat-devel >= 2.4.4-150400.3.17.1
  • libexpat1 >= 2.4.4-150400.3.17.1
  • libexpat1-32bit >= 2.4.4-150400.3.17.1
Patchnames:
SUSE-SLE-Product-SUSE-Manager-Server-4.3-2024-1129
openSUSE Leap 15.5
  • expat >= 2.4.4-150400.3.17.1
  • libexpat-devel >= 2.4.4-150400.3.17.1
  • libexpat-devel-32bit >= 2.4.4-150400.3.17.1
  • libexpat1 >= 2.4.4-150400.3.17.1
  • libexpat1-32bit >= 2.4.4-150400.3.17.1
Patchnames:
openSUSE-SLE-15.5-2024-1129
openSUSE Leap Micro 5.3
  • libexpat1 >= 2.4.4-150400.3.17.1
Patchnames:
openSUSE-Leap-Micro-5.3-2024-1129
openSUSE Leap Micro 5.4
  • libexpat1 >= 2.4.4-150400.3.17.1
Patchnames:
openSUSE-Leap-Micro-5.4-2024-1129
openSUSE Leap Micro 5.5
  • libexpat1 >= 2.4.4-150400.3.17.1
Patchnames:
openSUSE-Leap-Micro-5.5-2024-1129
openSUSE Tumbleweed
  • expat >= 2.6.2-1.1
  • libexpat-devel >= 2.6.2-1.1
  • libexpat-devel-32bit >= 2.6.2-1.1
  • libexpat1 >= 2.6.2-1.1
  • libexpat1-32bit >= 2.6.2-1.1
Patchnames:
openSUSE Tumbleweed GA expat-2.6.2-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 expat Not affected
SUSE Linux Enterprise Desktop 15 SP5 expat Released
SUSE Linux Enterprise Desktop 15 SP6 expat Released
SUSE Linux Enterprise High Performance Computing 12 SP5 expat Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 expat Released
SUSE Linux Enterprise High Performance Computing 15 SP6 expat Released
SUSE Linux Enterprise Micro 5.1 expat Not affected
SUSE Linux Enterprise Micro 5.2 expat Not affected
SUSE Linux Enterprise Micro 5.3 expat Released
SUSE Linux Enterprise Micro 5.4 expat Released
SUSE Linux Enterprise Micro 5.5 expat Released
SUSE Linux Enterprise Micro for Rancher 5.3 expat Released
SUSE Linux Enterprise Micro for Rancher 5.4 expat Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 expat Released
SUSE Linux Enterprise Module for Basesystem 15 SP6 expat Released
SUSE Linux Enterprise Real Time 15 SP3 expat Not affected
SUSE Linux Enterprise Server 12 SP5 expat Not affected
SUSE Linux Enterprise Server 12-LTSS expat Not affected
SUSE Linux Enterprise Server 15 SP5 expat Released
SUSE Linux Enterprise Server 15 SP6 expat Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 expat Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 expat Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 expat Released
SUSE Linux Enterprise Server for SAP Applications 15 SP6 expat Released
SUSE Linux Enterprise Software Development Kit 12 SP5 expat Not affected
SUSE Manager Proxy 4.3 expat Released
SUSE Manager Retail Branch Server 4.3 expat Released
SUSE Manager Server 4.3 expat Released
openSUSE Leap 15.5 expat Released
openSUSE Leap Micro 5.3 expat Released
openSUSE Leap Micro 5.4 expat Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 expat Affected
SUSE Linux Enterprise Desktop 15 SP4 LTSS expat Released
SUSE Linux Enterprise High Performance Computing 15 expat Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 expat Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS expat Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS expat Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 expat Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS expat Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS expat Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 expat Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS expat Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS expat Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 expat Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS expat Released
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS expat Released
SUSE Linux Enterprise High Performance Computing 15-ESPOS expat Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS expat Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 expat Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 expat Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 expat Affected
SUSE Linux Enterprise Server 15 SP2 expat Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS expat Not affected
SUSE Linux Enterprise Server 15 SP3 expat Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS expat Not affected
SUSE Linux Enterprise Server 15 SP4 expat Affected
SUSE Linux Enterprise Server 15 SP4-LTSS expat Released
SUSE Linux Enterprise Server for SAP Applications 15 expat Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 expat Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 expat Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 expat Not affected
SUSE OpenStack Cloud 8 expat Not affected
SUSE OpenStack Cloud 9 expat Not affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 expat Not affected
SUSE CaaS Platform 3.0 expat Not affected
SUSE CaaS Platform 4.0 expat Not affected
SUSE Enterprise Storage 6 expat Not affected
SUSE Enterprise Storage 7 expat Not affected
SUSE Linux Enterprise Desktop 11 SP4 expat Not affected
SUSE Linux Enterprise Desktop 12 expat Not affected
SUSE Linux Enterprise Desktop 12 SP1 expat Not affected
SUSE Linux Enterprise Desktop 12 SP2 expat Not affected
SUSE Linux Enterprise Desktop 12 SP3 expat Not affected
SUSE Linux Enterprise Desktop 12 SP4 expat Not affected
SUSE Linux Enterprise Desktop 15 expat Not affected
SUSE Linux Enterprise Desktop 15 SP1 expat Not affected
SUSE Linux Enterprise Desktop 15 SP2 expat Not affected
SUSE Linux Enterprise Desktop 15 SP3 expat Not affected
SUSE Linux Enterprise Micro 5.0 expat Not affected
SUSE Linux Enterprise Module for Basesystem 15 expat Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 expat Not affected
SUSE Linux Enterprise Real Time 15 SP2 expat Not affected
SUSE Linux Enterprise Real Time 15 SP4 expat Affected
SUSE Linux Enterprise Server 11 SP3 expat Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS expat Not affected
SUSE Linux Enterprise Server 11 SP4 expat Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS expat Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS expat Not affected
SUSE Linux Enterprise Server 12 expat Not affected
SUSE Linux Enterprise Server 12 SP1 expat Not affected
SUSE Linux Enterprise Server 12 SP1-LTSS expat Not affected
SUSE Linux Enterprise Server 12 SP2 expat Not affected
SUSE Linux Enterprise Server 12 SP2-BCL expat Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS expat Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS expat Not affected
SUSE Linux Enterprise Server 12 SP3 expat Not affected
SUSE Linux Enterprise Server 12 SP3-BCL expat Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS expat Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS expat Not affected
SUSE Linux Enterprise Server 12 SP4 expat Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS expat Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS expat Not affected
SUSE Linux Enterprise Server 15 expat Not affected
SUSE Linux Enterprise Server 15 SP1 expat Not affected
SUSE Linux Enterprise Server 15 SP1-BCL expat Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS expat Not affected
SUSE Linux Enterprise Server 15 SP2-BCL expat Not affected
SUSE Linux Enterprise Server 15 SP3-BCL expat Not affected
SUSE Linux Enterprise Server 15-LTSS expat Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 expat Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 expat Not affected
SUSE Linux Enterprise Server for SAP Applications 12 expat Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 expat Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 expat Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 expat Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 expat Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 expat Not affected
SUSE Linux Enterprise Software Development Kit 12 expat Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 expat Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 expat Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 expat Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 expat Not affected
SUSE Manager Proxy 4.0 expat Not affected
SUSE Manager Proxy 4.1 expat Not affected
SUSE Manager Proxy 4.2 expat Not affected
SUSE Manager Retail Branch Server 4.0 expat Not affected
SUSE Manager Retail Branch Server 4.1 expat Not affected
SUSE Manager Retail Branch Server 4.2 expat Not affected
SUSE Manager Server 4.0 expat Not affected
SUSE Manager Server 4.1 expat Not affected
SUSE Manager Server 4.2 expat Not affected
SUSE OpenStack Cloud 7 expat Not affected
SUSE OpenStack Cloud Crowbar 8 expat Not affected
SUSE OpenStack Cloud Crowbar 9 expat Not affected
openSUSE Leap 15.4 expat Released
Container Status
suse/sles12sp3 expatNot affected


SUSE Timeline for this CVE

CVE page created: Sun Mar 10 07:00:10 2024
CVE page last modified: Fri Apr 19 19:37:19 2024