Upstream information

CVE-2023-1428 at MITRE

Description

There exists an vulnerability causing an abort() to be called in gRPC.  The following headers cause gRPC's C++ implementation to abort() when called via http2: te: x (x != trailers) :scheme: x (x != http, https) grpclb_client_stats: x (x == anything) On top of sending one of those headers, a later header must be sent that gets the total header size past 8KB. We recommend upgrading past git commit 2485fa94bd8a723e5c977d55a3ce10b301b437f8 or v1.53 and above.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1212181 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 grpc Not affected
SUSE Linux Enterprise Desktop 15 SP5 grpc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 grpc Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP5 grpc Not affected
SUSE Linux Enterprise Module for Public Cloud 15 SP5 grpc Not affected
SUSE Linux Enterprise Real Time 15 SP3 grpc Not affected
SUSE Linux Enterprise Server 15 SP5 grpc Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 grpc Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 grpc Not affected
SUSE Manager Proxy 4.3 grpc Not affected
SUSE Manager Retail Branch Server 4.3 grpc Not affected
SUSE Manager Server 4.3 grpc Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 grpc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 grpc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2 grpc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 grpc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS grpc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS grpc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 grpc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS grpc Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS grpc Not affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 grpc Not affected
SUSE Linux Enterprise Module for Public Cloud 15 SP4 grpc Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP3 grpc Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP4 grpc Not affected
SUSE Linux Enterprise Server 15 SP2 grpc Not affected
SUSE Linux Enterprise Server 15 SP3 grpc Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS grpc Not affected
SUSE Linux Enterprise Server 15 SP4 grpc Not affected
SUSE Linux Enterprise Server 15 SP4-LTSS grpc Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 grpc Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 grpc Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 grpc Not affected
Products past their end of life and not receiving proactive updates anymore.
SUSE Enterprise Storage 6 grpc Not affected
SUSE Enterprise Storage 7 grpc Not affected
SUSE Linux Enterprise Module for Public Cloud 15 SP1 grpc Not affected
SUSE Linux Enterprise Module for Public Cloud 15 SP2 grpc Not affected
SUSE Linux Enterprise Module for Public Cloud 15 SP3 grpc Not affected
SUSE Linux Enterprise Real Time 15 SP4 grpc Not affected
SUSE Linux Enterprise Server 15 SP1 grpc Not affected
SUSE Linux Enterprise Server 15 SP3-BCL grpc Not affected
SUSE Manager Proxy 4.0 grpc Not affected
SUSE Manager Proxy 4.1 grpc Not affected
SUSE Manager Proxy 4.2 grpc Not affected
SUSE Manager Retail Branch Server 4.0 grpc Not affected
SUSE Manager Retail Branch Server 4.1 grpc Not affected
SUSE Manager Retail Branch Server 4.2 grpc Not affected
SUSE Manager Server 4.0 grpc Not affected
SUSE Manager Server 4.1 grpc Not affected
SUSE Manager Server 4.2 grpc Not affected


SUSE Timeline for this CVE

CVE page created: Fri Jun 9 14:00:02 2023
CVE page last modified: Thu Feb 22 17:22:18 2024