Upstream information

CVE-2018-1000155 at MITRE

Description

OpenFlow version 1.0 onwards contains a Denial of Service and Improper authorization vulnerability in OpenFlow handshake: The DPID (DataPath IDentifier) in the features_reply message are inherently trusted by the controller. that can result in Denial of Service, Unauthorized Access, Network Instability. This attack appear to be exploitable via Network connectivity: the attacker must first establish a transport connection with the OpenFlow controller and then initiate the OpenFlow handshake.

SUSE information

Overall state of this security issue: Revisit

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 6.4
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:H
Attack Vector Network Network
Attack Complexity Low High
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1093457 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 openvswitch Affected
SUSE Linux Enterprise High Performance Computing 15 SP5 openvswitch Affected
SUSE Linux Enterprise High Performance Computing 15 SP6 openvswitch Analysis
SUSE Linux Enterprise Module for Legacy 15 SP5 openvswitch Affected
SUSE Linux Enterprise Module for Package Hub 15 SP5 openvswitch Affected
SUSE Linux Enterprise Module for Package Hub 15 SP6 openvswitch Analysis
SUSE Linux Enterprise Module for Server Applications 15 SP5 openvswitch Affected
SUSE Linux Enterprise Module for Server Applications 15 SP6 openvswitch Analysis
SUSE Linux Enterprise Server 15 SP5 openvswitch Affected
SUSE Linux Enterprise Server 15 SP6 openvswitch Analysis
SUSE Linux Enterprise Server for SAP Applications 15 SP5 openvswitch Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP6 openvswitch Analysis
SUSE Manager Proxy 4.3 openvswitch Affected
SUSE Manager Retail Branch Server 4.3 openvswitch Affected
SUSE Manager Server 4.3 openvswitch Affected
openSUSE Leap 15.5 openvswitch Affected
openSUSE Leap 15.6 openvswitch Analysis
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise High Performance Computing 15 SP2 openvswitch Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS openvswitch Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS openvswitch Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 openvswitch Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS openvswitch Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS openvswitch Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 openvswitch Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS openvswitch Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS openvswitch Affected
SUSE Linux Enterprise Module for Server Applications 15 SP2 openvswitch Affected
SUSE Linux Enterprise Module for Server Applications 15 SP3 openvswitch Unsupported
SUSE Linux Enterprise Module for Server Applications 15 SP4 openvswitch Affected
SUSE Linux Enterprise Server 15 SP2 openvswitch Affected
SUSE Linux Enterprise Server 15 SP2-LTSS openvswitch Affected
SUSE Linux Enterprise Server 15 SP3 openvswitch Unsupported
SUSE Linux Enterprise Server 15 SP3-LTSS openvswitch Affected
SUSE Linux Enterprise Server 15 SP4 openvswitch Affected
SUSE Linux Enterprise Server 15 SP4-LTSS openvswitch Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 openvswitch Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 openvswitch Unsupported
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 openvswitch Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 openvswitch Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 openvswitch Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP4 openvswitch Affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 openvswitch Affected
SUSE CaaS Platform 4.0 openvswitch Affected
SUSE CaaS Platform 4.5 openvswitch Unsupported
SUSE Enterprise Storage 6 openvswitch Affected
SUSE Enterprise Storage 7 openvswitch Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 openvswitch Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS openvswitch Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS openvswitch Affected
SUSE Linux Enterprise Module for Package Hub 15 SP1 openvswitch Unsupported
SUSE Linux Enterprise Module for Package Hub 15 SP2 openvswitch Affected
SUSE Linux Enterprise Module for Package Hub 15 SP3 openvswitch Unsupported
SUSE Linux Enterprise Module for Package Hub 15 SP4 openvswitch Affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 openvswitch Affected
SUSE Linux Enterprise Real Time 15 SP2 openvswitch Unsupported
SUSE Linux Enterprise Real Time 15 SP3 openvswitch Affected
SUSE Linux Enterprise Real Time 15 SP4 openvswitch Affected
SUSE Linux Enterprise Server 12 SP2 openvswitch Affected
SUSE Linux Enterprise Server 12 SP2-BCL openvswitch Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS openvswitch Affected
SUSE Linux Enterprise Server 12 SP2-LTSS openvswitch Affected
SUSE Linux Enterprise Server 12 SP3 openvswitch Unsupported
SUSE Linux Enterprise Server 12 SP3-BCL openvswitch Unsupported
SUSE Linux Enterprise Server 12 SP3-ESPOS openvswitch Affected
SUSE Linux Enterprise Server 12 SP3-LTSS openvswitch Affected
SUSE Linux Enterprise Server 12 SP4 openvswitch Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS openvswitch Affected
SUSE Linux Enterprise Server 12 SP4-LTSS openvswitch Affected
SUSE Linux Enterprise Server 15 SP1 openvswitch Affected
SUSE Linux Enterprise Server 15 SP1-BCL openvswitch Affected
SUSE Linux Enterprise Server 15 SP1-LTSS openvswitch Affected
SUSE Linux Enterprise Server 15 SP2-BCL openvswitch Affected
SUSE Linux Enterprise Server 15 SP3-BCL openvswitch Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 openvswitch Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 openvswitch Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openvswitch Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP4 openvswitch Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 openvswitch Affected
SUSE Manager Proxy 4.0 openvswitch Affected
SUSE Manager Proxy 4.1 openvswitch Unsupported
SUSE Manager Proxy 4.2 openvswitch Unsupported
SUSE Manager Retail Branch Server 4.0 openvswitch Affected
SUSE Manager Retail Branch Server 4.1 openvswitch Unsupported
SUSE Manager Retail Branch Server 4.2 openvswitch Unsupported
SUSE Manager Server 4.0 openvswitch Affected
SUSE Manager Server 4.1 openvswitch Unsupported
SUSE Manager Server 4.2 openvswitch Unsupported
SUSE OpenStack Cloud 6 openvswitch Unsupported
SUSE OpenStack Cloud 6-LTSS openvswitch Affected
SUSE OpenStack Cloud 7 openvswitch Affected
SUSE OpenStack Cloud 8 openvswitch Affected
SUSE OpenStack Cloud 9 openvswitch Affected
SUSE OpenStack Cloud Crowbar 8 openvswitch Affected
SUSE OpenStack Cloud Crowbar 9 openvswitch Affected


SUSE Timeline for this CVE

CVE page created: Wed May 9 13:45:17 2018
CVE page last modified: Mon Jun 17 15:26:07 2024