changing d-bus limits

This document (000020405) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server 12

Situation

The default limit of d-bus has been reached.

Example message for hitting max_replies_per_connection limit as seen in /var/log/messages:
2021-10-10T12:53:24.272449+08:00 localhost systemd-logind[1417]: Failed to start session scope session-c1284.scope: The maximum number of pending replies per connection has been reached

Resolution

There is a different set of limits for user sessions and for system (configured in session.conf and system.conf).
For different available limits please see the manual page of the dbus-daemon with command:

man dbus-daemon

The default limits are configured during the d-bus compilation time.

On SLE15 or newer the defaults can be seen in the file /usr/share/dbus-1/system.conf and session.conf respectively.
On SLE12 and newer service packs the defaults can be seen in the source code for the dbus-1 package.

In our example the systemd-logind process is running in the system scope (as seen in the command systemd-cgls).

# systemd-cgls 
Control group /:
-.slice
├─user.slice 
└─system.slice 
  ├─haveged.service 
  └─systemd-logind.service 
(output is shortened)

The default in the file system.conf is:
<!-- <limit name="max_replies_per_connection">128</limit> -->

Create the file /etc/dbus-1/system-local.conf with the following content (for user session limits it would be session-local.conf):
<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-Bus Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
<limit name="max_replies_per_connection">1200</limit>
</busconfig>
The changes should be active right away as the dbus daemon is monitoring these files for changes.

Cause

The default d-bus limits may not be optimal for every user.
Alternatively there might be some process that is not behaving correctly and uses up d-bus resources.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020405
  • Creation Date: 07-Mar-2022
  • Modified Date:07-Mar-2022
    • SUSE Linux Enterprise Server
    • SUSE Linux Enterprise Server for SAP Applications

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center