Rancher v2.5 provisioned Kubernetes clusters, without a worker role node, display "Cluster health check failed: cluster agent is not ready" error

This document (000020043) is provided subject to the disclaimer at the end of this document.

Situation

Issue

When provisioning or updating a Rancher-provisioned Kubernetes cluster in Rancher v2.5.x, such that the cluster does not have a node with the worker role, the cluster will enter an Error status, displaying the message Cluster health check failed: cluster agent is not ready. By comparison, in Rancher v2.4.x, the cluster status would show Active in this scenario.

Pre-requisites

Root cause

Rancher v2.5.x implements an additional cluster health check to ensure that the Pod for the cluster-agent Deployment in the cattle-system namespace of the downstream cluster is ready and successfully connected to the Rancher server. The cluster-agent Pod will use cluster DNS to resolve the Rancher server hostname. As a result, in the instance that there is no node with the worker role, CoreDNS Pods will be unable to schedule and the cluster-agent will thus be unable to resolve the Rancher hostname, causing this check to fail.

Resolution

Provision a node in the cluster with the worker role, to ensure that CoreDNS Pods can be successfully scheduled.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000020043
  • Creation Date: 06-May-2021
  • Modified Date:06-May-2021
    • SUSE Rancher

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center