SUSE Support

Here When You Need Us

rsh & rlogin packages cannot be found in SLE 15

This document (7024198) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15

Situation

The packages rsh & rlogin do not exist in SUSE Linux Enterprise Server 15. 
Even searching for the packages returned nothing. 
 
In SUSE Linux Enterprise Server 12 Support Pack 5 they do exist. 
 
s15sp1:~ # zypper search-packages rsh
No package found
 
s12sp4:~ # zypper se rsh
S | Name       | Summary                                                   | Type   
--+------------+-----------------------------------------------------------+--------
i | rsh        | Clients for remote access commands (rsh, rlogin, and rcp) | package
  | rsh-server | Servers for Remote Access Commands (rsh, rlogin, rcp)     | package
 
 

Resolution

rsh usage should be replaced with ssh. In other words, "ssh is the new rsh".
scp replace rcp ,, ssh replace rexec, rlogin, rsh 

Cause

The rsh package no longer exists on the media, nor in the SLE-15 codestream. 
Instead, rsh was removed from openSUSE:Factory in mid 2015 citing security and maintenance concerns.

Additional Information

The following commands are not available anymore: 

/usr/bin/rcp
/usr/bin/rexec
/usr/bin/rlogin
/usr/bin/rsh

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7024198
  • Creation Date: 23-Oct-2019
  • Modified Date:24-Jan-2024
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.