NFSv4 mount maps permissions for users and groups to nobody

This document (7021120) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12 Service Pack 1 (SLES 12 SP1)
SUSE Linux Enterprise Server 12 Service Pack 2 (SLES 12 SP2)

Situation

File permissions on a single NFSv4 client share are mapped to nobody:nobody while the correct user and group exists locally:

[...]
       11      20 drwxrwsr-x  2 nobody  nobody      16384 Nov 15  2012 lost+found
148996097   91248 drwxrwsr-x  5 nobody  nobody   93335552 Jul 11 18:40 Statements
    32769   86308 drwxrwsr-x  5 nobody  nobody   88281088 Jun  8 00:19 Statements_Original
 34177025       4 drwxrwsr-x  2 nobody  nobody       4096 Jan 29  2015 TEST
 35012609       4 drwxrwsr-x  2 nobody  nobody       4096 Feb 28 19:43 upload
[...]

In /var/log/messages the following error is displayed:

Jul 15 02:27:54 linux nfsidmap[14274]: nss_getpwnam: name '<$USERNAME>' not found in domain 'localdomain'

The access permissions on other hosts mounting the share show the regular username and group.

Resolution

Please check the settings in /etc/idmapd.conf on all involved systems to ensure all settings are the same. If this is the case, please run

nfsidmap -c

to clear the cache of the nfsidmap daemon running with the NFS client.

Cause

Possible reasons for this behavior are a configuration mismatch or problems with the cached nfsidmap data on the NFS client.

Additional Information

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7021120
  • Creation Date: 26-Jul-2017
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center