Upstream information

CVE-2024-24680 at MITRE

Description

An issue was discovered in Django 3.2 before 3.2.24, 4.2 before 4.2.10, and Django 5.0 before 5.0.2. The intcomma template filter was subject to a potential denial-of-service attack when used with very long strings.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1219683 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion OpenStack 8
  • python-Django >= 1.11.29-3.59.3
  • venv-openstack-horizon-hpe-x86_64 >= 12.0.5~dev6-14.54.4
Patchnames:
HPE-Helion-OpenStack-8-2024-875
SUSE OpenStack Cloud 8
  • python-Django >= 1.11.29-3.59.3
  • venv-openstack-horizon-x86_64 >= 12.0.5~dev6-14.54.5
Patchnames:
SUSE-OpenStack-Cloud-8-2024-875
SUSE OpenStack Cloud 9
  • python-Django1 >= 1.11.29-3.58.3
  • venv-openstack-horizon-x86_64 >= 14.1.1~dev11-4.51.4
Patchnames:
SUSE-OpenStack-Cloud-9-2024-874
SUSE OpenStack Cloud Crowbar 8
  • python-Django >= 1.11.29-3.59.3
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2024-875
SUSE OpenStack Cloud Crowbar 9
  • python-Django1 >= 1.11.29-3.58.3
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2024-874
openSUSE Tumbleweed
  • python310-Django >= 4.2.10-1.1
  • python311-Django >= 4.2.10-1.1
  • python312-Django >= 4.2.10-1.1
  • python39-Django >= 4.2.10-1.1
Patchnames:
openSUSE Tumbleweed GA python310-Django-4.2.10-1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Module for Package Hub 15 SP6 python-Django Already fixed
openSUSE Leap 15.5 python-Django Affected
openSUSE Leap 15.6 python-Django Already fixed
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 python-Django Released
HPE Helion OpenStack 8 venv-openstack-horizon-hpe Released
SUSE OpenStack Cloud 8 python-Django Released
SUSE OpenStack Cloud 8 venv-openstack-horizon Released
SUSE OpenStack Cloud 9 python-Django1 Released
SUSE OpenStack Cloud 9 venv-openstack-horizon Released
SUSE OpenStack Cloud Crowbar 8 python-Django Released
SUSE OpenStack Cloud Crowbar 9 python-Django1 Released


SUSE Timeline for this CVE

CVE page created: Tue Feb 6 17:00:01 2024
CVE page last modified: Wed Jun 5 21:43:02 2024