Upstream information

CVE-2023-0594 at MITRE

Description

Grafana is an open-source platform for monitoring and observability. Starting with the 7.0 branch, Grafana had a stored XSS vulnerability in the trace view visualization. The stored XSS vulnerability was possible due the value of a span's attributes/resources were not properly sanitized and this will be rendered when the span's attributes/resources are expanded. An attacker needs to have the Editor role in order to change the value of a trace view visualization to contain JavaScript. This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard. Users may upgrade to version 8.5.21, 9.2.13 and 9.3.8 to receive a fix.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.3 7.3
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
Attack Vector Network Network
Attack Complexity Low Low
Privileges Required Low Low
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact None None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1208819 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Package Hub 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • grafana >= 8.5.22-150200.3.38.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP4-2023-1904
SUSE Manager Tools 12
  • grafana >= 8.5.22-1.45.1
Patchnames:
SUSE-SLE-Manager-Tools-12-2023-1902
SUSE Manager Tools 15
  • grafana >= 8.5.22-150000.1.45.1
Patchnames:
SUSE-SLE-Manager-Tools-15-2023-1903
openSUSE Leap 15.4
  • grafana >= 8.5.22-150200.3.38.1
Patchnames:
openSUSE-SLE-15.4-2023-1904


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Desktop 15 SP4 grafana Released
SUSE Linux Enterprise Desktop 15 SP5 grafana Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 grafana Released
SUSE Linux Enterprise High Performance Computing 15 SP5 grafana Affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 grafana Released
SUSE Linux Enterprise Server 15 SP4 grafana Released
SUSE Linux Enterprise Server 15 SP5 grafana Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 grafana Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 grafana Affected
SUSE Manager Client Tools Beta for SLE 12 grafana Affected
SUSE Manager Client Tools Beta for SLE 15 grafana Affected
SUSE Manager Client Tools for SLE 12 grafana Released
SUSE Manager Client Tools for SLE 15 grafana Released
SUSE Manager Proxy 4.3 grafana Released
SUSE Manager Retail Branch Server 4.3 grafana Released
SUSE Manager Server 4.3 grafana Released
SUSE Manager Tools 12 grafana Released
SUSE Manager Tools 15 grafana Released
SUSE Manager Tools 15 SP1 grafana Released
SUSE Package Hub 15 SP4 grafana Released
SUSE Package Hub 15 SP5 grafana Affected
openSUSE Leap 15.4 grafana Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 grafana Not affected
SUSE Enterprise Storage 6 grafana Affected
SUSE OpenStack Cloud 8 grafana Not affected
SUSE OpenStack Cloud 9 grafana Not affected
SUSE OpenStack Cloud Crowbar 8 grafana Not affected
SUSE OpenStack Cloud Crowbar 9 grafana Not affected
Products at an unknown state of their lifecycle.
SUSE Linux Enterprise Module for Package Hub 15 SP5 grafana Affected
Container Status
ses/7.1/ceph/grafana
ses/7/ceph/grafana
grafanaIn progress


SUSE Timeline for this CVE

CVE page created: Wed Mar 1 19:01:43 2023
CVE page last modified: Wed May 31 16:02:42 2023