Upstream information

CVE-2022-41716 at MITRE

Description

Due to unsanitized NUL values, attackers may be able to maliciously set environment variables on Windows. In syscall.StartProcess and os/exec.Cmd, invalid environment variable values containing NUL values are not properly checked for. A malicious environment variable value can exploit this behavior to set a value for a different environment variable. For example, the environment variable string "A=B\x00C=D" sets the variables "A=B" and "C=D".

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 0
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:N
Attack Vector Network Local
Attack Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact High None
Availability Impact None None
CVSSv3 Version 3.1 3.1

Note from the SUSE Security Team on the go1.* package

SUSE only supports the current and the previous GO language releases.

SUSE Bugzilla entry: 1204941 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container bci/golang:1.18-18.31
  • go1.18 >= 1.18.8-150000.1.37.1
Container bci/golang:oldstable-3.4
  • go1.19 >= 1.19.3-150000.1.15.1
SUSE Enterprise Storage 7.1
  • go1.18 >= 1.18.8-150000.1.37.1
  • go1.18-doc >= 1.18.8-150000.1.37.1
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
  • go1.18-race >= 1.18.8-150000.1.37.1
  • go1.19 >= 1.19.3-150000.1.15.1
  • go1.19-doc >= 1.19.3-150000.1.15.1
  • go1.19-race >= 1.19.3-150000.1.15.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP3-2022-4054
SUSE-SLE-Module-Development-Tools-15-SP3-2022-4055
SUSE-Storage-7.1-2023-2312
SUSE Linux Enterprise Desktop 15 SP3
SUSE Linux Enterprise High Performance Computing 15 SP3
SUSE Linux Enterprise Module for Development Tools 15 SP3
SUSE Linux Enterprise Server 15 SP3
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.2
  • go1.18 >= 1.18.8-150000.1.37.1
  • go1.18-doc >= 1.18.8-150000.1.37.1
  • go1.18-race >= 1.18.8-150000.1.37.1
  • go1.19 >= 1.19.3-150000.1.15.1
  • go1.19-doc >= 1.19.3-150000.1.15.1
  • go1.19-race >= 1.19.3-150000.1.15.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP3-2022-4054
SUSE-SLE-Module-Development-Tools-15-SP3-2022-4055
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Development Tools 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • go1.18 >= 1.18.8-150000.1.37.1
  • go1.18-doc >= 1.18.8-150000.1.37.1
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
  • go1.18-race >= 1.18.8-150000.1.37.1
  • go1.19 >= 1.19.3-150000.1.15.1
  • go1.19-doc >= 1.19.3-150000.1.15.1
  • go1.19-race >= 1.19.3-150000.1.15.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP4-2022-4054
SUSE-SLE-Module-Development-Tools-15-SP4-2022-4055
SUSE-SLE-Module-Development-Tools-15-SP4-2023-2312
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Development Tools 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • go1.19 >= 1.19.3-150000.1.15.1
  • go1.19-doc >= 1.19.3-150000.1.15.1
  • go1.19-race >= 1.19.3-150000.1.15.1
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 SP5 GA go1.19-1.19.9-150000.1.31.1
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP3-ESPOS-2023-2312
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
Patchnames:
SUSE-SLE-Product-HPC-15-SP3-LTSS-2023-2312
SUSE Linux Enterprise Real Time 15 SP3
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
Patchnames:
SUSE-SLE-Product-RT-15-SP3-2023-2312
SUSE Linux Enterprise Server 15 SP3-LTSS
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
Patchnames:
SUSE-SLE-Product-SLES-15-SP3-LTSS-2023-2312
SUSE Linux Enterprise Server for SAP Applications 15 SP3
  • go1.18 >= 1.18.8-150000.1.37.1
  • go1.18-doc >= 1.18.8-150000.1.37.1
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
  • go1.18-race >= 1.18.8-150000.1.37.1
  • go1.19 >= 1.19.3-150000.1.15.1
  • go1.19-doc >= 1.19.3-150000.1.15.1
  • go1.19-race >= 1.19.3-150000.1.15.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP3-2022-4054
SUSE-SLE-Module-Development-Tools-15-SP3-2022-4055
SUSE-SLE-Product-SLES_SAP-15-SP3-2023-2312
openSUSE Leap 15.3
  • go1.18 >= 1.18.8-150000.1.37.1
  • go1.18-doc >= 1.18.8-150000.1.37.1
  • go1.18-race >= 1.18.8-150000.1.37.1
  • go1.19 >= 1.19.3-150000.1.15.1
  • go1.19-doc >= 1.19.3-150000.1.15.1
  • go1.19-race >= 1.19.3-150000.1.15.1
Patchnames:
openSUSE-SLE-15.3-2022-4054
openSUSE-SLE-15.3-2022-4055
openSUSE Leap 15.4
  • go1.18 >= 1.18.8-150000.1.37.1
  • go1.18-doc >= 1.18.8-150000.1.37.1
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
  • go1.18-race >= 1.18.8-150000.1.37.1
  • go1.19 >= 1.19.3-150000.1.15.1
  • go1.19-doc >= 1.19.3-150000.1.15.1
  • go1.19-race >= 1.19.3-150000.1.15.1
Patchnames:
openSUSE-SLE-15.4-2022-4054
openSUSE-SLE-15.4-2022-4055
openSUSE-SLE-15.4-2023-2312
openSUSE Leap 15.5
  • go1.18-openssl >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-doc >= 1.18.10.1-150000.1.9.1
  • go1.18-openssl-race >= 1.18.10.1-150000.1.9.1
Patchnames:
openSUSE-SLE-15.5-2023-2312
openSUSE Tumbleweed
  • go1.18 >= 1.18.8-1.1
  • go1.18-doc >= 1.18.8-1.1
  • go1.18-race >= 1.18.8-1.1
  • go1.19 >= 1.19.3-1.1
  • go1.19-doc >= 1.19.3-1.1
  • go1.19-race >= 1.19.3-1.1
Patchnames:
openSUSE-Tumbleweed-2024-12471
openSUSE-Tumbleweed-2024-12472


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 go1.17 Unsupported
SUSE Enterprise Storage 7.1 go1.18 Released
SUSE Enterprise Storage 7.1 go1.18-openssl Released
SUSE Enterprise Storage 7.1 go1.19 Released
SUSE Linux Enterprise Desktop 15 SP5 go1.19 Released
SUSE Linux Enterprise High Performance Computing 15 SP5 go1.19 Released
SUSE Linux Enterprise Module for Development Tools 15 SP5 go1.19 Released
SUSE Linux Enterprise Server 15 SP5 go1.19 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 go1.19 Released
SUSE Manager Proxy 4.3 go1.17 Unsupported
SUSE Manager Proxy 4.3 go1.18 Released
SUSE Manager Proxy 4.3 go1.18-openssl Released
SUSE Manager Proxy 4.3 go1.19 Released
SUSE Manager Retail Branch Server 4.3 go1.17 Unsupported
SUSE Manager Retail Branch Server 4.3 go1.18 Released
SUSE Manager Retail Branch Server 4.3 go1.18-openssl Released
SUSE Manager Retail Branch Server 4.3 go1.19 Released
SUSE Manager Server 4.3 go1.17 Unsupported
SUSE Manager Server 4.3 go1.18 Released
SUSE Manager Server 4.3 go1.18-openssl Released
SUSE Manager Server 4.3 go1.19 Released
openSUSE Leap 15.5 go1.18-openssl Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 go1.17 Unsupported
SUSE Linux Enterprise Desktop 15 SP4 go1.18 Released
SUSE Linux Enterprise Desktop 15 SP4 go1.18-openssl Released
SUSE Linux Enterprise Desktop 15 SP4 go1.19 Released
SUSE Linux Enterprise High Performance Computing 15 SP2 go1.17 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS go1.17 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS go1.17 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3 go1.17 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3 go1.18 Released
SUSE Linux Enterprise High Performance Computing 15 SP3 go1.18-openssl Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 go1.19 Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS go1.17 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS go1.18 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS go1.18-openssl Released
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS go1.19 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS go1.17 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS go1.18 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS go1.18-openssl Released
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS go1.19 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 go1.17 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4 go1.18 Released
SUSE Linux Enterprise High Performance Computing 15 SP4 go1.18-openssl Released
SUSE Linux Enterprise High Performance Computing 15 SP4 go1.19 Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS go1.17 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS go1.18 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS go1.18-openssl Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS go1.19 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS go1.17 Unsupported
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS go1.18 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS go1.18-openssl Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS go1.19 Affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 go1.17 Unsupported
SUSE Linux Enterprise Module for Development Tools 15 SP3 go1.17 Unsupported
SUSE Linux Enterprise Module for Development Tools 15 SP3 go1.18 Released
SUSE Linux Enterprise Module for Development Tools 15 SP3 go1.18-openssl Affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 go1.19 Released
SUSE Linux Enterprise Module for Development Tools 15 SP4 go1.17 Unsupported
SUSE Linux Enterprise Module for Development Tools 15 SP4 go1.18 Released
SUSE Linux Enterprise Module for Development Tools 15 SP4 go1.18-openssl Released
SUSE Linux Enterprise Module for Development Tools 15 SP4 go1.19 Released
SUSE Linux Enterprise Server 15 SP2 go1.17 Unsupported
SUSE Linux Enterprise Server 15 SP2-LTSS go1.17 Unsupported
SUSE Linux Enterprise Server 15 SP3 go1.17 Unsupported
SUSE Linux Enterprise Server 15 SP3 go1.18 Released
SUSE Linux Enterprise Server 15 SP3 go1.18-openssl Affected
SUSE Linux Enterprise Server 15 SP3 go1.19 Released
SUSE Linux Enterprise Server 15 SP3-LTSS go1.17 Unsupported
SUSE Linux Enterprise Server 15 SP3-LTSS go1.18 Affected
SUSE Linux Enterprise Server 15 SP3-LTSS go1.18-openssl Released
SUSE Linux Enterprise Server 15 SP3-LTSS go1.19 Affected
SUSE Linux Enterprise Server 15 SP4 go1.17 Unsupported
SUSE Linux Enterprise Server 15 SP4 go1.18 Released
SUSE Linux Enterprise Server 15 SP4 go1.18-openssl Released
SUSE Linux Enterprise Server 15 SP4 go1.19 Released
SUSE Linux Enterprise Server 15 SP4-LTSS go1.17 Unsupported
SUSE Linux Enterprise Server 15 SP4-LTSS go1.18 Affected
SUSE Linux Enterprise Server 15 SP4-LTSS go1.18-openssl Affected
SUSE Linux Enterprise Server 15 SP4-LTSS go1.19 Affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 go1.17 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP2 go1.17 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP3 go1.17 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP3 go1.18 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 go1.18-openssl Released
SUSE Linux Enterprise Server for SAP Applications 15 SP3 go1.19 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 go1.17 Unsupported
SUSE Linux Enterprise Server for SAP Applications 15 SP4 go1.18 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 go1.18-openssl Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 go1.19 Released
Products past their end of life and not receiving proactive updates anymore.
SUSE Enterprise Storage 7 go1.17 Unsupported
SUSE Linux Enterprise Desktop 15 SP2 go1.17 Unsupported
SUSE Linux Enterprise Desktop 15 SP3 go1.17 Unsupported
SUSE Linux Enterprise Desktop 15 SP3 go1.18 Released
SUSE Linux Enterprise Desktop 15 SP3 go1.18-openssl Affected
SUSE Linux Enterprise Desktop 15 SP3 go1.19 Released
SUSE Linux Enterprise Real Time 15 SP2 go1.17 Unsupported
SUSE Linux Enterprise Real Time 15 SP3 go1.17 Unsupported
SUSE Linux Enterprise Real Time 15 SP3 go1.18 Affected
SUSE Linux Enterprise Real Time 15 SP3 go1.18-openssl Released
SUSE Linux Enterprise Real Time 15 SP3 go1.19 Affected
SUSE Linux Enterprise Real Time 15 SP4 go1.17 Unsupported
SUSE Linux Enterprise Real Time 15 SP4 go1.18 Affected
SUSE Linux Enterprise Real Time 15 SP4 go1.18-openssl Affected
SUSE Linux Enterprise Real Time 15 SP4 go1.19 Affected
SUSE Linux Enterprise Server 15 SP2-BCL go1.17 Unsupported
SUSE Linux Enterprise Server 15 SP3-BCL go1.17 Unsupported
SUSE Linux Enterprise Server 15 SP3-BCL go1.18 Affected
SUSE Linux Enterprise Server 15 SP3-BCL go1.18-openssl Affected
SUSE Linux Enterprise Server 15 SP3-BCL go1.19 Affected
SUSE Manager Proxy 4.1 go1.17 Unsupported
SUSE Manager Proxy 4.2 go1.17 Unsupported
SUSE Manager Proxy 4.2 go1.18 Released
SUSE Manager Proxy 4.2 go1.18-openssl Affected
SUSE Manager Proxy 4.2 go1.19 Released
SUSE Manager Retail Branch Server 4.1 go1.17 Unsupported
SUSE Manager Retail Branch Server 4.2 go1.17 Unsupported
SUSE Manager Retail Branch Server 4.2 go1.18 Released
SUSE Manager Retail Branch Server 4.2 go1.18-openssl Affected
SUSE Manager Retail Branch Server 4.2 go1.19 Released
SUSE Manager Server 4.1 go1.17 Unsupported
SUSE Manager Server 4.2 go1.17 Unsupported
SUSE Manager Server 4.2 go1.18 Released
SUSE Manager Server 4.2 go1.18-openssl Affected
SUSE Manager Server 4.2 go1.19 Released
openSUSE Leap 15.4 go1.18 Released
openSUSE Leap 15.4 go1.18-openssl Released
openSUSE Leap 15.4 go1.19 Released
Container Status
bci/golang:1.17 go1.17Unsupported
bci/golang:1.18 go1.18Released
bci/golang go1.18In progress
bci/golang:1.19 go1.19Released
Harvester master
rancher/system-agent:v0.3.6-suc usr/bin/kubectlAffected
rancher/rancher:v2.8.3 usr/bin/loglevelAffected
Harvester v1.2-head
rancher/rancher:v2.8.2 usr/bin/etcdctl
usr/bin/loglevel
usr/bin/telemetry
usr/share/rancher/ui/assets/wins.exe
Affected
rancher/system-agent:v0.3.4-suc usr/bin/kubectlAffected
Harvester v1.2.1
rancher/system-upgrade-controller:v0.11.0 bin/system-upgrade-controllerAffected
rancher/rancher:v2.7.5 usr/bin/etcdctl
usr/bin/loglevel
usr/bin/telemetry
usr/share/rancher/ui/assets/wins.exe
Affected
rancher/system-agent:v0.3.3-suc usr/bin/kubectlAffected
rancher/shell:v0.1.8 usr/local/bin/helm
usr/local/bin/k9s
usr/local/bin/kubectl
Affected
rancher/shell:v0.1.18 usr/local/bin/helm
usr/local/bin/k9s
usr/local/bin/kubectl
usr/local/bin/kustomize
Affected
Harvester v1.2.2
rancher/rancher:v2.8.2 usr/bin/etcdctl
usr/bin/loglevel
usr/bin/telemetry
usr/share/rancher/ui/assets/wins.exe
Affected
rancher/system-agent:v0.3.4-suc usr/bin/kubectlAffected
Harvester v1.3-head
rancher/system-agent:v0.3.6-suc usr/bin/kubectlAffected
rancher/rancher:v2.8.3 usr/bin/loglevelAffected
Harvester v1.3.0
rancher/rancher:v2.8.2 usr/bin/etcdctl
usr/bin/loglevel
usr/bin/telemetry
usr/share/rancher/ui/assets/wins.exe
Affected
rancher/system-agent:v0.3.4-suc usr/bin/kubectlAffected
Harvester v1.3.1
rancher/system-agent:v0.3.6-suc usr/bin/kubectlAffected
rancher/rancher:v2.8.3 usr/bin/loglevelAffected
Rancher v2.7-head
rancher/rke2-runtime:v1.23.17-rke2r1 bin/crictl
bin/runc
Affected
rancher/nginx-ingress-controller:nginx-1.2.1-hardened7
rancher/nginx-ingress-controller:nginx-1.2.1-hardened9
rancher/nginx-ingress-controller:nginx-1.4.1-hardened2
dbg
nginx-ingress-controller
wait-shutdown
Affected
rancher/rke-tools:v0.1.88 opt/rke-tools/bin/cri-dockerd
opt/rke-tools/rke-etcd-backup
tmp/bandwidth
tmp/bridge
tmp/dhcp
tmp/firewall
tmp/flannel
tmp/host-device
tmp/host-local
tmp/ipvlan
tmp/loopback
tmp/macvlan
tmp/portmap
tmp/ptp
tmp/sbr
tmp/static
tmp/tuning
tmp/vlan
tmp/vrf
usr/bin/confd
usr/local/bin/kubectl
Affected
rancher/rke-tools:v0.1.90 opt/rke-tools/rke-etcd-backup
tmp/bandwidth
tmp/bridge
tmp/dhcp
tmp/firewall
tmp/flannel
tmp/host-device
tmp/host-local
tmp/ipvlan
tmp/loopback
tmp/macvlan
tmp/portmap
tmp/ptp
tmp/sbr
tmp/static
tmp/tuning
tmp/vlan
tmp/vrf
usr/bin/confd
usr/local/bin/kubectl
Affected
rancher/rancher:v2.7-head usr/bin/etcdctl
usr/bin/loglevel
Affected
rancher/system-agent:v0.3.6-suc usr/bin/kubectlAffected
rancher/rancher-agent:v2.7-head usr/bin/loglevelAffected
rancher/rke-tools:v0.1.96 usr/local/bin/etcdctlAffected
rancher/rke2-cloud-provider:v0.0.3-build20211118
rancher/rke2-cloud-provider:v1.25.3-build20221017
usr/local/bin/rke2-cloud-providerAffected
Rancher v2.7.14
rancher/rke2-runtime:v1.23.17-rke2r1 bin/crictl
bin/runc
Affected
rancher/nginx-ingress-controller:nginx-1.2.1-hardened7
rancher/nginx-ingress-controller:nginx-1.2.1-hardened9
rancher/nginx-ingress-controller:nginx-1.4.1-hardened2
dbg
nginx-ingress-controller
wait-shutdown
Affected
rancher/rke-tools:v0.1.88 opt/rke-tools/bin/cri-dockerd
opt/rke-tools/rke-etcd-backup
tmp/bandwidth
tmp/bridge
tmp/dhcp
tmp/firewall
tmp/flannel
tmp/host-device
tmp/host-local
tmp/ipvlan
tmp/loopback
tmp/macvlan
tmp/portmap
tmp/ptp
tmp/sbr
tmp/static
tmp/tuning
tmp/vlan
tmp/vrf
usr/bin/confd
usr/local/bin/kubectl
Affected
rancher/rke-tools:v0.1.90 opt/rke-tools/rke-etcd-backup
tmp/bandwidth
tmp/bridge
tmp/dhcp
tmp/firewall
tmp/flannel
tmp/host-device
tmp/host-local
tmp/ipvlan
tmp/loopback
tmp/macvlan
tmp/portmap
tmp/ptp
tmp/sbr
tmp/static
tmp/tuning
tmp/vlan
tmp/vrf
usr/bin/confd
usr/local/bin/kubectl
Affected
rancher/system-agent:v0.3.6-suc usr/bin/kubectlAffected
rancher/rke-tools:v0.1.96 usr/local/bin/etcdctlAffected
rancher/rke2-cloud-provider:v0.0.3-build20211118
rancher/rke2-cloud-provider:v1.25.3-build20221017
usr/local/bin/rke2-cloud-providerAffected
Rancher v2.8-head
rancher/system-agent:v0.3.6-suc usr/bin/kubectlAffected
rancher/rke-tools:v0.1.96 usr/local/bin/etcdctlAffected
Rancher v2.8.5
rancher/system-agent:v0.3.6-suc usr/bin/kubectlAffected
rancher/rancher-agent:v2.8.5
rancher/rancher:v2.8.5
usr/bin/loglevelAffected
rancher/rke-tools:v0.1.96 usr/local/bin/etcdctlAffected
Rancher v2.9-head
rancher/system-agent:v0.3.6-rc2-suc usr/bin/kubectlAffected
rancher/rke-tools:v0.1.96
rancher/rke-tools:v0.1.97
usr/local/bin/etcdctlAffected
rancher/shell:v0.1.19 usr/local/bin/kubectlAffected


SUSE Timeline for this CVE

CVE page created: Tue Nov 1 20:15:45 2022
CVE page last modified: Thu Jun 20 10:27:26 2024