Upstream information

CVE-2020-8166 at MITRE

Description

A CSRF forgery vulnerability exists in rails

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 3.7
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact Low
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1172182 [NEW]

No SUSE Security Announcements cross referenced.

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Module for Public Cloud 15 SP2
  • rmt-server >= 2.6.5-3.3.1
  • rmt-server-debuginfo >= 2.6.5-3.3.1
  • rmt-server-debugsource >= 2.6.5-3.3.1
  • rmt-server-pubcloud >= 2.6.5-3.3.1
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • rmt-server >= 2.6.5-3.3.1
  • rmt-server-config >= 2.6.5-3.3.1
  • rmt-server-debuginfo >= 2.6.5-3.3.1
  • rmt-server-debugsource >= 2.6.5-3.3.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 15-SP2 Module for Public Cloud rmt-server In progress
SUSE Linux Enterprise 15-SP2 Module for Server Applications rmt-server In progress
SUSE Linux Enterprise High Availability Extension 15 rubygem-rails-5_1 Affected
SUSE Linux Enterprise High Availability Extension 15 SP1 rubygem-rails-5_1 Affected
SUSE Linux Enterprise High Availability Extension 15 SP2 rubygem-rails-5_1 Affected
SUSE OpenStack Cloud 6 LTSS rubygem-rails-4_2 Not affected
SUSE OpenStack Cloud 7 rubygem-rails-4_2 Not affected
SUSE OpenStack Cloud Crowbar 8 rubygem-rails-4_2 Not affected
SUSE OpenStack Cloud Crowbar 9 rubygem-rails-4_2 Not affected