Upstream information

CVE-2019-8675 at MITRE

Description

A buffer overflow issue was addressed with improved memory handling. This issue is fixed in macOS Mojave 10.14.6, Security Update 2019-004 High Sierra, Security Update 2019-004 Sierra. An attacker in a privileged network position may be able to execute arbitrary code.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 8.8
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3
SUSE Bugzilla entries: 1146358 [RESOLVED / FIXED], 1168422 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
HPE-Helion-OpenStack-8-2019-3057
Image SLES15-SP1-CHOST-BYOS-Ali
Image SLES15-SP1-CHOST-BYOS-Azure
Image SLES15-SP1-CHOST-BYOS-EC2
Image SLES15-SP1-CHOST-BYOS-GCE
Image SLES15-SP1-CHOST-BYOS-OpenStack
Image SLES15-SP2-CHOST-BYOS-Ali
Image SLES15-SP2-CHOST-BYOS-Azure
Image SLES15-SP2-CHOST-BYOS-EC2
Image SLES15-SP2-CHOST-BYOS-GCE
Image SLES15-SP2-CHOST-BYOS-OpenStack
  • cups-config >= 2.2.7-3.14.1
  • libcups2 >= 2.2.7-3.14.1
SUSE Enterprise Storage 5
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-Storage-5-2019-3057
SUSE Linux Enterprise Desktop 12 SP4
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-3057
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • cups >= 2.2.7-3.14.1
  • cups-client >= 2.2.7-3.14.1
  • cups-config >= 2.2.7-3.14.1
  • cups-devel >= 2.2.7-3.14.1
  • libcups2 >= 2.2.7-3.14.1
  • libcups2-32bit >= 2.2.7-3.14.1
  • libcupscgi1 >= 2.2.7-3.14.1
  • libcupsimage2 >= 2.2.7-3.14.1
  • libcupsmime1 >= 2.2.7-3.14.1
  • libcupsppdc1 >= 2.2.7-3.14.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-3030
SUSE Linux Enterprise Module for Basesystem 15
  • cups >= 2.2.7-3.14.1
  • cups-client >= 2.2.7-3.14.1
  • cups-config >= 2.2.7-3.14.1
  • cups-devel >= 2.2.7-3.14.1
  • libcups2 >= 2.2.7-3.14.1
  • libcups2-32bit >= 2.2.7-3.14.1
  • libcupscgi1 >= 2.2.7-3.14.1
  • libcupsimage2 >= 2.2.7-3.14.1
  • libcupsmime1 >= 2.2.7-3.14.1
  • libcupsppdc1 >= 2.2.7-3.14.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-3030
SUSE Linux Enterprise Module for Desktop Applications 15
  • cups >= 2.2.7-3.14.1
  • libcups2-32bit >= 2.2.7-3.14.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-3030
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • cups >= 2.2.7-3.14.1
  • cups-ddk >= 2.2.7-3.14.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP1-2019-3030
SUSE Linux Enterprise Module for Development Tools 15
  • cups >= 2.2.7-3.14.1
  • cups-ddk >= 2.2.7-3.14.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2019-3030
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • cups >= 2.2.7-3.14.1
  • cups-devel-32bit >= 2.2.7-3.14.1
  • libcupscgi1-32bit >= 2.2.7-3.14.1
  • libcupsimage2-32bit >= 2.2.7-3.14.1
  • libcupsmime1-32bit >= 2.2.7-3.14.1
  • libcupsppdc1-32bit >= 2.2.7-3.14.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-3030
SUSE Linux Enterprise Point of Sale 11 SP3
  • cups >= 1.3.9-8.46.56.8.1
  • cups-client >= 1.3.9-8.46.56.8.1
  • cups-libs >= 1.3.9-8.46.56.8.1
Patchnames:
sleposp3-cups-14229
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-3057
SUSE Linux Enterprise Server 11 SP4-LTSS
SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS
  • cups >= 1.3.9-8.46.56.8.1
  • cups-client >= 1.3.9-8.46.56.8.1
  • cups-libs >= 1.3.9-8.46.56.8.1
  • cups-libs-32bit >= 1.3.9-8.46.56.8.1
Patchnames:
slessp4-cups-14229
SUSE Linux Enterprise Server 12 SP1-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-3057
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-3057
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-3057
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-3057
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-3057
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-3057
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-3057
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-3057
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-3057
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-3057
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-3057
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2019-3057
SUSE Linux Enterprise Software Development Kit 12 SP4
  • cups >= 1.7.5-20.26.1
  • cups-ddk >= 1.7.5-20.26.1
  • cups-devel >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-3057
SUSE Linux Enterprise Software Development Kit 12 SP5
  • cups >= 1.7.5-20.26.1
  • cups-ddk >= 1.7.5-20.26.1
  • cups-devel >= 1.7.5-20.26.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2019-3057
SUSE OpenStack Cloud 7
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-3057
SUSE OpenStack Cloud 8
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-3057
SUSE OpenStack Cloud Crowbar 8
  • cups >= 1.7.5-20.26.1
  • cups-client >= 1.7.5-20.26.1
  • cups-libs >= 1.7.5-20.26.1
  • cups-libs-32bit >= 1.7.5-20.26.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-3057
openSUSE Leap 15.0
  • cups >= 2.2.7-lp150.2.13.1
  • cups-client >= 2.2.7-lp150.2.13.1
  • cups-client-debuginfo >= 2.2.7-lp150.2.13.1
  • cups-config >= 2.2.7-lp150.2.13.1
  • cups-ddk >= 2.2.7-lp150.2.13.1
  • cups-ddk-debuginfo >= 2.2.7-lp150.2.13.1
  • cups-debuginfo >= 2.2.7-lp150.2.13.1
  • cups-debugsource >= 2.2.7-lp150.2.13.1
  • cups-devel >= 2.2.7-lp150.2.13.1
  • cups-devel-32bit >= 2.2.7-lp150.2.13.1
  • libcups2 >= 2.2.7-lp150.2.13.1
  • libcups2-32bit >= 2.2.7-lp150.2.13.1
  • libcups2-32bit-debuginfo >= 2.2.7-lp150.2.13.1
  • libcups2-debuginfo >= 2.2.7-lp150.2.13.1
  • libcupscgi1 >= 2.2.7-lp150.2.13.1
  • libcupscgi1-32bit >= 2.2.7-lp150.2.13.1
  • libcupscgi1-32bit-debuginfo >= 2.2.7-lp150.2.13.1
  • libcupscgi1-debuginfo >= 2.2.7-lp150.2.13.1
  • libcupsimage2 >= 2.2.7-lp150.2.13.1
  • libcupsimage2-32bit >= 2.2.7-lp150.2.13.1
  • libcupsimage2-32bit-debuginfo >= 2.2.7-lp150.2.13.1
  • libcupsimage2-debuginfo >= 2.2.7-lp150.2.13.1
  • libcupsmime1 >= 2.2.7-lp150.2.13.1
  • libcupsmime1-32bit >= 2.2.7-lp150.2.13.1
  • libcupsmime1-32bit-debuginfo >= 2.2.7-lp150.2.13.1
  • libcupsmime1-debuginfo >= 2.2.7-lp150.2.13.1
  • libcupsppdc1 >= 2.2.7-lp150.2.13.1
  • libcupsppdc1-32bit >= 2.2.7-lp150.2.13.1
  • libcupsppdc1-32bit-debuginfo >= 2.2.7-lp150.2.13.1
  • libcupsppdc1-debuginfo >= 2.2.7-lp150.2.13.1
Patchnames:
openSUSE-2019-2573
openSUSE Leap 15.1
  • cups >= 2.2.7-lp151.6.3.1
  • cups-client >= 2.2.7-lp151.6.3.1
  • cups-client-debuginfo >= 2.2.7-lp151.6.3.1
  • cups-config >= 2.2.7-lp151.6.3.1
  • cups-ddk >= 2.2.7-lp151.6.3.1
  • cups-ddk-debuginfo >= 2.2.7-lp151.6.3.1
  • cups-debuginfo >= 2.2.7-lp151.6.3.1
  • cups-debugsource >= 2.2.7-lp151.6.3.1
  • cups-devel >= 2.2.7-lp151.6.3.1
  • cups-devel-32bit >= 2.2.7-lp151.6.3.1
  • libcups2 >= 2.2.7-lp151.6.3.1
  • libcups2-32bit >= 2.2.7-lp151.6.3.1
  • libcups2-32bit-debuginfo >= 2.2.7-lp151.6.3.1
  • libcups2-debuginfo >= 2.2.7-lp151.6.3.1
  • libcupscgi1 >= 2.2.7-lp151.6.3.1
  • libcupscgi1-32bit >= 2.2.7-lp151.6.3.1
  • libcupscgi1-32bit-debuginfo >= 2.2.7-lp151.6.3.1
  • libcupscgi1-debuginfo >= 2.2.7-lp151.6.3.1
  • libcupsimage2 >= 2.2.7-lp151.6.3.1
  • libcupsimage2-32bit >= 2.2.7-lp151.6.3.1
  • libcupsimage2-32bit-debuginfo >= 2.2.7-lp151.6.3.1
  • libcupsimage2-debuginfo >= 2.2.7-lp151.6.3.1
  • libcupsmime1 >= 2.2.7-lp151.6.3.1
  • libcupsmime1-32bit >= 2.2.7-lp151.6.3.1
  • libcupsmime1-32bit-debuginfo >= 2.2.7-lp151.6.3.1
  • libcupsmime1-debuginfo >= 2.2.7-lp151.6.3.1
  • libcupsppdc1 >= 2.2.7-lp151.6.3.1
  • libcupsppdc1-32bit >= 2.2.7-lp151.6.3.1
  • libcupsppdc1-32bit-debuginfo >= 2.2.7-lp151.6.3.1
  • libcupsppdc1-debuginfo >= 2.2.7-lp151.6.3.1
Patchnames:
openSUSE-2019-2575


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 15 Module for Basesystem cups Released
SUSE Linux Enterprise 15 Module for Desktop Applications cups Released
SUSE Linux Enterprise 15 Module for Development Tools cups Released
SUSE Linux Enterprise 15-SP1 Module for Basesystem cups Released
SUSE Linux Enterprise 15-SP1 Module for Development Tools cups Released
SUSE Linux Enterprise Desktop 12 SP4 cups Released
SUSE Linux Enterprise High Performance Computing 12 SP4 cups Released
SUSE Linux Enterprise High Performance Computing 12 SP5 cups Released
SUSE Linux Enterprise Server 11 SP1 cups Released
SUSE Linux Enterprise Server 11 SP3 cups Released
SUSE Linux Enterprise Server 11 SP4 LTSS cups Released
SUSE Linux Enterprise Server 12 SP1 LTSS cups Released
SUSE Linux Enterprise Server 12 SP2 LTSS cups Released
SUSE Linux Enterprise Server 12 SP3 LTSS cups Released
SUSE Linux Enterprise Server 12 SP4 cups Released
SUSE Linux Enterprise Server 12 SP5 cups Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 cups Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 cups Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 cups Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 cups Released
SUSE Linux Enterprise Software Bootstrap Kit 12 cups Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 cups Released
SUSE Linux Enterprise Software Development Kit 12 SP5 cups Released