Upstream information

CVE-2019-16115 at MITRE

Description

In Xpdf 4.01.01, a stack-based buffer under-read could be triggered in IdentityFunction::transform in Function.cc, used by GfxAxialShading::getColor. It can, for example, be triggered by sending a crafted PDF document to the pdftoppm tool. It allows an attacker to use a crafted PDF file to cause Denial of Service or possibly unspecified other impact.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 4.4
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High None
Availability Impact High Low
CVSSv3 Version 3.1 3
SUSE Bugzilla entry: 1150039 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 poppler Not affected
SLED-10-SP3 xpdf Not affected
SLED-10-SP4 poppler Not affected
SLED-10-SP4 xpdf Not affected
SLES for SAP Applications poppler Not affected
SLES for SAP Applications xpdf Not affected
SLES-10-SP3 poppler Not affected
SLES-10-SP3 xpdf Not affected
SLES-10-SP4 poppler Not affected
SLES-10-SP4 xpdf Not affected
SLES_LTSS-10-SP4 poppler Not affected
SLES_LTSS-10-SP4 xpdf Not affected
SUSE Linux Enterprise 15 Module for Basesystem poppler Affected
SUSE Linux Enterprise 15-SP1 Module for Basesystem poppler Affected
SUSE Linux Enterprise Desktop 11 poppler Unsupported
SUSE Linux Enterprise Desktop 11 xpdf Not affected
SUSE Linux Enterprise Desktop 11 SP1 poppler Not affected
SUSE Linux Enterprise Desktop 11 SP1 xpdf Not affected
SUSE Linux Enterprise Desktop 11 SP2 poppler Not affected
SUSE Linux Enterprise Desktop 11 SP2 xpdf Not affected
SUSE Linux Enterprise Desktop 11 SP3 poppler Not affected
SUSE Linux Enterprise Desktop 11 SP4 poppler Not affected
SUSE Linux Enterprise Desktop 12 poppler Affected
SUSE Linux Enterprise Desktop 12 SP1 poppler Affected
SUSE Linux Enterprise Desktop 12 SP2 poppler Affected
SUSE Linux Enterprise Desktop 12 SP3 poppler Affected
SUSE Linux Enterprise Desktop 12 SP4 poppler Affected
SUSE Linux Enterprise Desktop 12 SP5 poppler Affected
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search poppler Not affected
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search xpdf Not affected
SUSE Linux Enterprise High Performance Computing 12 SP2 poppler Affected
SUSE Linux Enterprise High Performance Computing 12 SP3 poppler Affected
SUSE Linux Enterprise High Performance Computing 12 SP4 poppler Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 poppler Affected
SUSE Linux Enterprise Server 11 poppler Unsupported
SUSE Linux Enterprise Server 11 SP1 poppler Not affected
SUSE Linux Enterprise Server 11 SP1 xpdf Not affected
SUSE Linux Enterprise Server 11 SP1 LTSS poppler Not affected
SUSE Linux Enterprise Server 11 SP1 LTSS xpdf Not affected
SUSE Linux Enterprise Server 11 SP2 poppler Not affected
SUSE Linux Enterprise Server 11 SP2 xpdf Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS poppler Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS xpdf Not affected
SUSE Linux Enterprise Server 11 SP2 for VMware poppler Not affected
SUSE Linux Enterprise Server 11 SP2 for VMware xpdf Not affected
SUSE Linux Enterprise Server 11 SP3 poppler Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS poppler Not affected
SUSE Linux Enterprise Server 11 SP3 for VMware poppler Not affected
SUSE Linux Enterprise Server 11 SP4 poppler Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS poppler Not affected
SUSE Linux Enterprise Server 12 poppler Affected
SUSE Linux Enterprise Server 12 LTSS poppler Affected
SUSE Linux Enterprise Server 12 SP1 poppler Affected
SUSE Linux Enterprise Server 12 SP1 LTSS poppler Affected
SUSE Linux Enterprise Server 12 SP2 poppler Affected
SUSE Linux Enterprise Server 12 SP2 BCL poppler Affected
SUSE Linux Enterprise Server 12 SP2 LTSS poppler Affected
SUSE Linux Enterprise Server 12 SP3 poppler Affected
SUSE Linux Enterprise Server 12 SP3 BCL poppler Affected
SUSE Linux Enterprise Server 12 SP3 LTSS poppler Affected
SUSE Linux Enterprise Server 12 SP4 poppler Affected
SUSE Linux Enterprise Server 12 SP5 poppler Affected
SUSE Linux Enterprise Server for SAP Applications 12 poppler Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 poppler Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 poppler Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 poppler Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 poppler Affected
SUSE Linux Enterprise Server for SAP Business All-in-One poppler Not affected
SUSE Linux Enterprise Server for SAP Business All-in-One xpdf Not affected
SUSE Linux Enterprise Server for the Raspberry Pi poppler Affected
SUSE Linux Enterprise Software Bootstrap Kit 12 poppler Affected
SUSE Linux Enterprise Software Development Kit 11 poppler Unsupported
SUSE Linux Enterprise Software Development Kit 11 SP1 poppler Not affected
SUSE Linux Enterprise Software Development Kit 11 SP2 poppler Not affected
SUSE Linux Enterprise Software Development Kit 11 SP3 poppler Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 poppler Not affected
SUSE Linux Enterprise Software Development Kit 12 poppler Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 poppler Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 poppler Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 poppler Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 poppler Affected