Upstream information

CVE-2018-10886 at MITRE

Description

** REJECT ** DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: none. Reason: this candidate is not about any specific product, protocol, or design, that falls into the scope of the assigning CNA. Notes: None.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 5.3
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact Low
CVSSv3 Version 3
SUSE Bugzilla entry: 1100053 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
  • ant >= 1.9.4-3.3.1
SUSE Linux Enterprise Module for Development Tools 15 SP1
  • ant >= 1.9.10-3.6.1
  • ant-antlr >= 1.9.10-3.6.1
  • ant-apache-bcel >= 1.9.10-3.6.1
  • ant-apache-bsf >= 1.9.10-3.6.1
  • ant-apache-log4j >= 1.9.10-3.6.1
  • ant-apache-oro >= 1.9.10-3.6.1
  • ant-apache-regexp >= 1.9.10-3.6.1
  • ant-apache-resolver >= 1.9.10-3.6.1
  • ant-commons-logging >= 1.9.10-3.6.1
  • ant-javamail >= 1.9.10-3.6.1
  • ant-jdepend >= 1.9.10-3.6.1
  • ant-jmf >= 1.9.10-3.6.1
  • ant-junit >= 1.9.10-3.6.1
  • ant-manual >= 1.9.10-3.6.1
  • ant-scripts >= 1.9.10-3.6.1
  • ant-swing >= 1.9.10-3.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP1-2020-1352
SUSE Linux Enterprise Module for Development Tools 15
  • ant >= 1.9.10-3.3.1
  • ant-antlr >= 1.9.10-3.3.1
  • ant-apache-bcel >= 1.9.10-3.3.1
  • ant-apache-bsf >= 1.9.10-3.3.1
  • ant-apache-log4j >= 1.9.10-3.3.1
  • ant-apache-oro >= 1.9.10-3.3.1
  • ant-apache-regexp >= 1.9.10-3.3.1
  • ant-apache-resolver >= 1.9.10-3.3.1
  • ant-commons-logging >= 1.9.10-3.3.1
  • ant-javamail >= 1.9.10-3.3.1
  • ant-jdepend >= 1.9.10-3.3.1
  • ant-jmf >= 1.9.10-3.3.1
  • ant-junit >= 1.9.10-3.3.1
  • ant-manual >= 1.9.10-3.3.1
  • ant-scripts >= 1.9.10-3.3.1
  • ant-swing >= 1.9.10-3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2018-2021
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • ant-antlr >= 1.9.10-3.6.1
  • ant-apache-xalan2 >= 1.9.10-3.6.1
  • ant-commons-net >= 1.9.10-3.6.1
  • ant-jsch >= 1.9.10-3.6.1
  • ant-testutil >= 1.9.10-3.6.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1352
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • ant >= 1.7.1-20.11.5.1
  • ant-antlr >= 1.7.1-16.11.5.1
  • ant-trax >= 1.7.1-16.11.5.1
Patchnames:
slessp4-ant-13781
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ant >= 1.9.4-3.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1988
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • ant >= 1.9.4-3.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2020-1351
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • ant >= 1.9.4-3.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-1351
SUSE Linux Enterprise Software Development Kit 11 SP4
  • ant >= 1.7.1-20.11.5.1
  • ant-antlr >= 1.7.1-16.11.5.1
  • ant-apache-bcel >= 1.7.1-16.11.5.1
  • ant-apache-bsf >= 1.7.1-16.11.5.1
  • ant-apache-log4j >= 1.7.1-16.11.5.1
  • ant-apache-oro >= 1.7.1-16.11.5.1
  • ant-apache-regexp >= 1.7.1-16.11.5.1
  • ant-apache-resolver >= 1.7.1-16.11.5.1
  • ant-commons-logging >= 1.7.1-16.11.5.1
  • ant-javamail >= 1.7.1-16.11.5.1
  • ant-jdepend >= 1.7.1-16.11.5.1
  • ant-jmf >= 1.7.1-16.11.5.1
  • ant-junit >= 1.7.1-16.11.5.1
  • ant-manual >= 1.7.1-20.11.5.1
  • ant-nodeps >= 1.7.1-16.11.5.1
  • ant-scripts >= 1.7.1-20.11.5.1
  • ant-swing >= 1.7.1-16.11.5.1
  • ant-trax >= 1.7.1-16.11.5.1
Patchnames:
sdksp4-ant-13781
SUSE Linux Enterprise Software Development Kit 12 SP3
  • ant >= 1.9.4-3.3.1
  • ant-antlr >= 1.9.4-3.3.1
  • ant-apache-bcel >= 1.9.4-3.3.1
  • ant-apache-bsf >= 1.9.4-3.3.1
  • ant-apache-log4j >= 1.9.4-3.3.1
  • ant-apache-oro >= 1.9.4-3.3.1
  • ant-apache-regexp >= 1.9.4-3.3.1
  • ant-apache-resolver >= 1.9.4-3.3.1
  • ant-commons-logging >= 1.9.4-3.3.1
  • ant-javadoc >= 1.9.4-3.3.1
  • ant-javamail >= 1.9.4-3.3.1
  • ant-jdepend >= 1.9.4-3.3.1
  • ant-jmf >= 1.9.4-3.3.1
  • ant-junit >= 1.9.4-3.3.1
  • ant-manual >= 1.9.4-3.3.1
  • ant-scripts >= 1.9.4-3.3.1
  • ant-swing >= 1.9.4-3.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1988
SUSE Linux Enterprise Software Development Kit 12 SP4
  • ant >= 1.9.4-3.6.1
  • ant-antlr >= 1.9.4-3.6.1
  • ant-apache-bcel >= 1.9.4-3.6.1
  • ant-apache-bsf >= 1.9.4-3.6.1
  • ant-apache-log4j >= 1.9.4-3.6.1
  • ant-apache-oro >= 1.9.4-3.6.1
  • ant-apache-regexp >= 1.9.4-3.6.1
  • ant-apache-resolver >= 1.9.4-3.6.1
  • ant-commons-logging >= 1.9.4-3.6.1
  • ant-javadoc >= 1.9.4-3.6.1
  • ant-javamail >= 1.9.4-3.6.1
  • ant-jdepend >= 1.9.4-3.6.1
  • ant-jmf >= 1.9.4-3.6.1
  • ant-junit >= 1.9.4-3.6.1
  • ant-manual >= 1.9.4-3.6.1
  • ant-scripts >= 1.9.4-3.6.1
  • ant-swing >= 1.9.4-3.6.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2020-1351
SUSE Linux Enterprise Software Development Kit 12 SP5
  • ant >= 1.9.4-3.6.1
  • ant-antlr >= 1.9.4-3.6.1
  • ant-apache-bcel >= 1.9.4-3.6.1
  • ant-apache-bsf >= 1.9.4-3.6.1
  • ant-apache-log4j >= 1.9.4-3.6.1
  • ant-apache-oro >= 1.9.4-3.6.1
  • ant-apache-regexp >= 1.9.4-3.6.1
  • ant-apache-resolver >= 1.9.4-3.6.1
  • ant-commons-logging >= 1.9.4-3.6.1
  • ant-javadoc >= 1.9.4-3.6.1
  • ant-javamail >= 1.9.4-3.6.1
  • ant-jdepend >= 1.9.4-3.6.1
  • ant-jmf >= 1.9.4-3.6.1
  • ant-junit >= 1.9.4-3.6.1
  • ant-manual >= 1.9.4-3.6.1
  • ant-scripts >= 1.9.4-3.6.1
  • ant-swing >= 1.9.4-3.6.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2020-1351
openSUSE Leap 15.0
  • ant >= 1.9.10-lp150.2.3.1
  • ant-antlr >= 1.9.10-lp150.2.3.1
  • ant-apache-bcel >= 1.9.10-lp150.2.3.1
  • ant-apache-bsf >= 1.9.10-lp150.2.3.1
  • ant-apache-log4j >= 1.9.10-lp150.2.3.1
  • ant-apache-oro >= 1.9.10-lp150.2.3.1
  • ant-apache-regexp >= 1.9.10-lp150.2.3.1
  • ant-apache-resolver >= 1.9.10-lp150.2.3.1
  • ant-apache-xalan2 >= 1.9.10-lp150.2.3.1
  • ant-commons-logging >= 1.9.10-lp150.2.3.1
  • ant-commons-net >= 1.9.10-lp150.2.3.1
  • ant-javamail >= 1.9.10-lp150.2.3.1
  • ant-jdepend >= 1.9.10-lp150.2.3.1
  • ant-jmf >= 1.9.10-lp150.2.3.1
  • ant-jsch >= 1.9.10-lp150.2.3.1
  • ant-junit >= 1.9.10-lp150.2.3.1
  • ant-manual >= 1.9.10-lp150.2.3.1
  • ant-scripts >= 1.9.10-lp150.2.3.1
  • ant-swing >= 1.9.10-lp150.2.3.1
  • ant-testutil >= 1.9.10-lp150.2.3.1
Patchnames:
openSUSE-2019-729
openSUSE Leap 15.1
  • ant >= 1.9.10-lp151.4.3.1
  • ant-antlr >= 1.9.10-lp151.4.3.1
  • ant-apache-bcel >= 1.9.10-lp151.4.3.1
  • ant-apache-bsf >= 1.9.10-lp151.4.3.1
  • ant-apache-log4j >= 1.9.10-lp151.4.3.1
  • ant-apache-oro >= 1.9.10-lp151.4.3.1
  • ant-apache-regexp >= 1.9.10-lp151.4.3.1
  • ant-apache-resolver >= 1.9.10-lp151.4.3.1
  • ant-apache-xalan2 >= 1.9.10-lp151.4.3.1
  • ant-commons-logging >= 1.9.10-lp151.4.3.1
  • ant-commons-net >= 1.9.10-lp151.4.3.1
  • ant-javamail >= 1.9.10-lp151.4.3.1
  • ant-jdepend >= 1.9.10-lp151.4.3.1
  • ant-jmf >= 1.9.10-lp151.4.3.1
  • ant-jsch >= 1.9.10-lp151.4.3.1
  • ant-junit >= 1.9.10-lp151.4.3.1
  • ant-manual >= 1.9.10-lp151.4.3.1
  • ant-scripts >= 1.9.10-lp151.4.3.1
  • ant-swing >= 1.9.10-lp151.4.3.1
  • ant-testutil >= 1.9.10-lp151.4.3.1
Patchnames:
openSUSE-2020-703


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 15 Module for Development Tools ant Released
SUSE Linux Enterprise 15-SP1 Module for Development Tools ant Released
SUSE Linux Enterprise 15-SP1 Module for Development Tools ant-antlr Released
SUSE Linux Enterprise 15-SP1 Module for Development Tools ant-junit Released
SUSE Linux Enterprise High Performance Computing 12 SP4 ant Released
SUSE Linux Enterprise High Performance Computing 12 SP5 ant Released
SUSE Linux Enterprise Server 11 SP3 LTSS ant Affected
SUSE Linux Enterprise Server 11 SP4 ant Released
SUSE Linux Enterprise Server 12 LTSS ant Affected
SUSE Linux Enterprise Server 12 SP1 LTSS ant Affected
SUSE Linux Enterprise Server 12 SP2 LTSS ant Affected
SUSE Linux Enterprise Server 12 SP3 ant Released
SUSE Linux Enterprise Server 12 SP4 ant Released
SUSE Linux Enterprise Server 12 SP5 ant Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 ant Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 ant Released
SUSE Linux Enterprise Software Development Kit 11 SP4 ant Released
SUSE Linux Enterprise Software Development Kit 12 SP3 ant Released
SUSE Linux Enterprise Software Development Kit 12 SP4 ant Released
SUSE Linux Enterprise Software Development Kit 12 SP5 ant Released