Upstream information

CVE-2018-1000805 at MITRE

Description

Paramiko version 2.4.1, 2.3.2, 2.2.3, 2.1.5, 2.0.8, 1.18.5, 1.17.6 contains a Incorrect Access Control vulnerability in SSH server that can result in RCE. This attack appear to be exploitable via network connectivity.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 9.8
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required Low None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
SUSE Bugzilla entry: 1111151 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • python-paramiko >= 2.2.4-4.3.1
Patchnames:
HPE-Helion-OpenStack-8-2019-396
Openstack Cloud Magnum Orchestration 7
  • python-paramiko >= 2.0.9-3.6.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2019-481
SUSE Enterprise Storage 4
  • python-paramiko >= 2.0.9-3.6.1
Patchnames:
SUSE-Storage-4-2019-481
SUSE Linux Enterprise Module for Basesystem 15
  • python-paramiko >= 2.4.2-3.3.2
  • python2-paramiko >= 2.4.2-3.3.2
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-174
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • python-paramiko >= 2.4.2-3.3.2
  • python-paramiko-doc >= 2.4.2-3.3.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-174
SUSE Linux Enterprise Module for Public Cloud 15
  • python-paramiko >= 2.4.2-3.3.2
  • python3-paramiko >= 2.4.2-3.3.2
Patchnames:
SUSE-SLE-Module-Public-Cloud-15-2019-174
SUSE OpenStack Cloud 7
  • python-amqp >= 1.4.9-3.3.1
  • python-oslo.messaging >= 5.10.2-3.9.1
  • python-ovs >= 2.5.0-3.3.1
  • python-paramiko >= 2.0.9-3.6.1
  • python-psql2mysql >= 0.5.0+git.1539592188.13e5d0f-1.9.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-481
SUSE OpenStack Cloud 8
  • python-paramiko >= 2.2.4-4.3.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-396
SUSE OpenStack Cloud Crowbar 8
  • python-paramiko >= 2.2.4-4.3.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-396
openSUSE Leap 15.0
  • python-paramiko-doc >= 2.4.2-lp150.2.3.1
  • python2-paramiko >= 2.4.2-lp150.2.3.1
  • python3-paramiko >= 2.4.2-lp150.2.3.1
Patchnames:
openSUSE-2019-129


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 python-paramiko Affected
HPE Helion OpenStack 8 python-paramiko Released
OpenStack Cloud Magnum Orchestration 7.0 python-paramiko Released
SUSE Linux Enterprise Module for Basesystem 15 GA python-paramiko Released
SUSE Linux Enterprise Module for Public Cloud 12 python-paramiko Affected
SUSE Linux Enterprise Module for Public Cloud 15 python-paramiko Released
SUSE Openstack Cloud 7 python-paramiko Released
SUSE Openstack Cloud 8 python-paramiko Released
SUSE Storage 4 python-paramiko Released
SUSE Storage 5 python-paramiko Affected