Upstream information

CVE-2017-2625 at MITRE

Description

It was discovered that libXdmcp before 1.1.2 including used weak entropy to generate session keys. On a multi-user system using xdmcp, a local attacker could potentially use information available from the process list to brute force the key, allowing them to hijack other users' sessions.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 2.1 4.9
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N AV:L/AC:L/Au:N/C:C/I:N/A:N
Access Vector Local Local
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial Complete
Integrity Impact None None
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
CVSSv3 Version 3
SUSE Bugzilla entries: 1025046 [RESOLVED / FIXED], 1025068 [RESOLVED / FIXED], 1025639 [RESOLVED / FIXED], 1123802 [RESOLVED / FIXED], 815650 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libXdmcp >= 1.1.1-10.1
  • libXdmcp6 >= 1.1.1-10.1
  • libXdmcp6-32bit >= 1.1.1-10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1153
SUSE Linux Enterprise Desktop 12 SP3
  • libXdmcp >= 1.1.1-12.1
  • libXdmcp6 >= 1.1.1-12.1
  • libXdmcp6-32bit >= 1.1.1-12.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-236
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • libXdmcp6 >= 1.1.1-12.1
  • libXdmcp6-32bit >= 1.1.1-12.1
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libXdmcp-devel >= 1.1.2-1.23
  • libXdmcp6 >= 1.1.2-1.23
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • xorg-x11-libXdmcp >= 7.4-3.1
  • xorg-x11-libXdmcp-32bit >= 7.4-3.1
  • xorg-x11-libXdmcp-x86 >= 7.4-3.1
Patchnames:
slessp4-xorg-x11-libXdmcp-13209
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libXdmcp >= 1.1.1-10.1
  • libXdmcp6 >= 1.1.1-10.1
  • libXdmcp6-32bit >= 1.1.1-10.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1153
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libXdmcp >= 1.1.1-12.1
  • libXdmcp6 >= 1.1.1-12.1
  • libXdmcp6-32bit >= 1.1.1-12.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-236
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libXdmcp >= 1.1.1-10.1
  • libXdmcp6 >= 1.1.1-10.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1153
SUSE Linux Enterprise Software Development Kit 11 SP4
  • xorg-x11-libXdmcp >= 7.4-3.1
  • xorg-x11-libXdmcp-32bit >= 7.4-3.1
  • xorg-x11-libXdmcp-devel >= 7.4-3.1
  • xorg-x11-libXdmcp-devel-32bit >= 7.4-3.1
Patchnames:
sdksp4-xorg-x11-libXdmcp-13209
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libXdmcp >= 1.1.1-10.1
  • libXdmcp-devel >= 1.1.1-10.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1153
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libXdmcp >= 1.1.1-12.1
  • libXdmcp-devel >= 1.1.1-12.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-236
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libXdmcp-devel >= 1.1.1-12.1
openSUSE Leap 15.0
  • libXdmcp6 >= 1.1.2-lp150.1.7
Patchnames:
openSUSE Leap 15.0 GA libXdmcp6
openSUSE Leap 42.2
  • libXdmcp >= 1.1.2-3.3.1
  • libXdmcp-debugsource >= 1.1.2-3.3.1
  • libXdmcp-devel >= 1.1.2-3.3.1
  • libXdmcp-devel-32bit >= 1.1.2-3.3.1
  • libXdmcp6 >= 1.1.2-3.3.1
  • libXdmcp6-32bit >= 1.1.2-3.3.1
  • libXdmcp6-debuginfo >= 1.1.2-3.3.1
  • libXdmcp6-debuginfo-32bit >= 1.1.2-3.3.1
Patchnames:
openSUSE-2017-789
openSUSE Leap 42.3
  • libXdmcp-devel >= 1.1.2-5.1
  • libXdmcp6 >= 1.1.2-5.1
Patchnames:
openSUSE Leap 42.3 GA libXdmcp-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 libXdmcp Unsupported
SUSE Linux Enterprise Desktop 12 SP1 xorg-x11 Not affected
SUSE Linux Enterprise Desktop 12 SP2 libXdmcp Released
SUSE Linux Enterprise Desktop 12 SP2 xorg-x11 Affected
SUSE Linux Enterprise Desktop 12 SP3 libXdmcp Released
SUSE Linux Enterprise High Performance Computing 12 SP5 libXdmcp Released
SUSE Linux Enterprise Server 11 SP1 xorg-x11 Not affected
SUSE Linux Enterprise Server 11 SP1 xorg-x11-libXdmcp Released
SUSE Linux Enterprise Server 11 SP3 xorg-x11 Not affected
SUSE Linux Enterprise Server 11 SP3 xorg-x11-libXdmcp Released
SUSE Linux Enterprise Server 11 SP4 xorg-x11 Not affected
SUSE Linux Enterprise Server 11 SP4 xorg-x11-libXdmcp Released
SUSE Linux Enterprise Server 12 SP1 libXdmcp Unsupported
SUSE Linux Enterprise Server 12 SP1 xorg-x11 Not affected
SUSE Linux Enterprise Server 12 SP2 libXdmcp Released
SUSE Linux Enterprise Server 12 SP2 xorg-x11 Not affected
SUSE Linux Enterprise Server 12 SP3 libXdmcp Released
SUSE Linux Enterprise Server 12 SP5 libXdmcp Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libXdmcp Released
SUSE Linux Enterprise Server for the Raspberry Pi libXdmcp Released
SUSE Linux Enterprise Software Development Kit 11 SP4 xorg-x11-libXdmcp Released
SUSE Linux Enterprise Software Development Kit 12 libXdmcp Released
SUSE Linux Enterprise Software Development Kit 12 SP1 libXdmcp Unsupported
SUSE Linux Enterprise Software Development Kit 12 SP3 libXdmcp Released