Upstream information

CVE-2016-9387 at MITRE

Description

Integer overflow in the jpc_dec_process_siz function in libjasper/jpc/jpc_dec.c in JasPer before 1.900.13 allows remote attackers to have unspecified impact via a crafted file, which triggers an assertion failure.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 1.9
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:L/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Local
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial None
Integrity Impact Partial None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3
SUSE Bugzilla entry: 1010960 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libjasper4 >= 2.0.14-3.3.2
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libjasper4 >= 2.0.14-3.11.8
SUSE Linux Enterprise Module for Basesystem 15
  • libjasper4 >= 2.0.14-1.19
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • libjasper-devel >= 2.0.14-3.3.2
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • libjasper-devel >= 2.0.14-3.11.8
SUSE Linux Enterprise Module for Desktop Applications 15
  • libjasper-devel >= 2.0.14-1.19
openSUSE Leap 15.0
  • libjasper4 >= 2.0.14-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libjasper4


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 ghostscript-library Unsupported
SLED-10-SP4 ghostscript-library Unsupported
SLES for SAP Applications ghostscript-library Ignore
SLES-10-SP3 ghostscript-library Unsupported
SLES-10-SP4 ghostscript-library Unsupported
SLES_LTSS-10-SP4 ghostscript-library Unsupported
SUSE Linux Enterprise 15 Module for Basesystem jasper Not affected
SUSE Linux Enterprise 15 Module for Desktop Applications jasper Not affected
SUSE Linux Enterprise 15-SP1 Module for Basesystem jasper Not affected
SUSE Linux Enterprise 15-SP1 Module for Desktop Applications jasper Not affected
SUSE Linux Enterprise Desktop 11 ghostscript-library Ignore
SUSE Linux Enterprise Desktop 11 SP1 ghostscript-library Ignore
SUSE Linux Enterprise Desktop 11 SP2 ghostscript-library Ignore
SUSE Linux Enterprise Desktop 11 SP3 ghostscript-library Ignore
SUSE Linux Enterprise Desktop 11 SP4 ghostscript-library Ignore
SUSE Linux Enterprise Desktop 12 SP1 jasper Not affected
SUSE Linux Enterprise Desktop 12 SP2 jasper Not affected
SUSE Linux Enterprise Desktop 12 SP4 jasper Not affected
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search ghostscript-library Ignore
SUSE Linux Enterprise High Performance Computing 12 SP4 jasper Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 jasper Released
SUSE Linux Enterprise Server 11 ghostscript-library Ignore
SUSE Linux Enterprise Server 11 SP1 ghostscript-library Ignore
SUSE Linux Enterprise Server 11 SP1 LTSS ghostscript-library Ignore
SUSE Linux Enterprise Server 11 SP2 ghostscript-library Ignore
SUSE Linux Enterprise Server 11 SP2 LTSS ghostscript-library Ignore
SUSE Linux Enterprise Server 11 SP2 for VMware ghostscript-library Ignore
SUSE Linux Enterprise Server 11 SP3 ghostscript-library Ignore
SUSE Linux Enterprise Server 11 SP3 LTSS ghostscript-library Ignore
SUSE Linux Enterprise Server 11 SP3 for VMware ghostscript-library Ignore
SUSE Linux Enterprise Server 11 SP4 ghostscript-library Ignore
SUSE Linux Enterprise Server 11 SP4 jasper Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS ghostscript-library Ignore
SUSE Linux Enterprise Server 11 SP4 LTSS jasper Not affected
SUSE Linux Enterprise Server 12 SP1 jasper Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS jasper Not affected
SUSE Linux Enterprise Server 12 SP2 jasper Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS jasper Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS jasper Not affected
SUSE Linux Enterprise Server 12 SP4 jasper Not affected
SUSE Linux Enterprise Server 12 SP5 jasper Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 jasper Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 jasper Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 jasper Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 jasper Released
SUSE Linux Enterprise Server for SAP Business All-in-One ghostscript-library Ignore
SUSE Linux Enterprise Software Development Kit 11 ghostscript-library Ignore
SUSE Linux Enterprise Software Development Kit 11 SP1 ghostscript-library Ignore
SUSE Linux Enterprise Software Development Kit 11 SP2 ghostscript-library Ignore
SUSE Linux Enterprise Software Development Kit 11 SP3 ghostscript-library Ignore
SUSE Linux Enterprise Software Development Kit 11 SP4 ghostscript-library Ignore
SUSE Linux Enterprise Software Development Kit 11 SP4 jasper Not affected
SUSE Linux Enterprise Software Development Kit 12 jasper Not affected
SUSE Linux Enterprise Software Development Kit 12 SP1 jasper Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 jasper Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 jasper Not affected