Upstream information

CVE-2016-4476 at MITRE

Description

hostapd 0.6.7 through 2.5 and wpa_supplicant 0.6.7 through 2.5 do not reject \n and \r characters in passphrase parameters, which allows remote attackers to cause a denial of service (daemon outage) via a crafted WPS operation.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 1.9
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:L/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Local
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 978172 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • wpa_supplicant >= 2.6-15.10.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • wpa_supplicant >= 2.6-4.11.1
SUSE Linux Enterprise Module for Basesystem 15
  • wpa_supplicant >= 2.6-2.50
openSUSE Leap 15.0
  • wpa_supplicant >= 2.6-lp150.2.13
Patchnames:
openSUSE Leap 15.0 GA wpa_supplicant
openSUSE Leap 42.2
  • hostapd >= 2.6-5.3.1
  • hostapd-debuginfo >= 2.6-5.3.1
  • hostapd-debugsource >= 2.6-5.3.1
Patchnames:
openSUSE-2017-1201
openSUSE Leap 42.3
  • hostapd >= 2.6-8.1
  • hostapd-debuginfo >= 2.6-8.1
  • hostapd-debugsource >= 2.6-8.1
Patchnames:
openSUSE-2017-1201
openSUSE Tumbleweed
  • hostapd >= 2.6-1.1
  • wpa_supplicant >= 2.6-1.1
  • wpa_supplicant-gui >= 2.6-1.1
Patchnames:
openSUSE Tumbleweed GA hostapd
openSUSE Tumbleweed GA wpa_supplicant


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP4 wpa_supplicant Affected
SUSE Linux Enterprise Desktop 12 wpa_supplicant Affected
SUSE Linux Enterprise Desktop 12 SP1 wpa_supplicant Unsupported
SUSE Linux Enterprise Server 11 SP1 wpa_supplicant Affected
SUSE Linux Enterprise Server 11 SP2 LTSS wpa_supplicant Affected
SUSE Linux Enterprise Server 11 SP3 wpa_supplicant Affected
SUSE Linux Enterprise Server 11 SP3 LTSS wpa_supplicant Affected
SUSE Linux Enterprise Server 11 SP4 wpa_supplicant Affected
SUSE Linux Enterprise Server 12 wpa_supplicant Affected
SUSE Linux Enterprise Server 12 SP1 wpa_supplicant Unsupported
SUSE Linux Enterprise Server for SAP Applications 12 SP3 wpa_supplicant Affected