Upstream information

CVE-2016-10010 at MITRE

Description

sshd in OpenSSH before 7.4, when privilege separation is not used, creates forwarded Unix-domain sockets as root, which might allow local users to gain privileges via unspecified vectors, related to serverloop.c.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.9 7.1
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C AV:N/AC:H/Au:S/C:C/I:C/A:C
Access Vector Local Network
Access Complexity Medium High
Authentication None Single
Confidentiality Impact Complete Complete
Integrity Impact Complete Complete
Availability Impact Complete Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 7
Vector CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity High
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3

Note from the SUSE Security Team

This issue only affects SUSE Linux Enterprise 12 SP2, older Enterprise versions have older openssh versions which do not support UNIX domain socket forwarding. The vulnerability also only works with privilege seperation turned off, which is not the default.

SUSE Bugzilla entries: 1016336 [IN_PROGRESS], 1016368 [RESOLVED / FIXED], 1021751 [RESOLVED / FIXED], 1025354 [RESOLVED / WORKSFORME]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • openssh >= 7.2p2-66.1
  • openssh-askpass-gnome >= 7.2p2-66.3
  • openssh-helpers >= 7.2p2-66.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-138
SUSE Linux Enterprise Desktop 12 SP3
  • openssh >= 7.2p2-69.1
  • openssh-helpers >= 7.2p2-69.1
SUSE Linux Enterprise Desktop 12 SP4
  • openssh >= 7.2p2-74.25.1
  • openssh-helpers >= 7.2p2-74.25.1
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP5
  • openssh >= 7.2p2-74.45.1
  • openssh-fips >= 7.2p2-74.45.1
  • openssh-helpers >= 7.2p2-74.45.1
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • openssh >= 7.9p1-4.7
  • openssh-helpers >= 7.9p1-4.7
SUSE Linux Enterprise Module for Basesystem 15
  • openssh >= 7.6p1-7.8
  • openssh-helpers >= 7.6p1-7.8
SUSE Linux Enterprise Module for Server Applications 15 SP1
  • openssh-fips >= 7.9p1-4.7
SUSE Linux Enterprise Module for Server Applications 15
  • openssh-fips >= 7.6p1-7.8
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • openssh >= 7.2p2-66.1
  • openssh-askpass-gnome >= 7.2p2-66.3
  • openssh-fips >= 7.2p2-66.1
  • openssh-helpers >= 7.2p2-66.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-138
SUSE Linux Enterprise Server 12 SP3
  • openssh >= 7.2p2-69.1
  • openssh-fips >= 7.2p2-69.1
  • openssh-helpers >= 7.2p2-69.1
SUSE Linux Enterprise Server 12 SP4
  • openssh >= 7.2p2-74.25.1
  • openssh-fips >= 7.2p2-74.25.1
  • openssh-helpers >= 7.2p2-74.25.1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • openssh >= 7.2p2-66.1
  • openssh-askpass-gnome >= 7.2p2-66.3
  • openssh-fips >= 7.2p2-66.1
  • openssh-helpers >= 7.2p2-66.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-138
openSUSE Leap 15.0
  • openssh >= 7.6p1-lp150.7.4
  • openssh-helpers >= 7.6p1-lp150.7.4
Patchnames:
openSUSE Leap 15.0 GA openssh
openSUSE Leap 42.2
  • openssh >= 7.2p2-9.1
  • openssh-askpass-gnome >= 7.2p2-9.1
  • openssh-askpass-gnome-debuginfo >= 7.2p2-9.1
  • openssh-cavs >= 7.2p2-9.1
  • openssh-debuginfo >= 7.2p2-9.1
  • openssh-debugsource >= 7.2p2-9.1
  • openssh-fips >= 7.2p2-9.1
  • openssh-helpers >= 7.2p2-9.1
  • openssh-helpers-debuginfo >= 7.2p2-9.1
Patchnames:
openSUSE-2017-184
openSUSE Leap 42.3
  • openssh >= 7.2p2-13.1
  • openssh-helpers >= 7.2p2-13.1
Patchnames:
openSUSE Leap 42.3 GA openssh


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 openssh Not affected
SUSE Linux Enterprise Desktop 12 SP2 openssh Released
SUSE Linux Enterprise Server 11 SP4 openssh Not affected
SUSE Linux Enterprise Server 11-SECURITY openssh-openssl1 Not affected
SUSE Linux Enterprise Server 12 SP1 openssh Not affected
SUSE Linux Enterprise Server 12 SP2 openssh Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI openssh Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 openssh Released