Upstream information

CVE-2015-7218 at MITRE

Description

The HTTP/2 implementation in Mozilla Firefox before 43.0 allows remote attackers to cause a denial of service (integer underflow, assertion failure, and application exit) via a single-byte header frame that triggers incorrect memory allocation.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 959277 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • MozillaFirefox >= 60.6.2-3.32.1
  • MozillaFirefox-devel >= 60.6.2-3.32.1
  • MozillaFirefox-translations-common >= 60.6.2-3.32.1
  • MozillaFirefox-translations-other >= 60.6.2-3.32.1
SUSE Linux Enterprise Module for Desktop Applications 15
  • MozillaFirefox >= 52.7.3-1.35
  • MozillaFirefox-devel >= 52.7.3-1.35
  • MozillaFirefox-translations-common >= 52.7.3-1.35
  • MozillaFirefox-translations-other >= 52.7.3-1.35
openSUSE 13.1
  • MozillaFirefox >= 43.0-97.1
  • MozillaFirefox-branding-upstream >= 43.0-97.1
  • MozillaFirefox-buildsymbols >= 43.0-97.1
  • MozillaFirefox-debuginfo >= 43.0-97.1
  • MozillaFirefox-debugsource >= 43.0-97.1
  • MozillaFirefox-devel >= 43.0-97.1
  • MozillaFirefox-translations-common >= 43.0-97.1
  • MozillaFirefox-translations-other >= 43.0-97.1
  • seamonkey >= 2.40-62.1
  • seamonkey-debuginfo >= 2.40-62.1
  • seamonkey-debugsource >= 2.40-62.1
  • seamonkey-dom-inspector >= 2.40-62.1
  • seamonkey-irc >= 2.40-62.1
  • seamonkey-translations-common >= 2.40-62.1
  • seamonkey-translations-other >= 2.40-62.1
Patchnames:
2016-129
openSUSE-2015-942
openSUSE Leap 15.0
  • MozillaFirefox >= 60.0-lp150.2.2
  • MozillaFirefox-translations-common >= 60.0-lp150.2.2
  • MozillaFirefox-translations-other >= 60.0-lp150.2.2
Patchnames:
openSUSE Leap 15.0 GA MozillaFirefox
openSUSE Leap 42.1
  • MozillaFirefox >= 43.0-6.1
  • MozillaFirefox-branding-upstream >= 43.0-6.1
  • MozillaFirefox-buildsymbols >= 43.0-6.1
  • MozillaFirefox-debuginfo >= 43.0-6.1
  • MozillaFirefox-debugsource >= 43.0-6.1
  • MozillaFirefox-devel >= 43.0-6.1
  • MozillaFirefox-translations-common >= 43.0-6.1
  • MozillaFirefox-translations-other >= 43.0-6.1
  • seamonkey >= 2.40-6.2
  • seamonkey-debuginfo >= 2.40-6.2
  • seamonkey-debugsource >= 2.40-6.2
  • seamonkey-dom-inspector >= 2.40-6.2
  • seamonkey-irc >= 2.40-6.2
  • seamonkey-translations-common >= 2.40-6.2
  • seamonkey-translations-other >= 2.40-6.2
Patchnames:
openSUSE-2015-942
openSUSE-2016-126
openSUSE Leap 42.2
  • MozillaFirefox >= 49.0.2-37.1
  • MozillaFirefox-translations-common >= 49.0.2-37.1
Patchnames:
openSUSE Leap 42.2 GA MozillaFirefox
openSUSE Leap 42.3
  • MozillaFirefox >= 52.2-58.2
  • MozillaFirefox-translations-common >= 52.2-58.2
Patchnames:
openSUSE Leap 42.3 GA MozillaFirefox
openSUSE Tumbleweed
  • MozillaFirefox >= 50.1.0-1.1
  • MozillaFirefox-branding-upstream >= 50.1.0-1.1
  • MozillaFirefox-buildsymbols >= 50.1.0-1.1
  • MozillaFirefox-devel >= 50.1.0-1.1
  • MozillaFirefox-translations-common >= 50.1.0-1.1
  • MozillaFirefox-translations-other >= 50.1.0-1.1
  • seamonkey >= 2.40-6.1
  • seamonkey-dom-inspector >= 2.40-6.1
  • seamonkey-irc >= 2.40-6.1
  • seamonkey-translations-common >= 2.40-6.1
  • seamonkey-translations-other >= 2.40-6.1
Patchnames:
openSUSE Tumbleweed GA MozillaFirefox
openSUSE Tumbleweed GA seamonkey


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 MozillaFirefox Released
SLED-10-SP4 MozillaFirefox Released
SLES for SAP Applications MozillaFirefox Released
SLES-10-SP3 MozillaFirefox Released
SLES-10-SP4 MozillaFirefox Released
SLES_LTSS-10-SP4 MozillaFirefox Released
SUSE Linux Enterprise Desktop 11 SP2 MozillaFirefox Released
SUSE Linux Enterprise Desktop 11 SP3 MozillaFirefox Released
SUSE Linux Enterprise Desktop 11 SP4 MozillaFirefox Released
SUSE Linux Enterprise Desktop 12 MozillaFirefox Released
SUSE Linux Enterprise Desktop 12 SP1 MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP1 MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP1 LTSS MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP2 MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP2 LTSS MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP2 for VMware MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP3 MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP3 LTSS MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP3 for VMware MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP4 MozillaFirefox Released
SUSE Linux Enterprise Server 12 MozillaFirefox Released
SUSE Linux Enterprise Server 12 SP1 MozillaFirefox Released
SUSE Linux Enterprise Software Development Kit 11 SP3 MozillaFirefox Released
SUSE Linux Enterprise Software Development Kit 11 SP4 MozillaFirefox Released
SUSE Linux Enterprise Software Development Kit 12 MozillaFirefox Released
SUSE Linux Enterprise Software Development Kit 12 SP1 MozillaFirefox Released