Upstream information

CVE-2012-3410 at MITRE

Description

Stack-based buffer overflow in lib/sh/eaccess.c in GNU Bash before 4.2 patch 33 might allow local users to bypass intended restricted shell access via a long filename in /dev/fd, which is not properly handled when expanding the /dev/fd prefix.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 770795 [RESOLVED / FIXED], 826692 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • bash >= 3.2-147.12.1
  • bash-doc >= 3.2-147.12.1
  • bash-x86 >= 3.2-147.12.1
  • libreadline5 >= 5.2-147.12.1
  • libreadline5-32bit >= 5.2-147.14.22.1
  • libreadline5-x86 >= 5.2-147.12.1
  • readline-doc >= 5.2-147.12.1
Patchnames:
slessp1-bash
SUSE Linux Enterprise Server 11 SP2
  • bash >= 3.2-147.12.1
  • bash-doc >= 3.2-147.12.1
  • bash-x86 >= 3.2-147.12.1
  • libreadline5 >= 5.2-147.12.1
  • libreadline5-32bit >= 5.2-147.12.1
  • libreadline5-x86 >= 5.2-147.12.1
  • readline-doc >= 5.2-147.12.1
Patchnames:
slessp1-bash
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • bash >= 3.1-24.30.1
  • readline >= 5.1-24.30.1
  • readline-devel >= 5.1-24.30.1
Builds
ZYPP Patch Nr: 8217
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • bash >= 3.1-24.30.1
  • readline >= 5.1-24.30.1
  • readline-32bit >= 5.1-24.30.1
  • readline-devel >= 5.1-24.30.1
  • readline-devel-32bit >= 5.1-24.30.1
Builds
ZYPP Patch Nr: 8217
SUSE Linux Enterprise Server 10 SP4 for IPF
  • bash >= 3.1-24.30.1
  • bash-x86 >= 3.1-24.30.1
  • readline >= 5.1-24.30.1
  • readline-devel >= 5.1-24.30.1
  • readline-x86 >= 5.1-24.30.1
Builds
ZYPP Patch Nr: 8217
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • bash >= 3.1-24.30.1
  • readline >= 5.1-24.30.1
  • readline-64bit >= 5.1-24.30.1
  • readline-devel >= 5.1-24.30.1
  • readline-devel-64bit >= 5.1-24.30.1
Builds
ZYPP Patch Nr: 8217
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libreadline5 >= 5.2-147.12.1
  • readline-devel >= 5.2-147.12.1
Builds
SAT Patch Nr: 6541
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • readline-devel >= 5.2-147.12.1
Builds
SAT Patch Nr: 6541
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • readline-devel >= 5.2-147.12.1
  • readline-devel-32bit >= 5.2-147.12.1
Builds
SAT Patch Nr: 6541
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libreadline5 >= 5.2-147.12.1
  • readline-devel >= 5.2-147.12.1
  • readline-devel-32bit >= 5.2-147.12.1
Builds
SAT Patch Nr: 6541
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • bash >= 3.2-147.12.1
  • bash-doc >= 3.2-147.12.1
  • libreadline5 >= 5.2-147.12.1
  • readline-doc >= 5.2-147.12.1
Builds
SAT Patch Nr: 6541
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • bash >= 3.2-147.12.1
  • bash-doc >= 3.2-147.12.1
  • libreadline5 >= 5.2-147.12.1
  • libreadline5-32bit >= 5.2-147.12.1
  • readline-doc >= 5.2-147.12.1
Builds
SAT Patch Nr: 6541
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
  • bash >= 3.2-147.12.1
  • bash-doc >= 3.2-147.12.1
  • bash-x86 >= 3.2-147.12.1
  • libreadline5 >= 5.2-147.12.1
  • libreadline5-x86 >= 5.2-147.12.1
  • readline-doc >= 5.2-147.12.1
Builds
SAT Patch Nr: 6541
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • bash >= 3.1-24.32.1
  • readline >= 5.1-24.32.1
  • readline-devel >= 5.1-24.32.1
Builds
ZYPP Patch Nr: 8951
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
  • bash >= 3.1-24.32.1
  • readline >= 5.1-24.32.1
  • readline-32bit >= 5.1-24.32.1
  • readline-devel >= 5.1-24.32.1
  • readline-devel-32bit >= 5.1-24.32.1
Builds
ZYPP Patch Nr: 8951
openSUSE 11.4
  • bash >= 4.1-20.28.1
  • bash-debuginfo >= 4.1-20.28.1
  • bash-debuginfo-32bit >= 4.1-20.28.1
  • bash-debuginfo-x86 >= 4.1-20.28.1
  • bash-debugsource >= 4.1-20.28.1
  • bash-devel >= 4.1-18.28.1
  • bash-doc >= 4.1-18.28.1
  • bash-lang >= 4.1-20.28.1
  • bash-loadables >= 4.1-18.28.1
  • bash-loadables-debuginfo >= 4.1-18.28.1
  • bash-x86 >= 4.1-20.28.1
  • libreadline6 >= 6.1-18.28.1
  • libreadline6-32bit >= 6.1-18.28.1
  • libreadline6-debuginfo >= 6.1-18.28.1
  • libreadline6-debuginfo-32bit >= 6.1-18.28.1
  • libreadline6-debuginfo-x86 >= 6.1-18.28.1
  • libreadline6-x86 >= 6.1-18.28.1
  • readline-devel >= 6.1-18.28.1
  • readline-devel-32bit >= 6.1-18.28.1
  • readline-doc >= 6.1-18.28.1
Patchnames:
openSUSE-2012-408


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 bash Released
SLED-10-SP4 bash Released
SLES-10-SP3 bash Released
SLES-10-SP4 bash Released
SLES_LTSS-10-SP4 bash Released
SUSE Linux Enterprise Desktop 11 SP1 bash Released
SUSE Linux Enterprise Desktop 11 SP2 bash Released
SUSE Linux Enterprise Desktop 11 SP3 bash Released
SUSE Linux Enterprise Server 11 SP1 bash Released
SUSE Linux Enterprise Server 11 SP1 LTSS bash Released
SUSE Linux Enterprise Server 11 SP2 bash Released
SUSE Linux Enterprise Server 11 SP2 LTSS bash Released
SUSE Linux Enterprise Server 11 SP2 for VMware bash Released
SUSE Linux Enterprise Server 11 SP3 bash Released
SUSE Linux Enterprise Server 11 SP3 for VMware bash Released
SUSE Linux Enterprise Server for SAP Business All-in-One bash Released
SUSE Linux Enterprise Software Development Kit 11 SP1 bash Released
SUSE Linux Enterprise Software Development Kit 11 SP2 bash Released
SUSE Linux Enterprise Software Development Kit 11 SP3 bash Released