Upstream information

CVE-2011-1145 at MITRE

Description

The SQLDriverConnect() function in unixODBC before 2.2.14p2 have a possible buffer overflow condition when specifying a large value for SAVEFILE parameter in the connection string.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entries: 678796 [RESOLVED / FIXED], 764737 [RESOLVED / INVALID]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
SUSE Linux Enterprise Desktop 12 SP3
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server 12 SP3
  • unixODBC >= 2.3.4-6.5
  • unixODBC-32bit >= 2.3.4-6.5
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • unixODBC >= 2.3.6-7.9.1
  • unixODBC-32bit >= 2.3.6-7.9.1
SUSE Linux Enterprise Desktop 12
SUSE Linux Enterprise Desktop 12 SP1
SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 SP1
  • unixODBC >= 2.3.1-4.95
  • unixODBC-32bit >= 2.3.1-4.95
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • unixODBC >= 2.3.6-1.12
  • unixODBC-devel >= 2.3.6-1.12
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP4
  • unixODBC_23 >= 2.3.1-0.9.40
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • unixODBC >= 2.3.4-6.5
SUSE Linux Enterprise Software Development Kit 11 SP4
  • unixODBC_23-devel >= 2.3.1-0.9.40
SUSE Linux Enterprise Software Development Kit 12 SP2
SUSE Linux Enterprise Software Development Kit 12 SP3
  • unixODBC-devel >= 2.3.4-6.5
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • unixODBC-devel >= 2.3.6-7.9.1
SUSE Linux Enterprise Software Development Kit 12
SUSE Linux Enterprise Software Development Kit 12 SP1
  • unixODBC-devel >= 2.3.1-4.95
openSUSE 11.3
  • unixODBC-debuginfo >= 2.2.12-204.3.1
  • unixODBC-debuginfo-32bit >= 2.2.12-204.3.1
  • unixODBC-debugsource >= 2.2.12-204.3.1
openSUSE 11.3
  • unixODBC >= 2.2.12-204.3.1
  • unixODBC-32bit >= 2.2.12-204.3.1
  • unixODBC-devel >= 2.2.12-204.3.1
  • unixODBC-devel-32bit >= 2.2.12-204.3.1
openSUSE 11.4
  • unixODBC >= 2.2.12-207.208.1
  • unixODBC-32bit >= 2.2.12-207.208.1
  • unixODBC-devel >= 2.2.12-207.208.1
  • unixODBC-devel-32bit >= 2.2.12-207.208.1
openSUSE 11.4
  • unixODBC >= 2.2.12-207.208.1
  • unixODBC-32bit >= 2.2.12-207.208.1
  • unixODBC-debuginfo >= 2.2.12-207.208.1
  • unixODBC-debuginfo-32bit >= 2.2.12-207.208.1
  • unixODBC-debugsource >= 2.2.12-207.208.1
  • unixODBC-devel >= 2.2.12-207.208.1
  • unixODBC-devel-32bit >= 2.2.12-207.208.1
Patchnames:
unixODBC
openSUSE Leap 15.0
  • unixODBC >= 2.3.6-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA unixODBC
openSUSE Leap 42.1
  • unixODBC >= 2.3.1-3.2
  • unixODBC-32bit >= 2.3.1-3.2
Patchnames:
openSUSE Leap 42.1 GA unixODBC
openSUSE Leap 42.2
  • unixODBC >= 2.3.4-1.5
Patchnames:
openSUSE Leap 42.2 GA unixODBC
openSUSE Leap 42.3
  • unixODBC >= 2.3.4-3.3
Patchnames:
openSUSE Leap 42.3 GA unixODBC
openSUSE Tumbleweed
  • unixODBC >= 2.3.4-3.5
  • unixODBC-32bit >= 2.3.4-3.5
  • unixODBC-devel >= 2.3.4-3.5
Patchnames:
openSUSE Tumbleweed GA unixODBC


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
unixODBC Released
SLED-10-SP3 unixODBC Affected
SLED-10-SP4 unixODBC Affected
SLES for SAP Applications unixODBC Released
SLES-10-SP3 unixODBC Affected
SLES-10-SP4 unixODBC Affected
SLES_LTSS-10-SP4 unixODBC Affected
SUSE Linux Enterprise Desktop 11 SP1 unixODBC In progress
SUSE Linux Enterprise Desktop 11 SP2 unixODBC Released
SUSE Linux Enterprise Desktop 11 SP3 unixODBC Released
SUSE Linux Enterprise Desktop 11 SP4 unixODBC Released
SUSE Linux Enterprise Server 11 SP1 unixODBC Affected
SUSE Linux Enterprise Server 11 SP1 LTSS unixODBC Released
SUSE Linux Enterprise Server 11 SP2 unixODBC Released
SUSE Linux Enterprise Server 11 SP2 LTSS unixODBC Released
SUSE Linux Enterprise Server 11 SP2 for VMware unixODBC Released
SUSE Linux Enterprise Server 11 SP3 unixODBC In progress
SUSE Linux Enterprise Server 11 SP3 unixODBC-gui-qt In progress
SUSE Linux Enterprise Server 11 SP3 LTSS unixODBC Released
SUSE Linux Enterprise Server 11 SP3 for VMware unixODBC Released
SUSE Linux Enterprise Server 11 SP4 unixODBC In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP3 unixODBC Analysis
SUSE Linux Enterprise Server for SAP Business All-in-One unixODBC Affected
SUSE Linux Enterprise Software Development Kit 11 SP1 unixODBC Affected
SUSE Linux Enterprise Software Development Kit 11 SP2 unixODBC Released
SUSE Linux Enterprise Software Development Kit 11 SP3 unixODBC Released
SUSE Linux Enterprise Software Development Kit 11 SP4 unixODBC In progress