Upstream information

CVE-2010-1128 at MITRE

Description

The Linear Congruential Generator (LCG) in PHP before 5.2.13 does not provide the expected entropy, which makes it easier for context-dependent attackers to guess values that were intended to be unpredictable, as demonstrated by session cookies generated by using the uniqid function.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 629443 [RESOLVED / DUPLICATE]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications php5 Already fixed
SLES for SAP Applications php53 Already fixed
SLES-10-SP3 php5 Already fixed
SLES-10-SP4 php5 Already fixed
SLES_LTSS-10-SP4 php5 Already fixed
SUSE Linux Enterprise 12 Module for Web and Scripting php5 Already fixed
SUSE Linux Enterprise 12 Module for Web and Scripting php7 Already fixed
SUSE Linux Enterprise 12 Module for Web and Scripting php72 Already fixed
SUSE Linux Enterprise 15 Module for Web and Scripting php7 Already fixed
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search php5 Already fixed
SUSE Linux Enterprise Server 11 SP1 php5 Already fixed
SUSE Linux Enterprise Server 11 SP1 LTSS php5 Already fixed
SUSE Linux Enterprise Server 11 SP2 php5 Already fixed
SUSE Linux Enterprise Server 11 SP2 php53 Already fixed
SUSE Linux Enterprise Server 11 SP2 LTSS php5 Already fixed
SUSE Linux Enterprise Server 11 SP2 LTSS php53 Already fixed
SUSE Linux Enterprise Server 11 SP2 for VMware php5 Already fixed
SUSE Linux Enterprise Server 11 SP2 for VMware php53 Already fixed
SUSE Linux Enterprise Server 11 SP3 php53 Already fixed
SUSE Linux Enterprise Server 11 SP3 LTSS php53 Already fixed
SUSE Linux Enterprise Server 11 SP3 for VMware php53 Already fixed
SUSE Linux Enterprise Server 11 SP4 php53 Already fixed
SUSE Linux Enterprise Server for SAP Business All-in-One php5 Already fixed
SUSE Linux Enterprise Software Development Kit 11 php5 Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP1 php5 Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP2 php5 Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP2 php53 Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP3 php53 Already fixed
SUSE Linux Enterprise Software Development Kit 11 SP4 php53 Already fixed
SUSE Linux Enterprise Software Development Kit 12 php5 Already fixed
SUSE Linux Enterprise Software Development Kit 12 php7 Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP1 php5 Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP1 php7 Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP3 php5 Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP3 php7 Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP3 php72 Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP4 php5 Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP4 php7 Already fixed