Upstream information

CVE-2006-7246 at MITRE

Description

NetworkManager 0.9.x does not pin a certificate's subject to an ESSID when 802.11X authentication is used.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

SUSE Bugzilla entries: 1047509 [RESOLVED / FIXED], 1047511 [REOPENED], 574266 [ASSIGNED], 777228 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libnm0 >= 1.10.6-5.3.1
  • typelib-1_0-NM-1_0 >= 1.10.6-5.3.1
SUSE Linux Enterprise Module for Basesystem 15 SP2
  • libnm0 >= 1.22.6-1.36
  • typelib-1_0-NM-1_0 >= 1.22.6-1.36
SUSE Linux Enterprise Module for Basesystem 15
  • libnm0 >= 1.10.6-3.16
  • typelib-1_0-NM-1_0 >= 1.10.6-3.16
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • NetworkManager >= 1.10.6-5.3.1
  • NetworkManager-devel >= 1.10.6-5.3.1
  • libnm-glib-vpn1 >= 1.10.6-5.3.1
  • libnm-glib4 >= 1.10.6-5.3.1
  • libnm-util2 >= 1.10.6-5.3.1
  • typelib-1_0-NMClient-1_0 >= 1.10.6-5.3.1
  • typelib-1_0-NetworkManager-1_0 >= 1.10.6-5.3.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP2
  • NetworkManager >= 1.22.6-1.36
  • NetworkManager-devel >= 1.22.6-1.36
SUSE Linux Enterprise Module for Desktop Applications 15
  • NetworkManager >= 1.10.6-3.16
  • NetworkManager-devel >= 1.10.6-3.16
  • libnm-glib-vpn1 >= 1.10.6-3.16
  • libnm-glib4 >= 1.10.6-3.16
  • libnm-util2 >= 1.10.6-3.16
  • typelib-1_0-NMClient-1_0 >= 1.10.6-3.16
  • typelib-1_0-NetworkManager-1_0 >= 1.10.6-3.16
SUSE Linux Enterprise Server 11 SP1
  • NetworkManager >= 0.7.1_git20090811-3.9.9.5
  • NetworkManager-glib >= 0.7.1_git20090811-3.9.9.5
  • NetworkManager-gnome >= 0.7.1-5.15.11.1
  • wpa_supplicant >= 0.6.9-4.5.4
Patchnames:
slessp1-NetworkManager
slessp1-NetworkManager-gnome
SUSE Linux Enterprise Workstation Extension 15 SP1
  • NetworkManager-lang >= 1.10.6-5.3.1
SUSE Linux Enterprise Workstation Extension 15 SP2
  • NetworkManager-lang >= 1.22.6-1.36
SUSE Linux Enterprise Workstation Extension 15
  • NetworkManager-lang >= 1.10.6-3.16
openSUSE 11.4
  • NetworkManager >= 0.8.2-15.28.1
  • NetworkManager-debuginfo >= 0.8.2-15.28.1
  • NetworkManager-debugsource >= 0.8.2-15.28.1
  • NetworkManager-devel >= 0.8.2-15.28.1
  • NetworkManager-doc >= 0.8.2-15.28.1
  • NetworkManager-glib >= 0.8.2-15.28.1
  • NetworkManager-glib-debuginfo >= 0.8.2-15.28.1
  • NetworkManager-gnome >= 0.8.2-9.16.1
  • NetworkManager-gnome-debuginfo >= 0.8.2-9.16.1
  • NetworkManager-gnome-debugsource >= 0.8.2-9.16.1
  • NetworkManager-gnome-lang >= 0.8.2-9.16.1
  • NetworkManager-lang >= 0.8.2-15.28.1
  • wpa_supplicant >= 0.7.3-3.4.1
  • wpa_supplicant-debuginfo >= 0.7.3-3.4.1
  • wpa_supplicant-debugsource >= 0.7.3-3.4.1
  • wpa_supplicant-gui >= 0.7.3-3.4.1
  • wpa_supplicant-gui-debuginfo >= 0.7.3-3.4.1
Patchnames:
NetworkManager
NetworkManager-gnome
openSUSE 12.3
  • NetworkManager >= 0.9.6.4-5.6.1
  • NetworkManager-debuginfo >= 0.9.6.4-5.6.1
  • NetworkManager-debugsource >= 0.9.6.4-5.6.1
  • NetworkManager-devel >= 0.9.6.4-5.6.1
  • NetworkManager-devel-32bit >= 0.9.6.4-5.6.1
  • NetworkManager-gnome >= 0.9.6.4-2.5.1
  • NetworkManager-gnome-debuginfo >= 0.9.6.4-2.5.1
  • NetworkManager-gnome-debugsource >= 0.9.6.4-2.5.1
  • NetworkManager-gnome-lang >= 0.9.6.4-2.5.1
  • NetworkManager-lang >= 0.9.6.4-5.6.1
  • gnome-control-center >= 3.6.3-3.14.1
  • gnome-control-center-branding-upstream >= 3.6.3-3.14.1
  • gnome-control-center-debuginfo >= 3.6.3-3.14.1
  • gnome-control-center-debugsource >= 3.6.3-3.14.1
  • gnome-control-center-devel >= 3.6.3-3.14.1
  • gnome-control-center-lang >= 3.6.3-3.14.1
  • gnome-control-center-user-faces >= 3.6.3-3.14.1
  • libnm-glib-vpn1 >= 0.9.6.4-5.6.1
  • libnm-glib-vpn1-32bit >= 0.9.6.4-5.6.1
  • libnm-glib-vpn1-debuginfo >= 0.9.6.4-5.6.1
  • libnm-glib-vpn1-debuginfo-32bit >= 0.9.6.4-5.6.1
  • libnm-glib4 >= 0.9.6.4-5.6.1
  • libnm-glib4-32bit >= 0.9.6.4-5.6.1
  • libnm-glib4-debuginfo >= 0.9.6.4-5.6.1
  • libnm-glib4-debuginfo-32bit >= 0.9.6.4-5.6.1
  • libnm-gtk-devel >= 0.9.6.4-2.5.1
  • libnm-gtk0 >= 0.9.6.4-2.5.1
  • libnm-gtk0-debuginfo >= 0.9.6.4-2.5.1
  • libnm-util2 >= 0.9.6.4-5.6.1
  • libnm-util2-32bit >= 0.9.6.4-5.6.1
  • libnm-util2-debuginfo >= 0.9.6.4-5.6.1
  • libnm-util2-debuginfo-32bit >= 0.9.6.4-5.6.1
  • typelib-1_0-NMClient-1_0 >= 0.9.6.4-5.6.1
  • typelib-1_0-NetworkManager-1_0 >= 0.9.6.4-5.6.1
Patchnames:
openSUSE-2013-333
openSUSE Leap 15.0
  • NetworkManager >= 1.10.6-lp150.3.1
  • NetworkManager-lang >= 1.10.6-lp150.3.1
  • libnm-glib-vpn1 >= 1.10.6-lp150.3.1
  • libnm-glib4 >= 1.10.6-lp150.3.1
  • libnm-util2 >= 1.10.6-lp150.3.1
  • libnm0 >= 1.10.6-lp150.3.1
  • typelib-1_0-NM-1_0 >= 1.10.6-lp150.3.1
  • typelib-1_0-NMClient-1_0 >= 1.10.6-lp150.3.1
  • typelib-1_0-NetworkManager-1_0 >= 1.10.6-lp150.3.1
Patchnames:
openSUSE Leap 15.0 GA NetworkManager
openSUSE Tumbleweed
  • NetworkManager >= 1.4.2-1.2
  • NetworkManager-branding-upstream >= 1.4.2-1.2
  • NetworkManager-devel >= 1.4.2-1.2
  • NetworkManager-devel-32bit >= 1.4.2-1.2
  • NetworkManager-lang >= 1.4.2-1.2
  • libnm-glib-vpn1 >= 1.4.2-1.2
  • libnm-glib-vpn1-32bit >= 1.4.2-1.2
  • libnm-glib4 >= 1.4.2-1.2
  • libnm-glib4-32bit >= 1.4.2-1.2
  • libnm-util2 >= 1.4.2-1.2
  • libnm-util2-32bit >= 1.4.2-1.2
  • libnm0 >= 1.4.2-1.2
  • typelib-1_0-NM-1_0 >= 1.4.2-1.2
  • typelib-1_0-NMClient-1_0 >= 1.4.2-1.2
  • typelib-1_0-NetworkManager-1_0 >= 1.4.2-1.2
Patchnames:
openSUSE Tumbleweed GA NetworkManager


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 NetworkManager Released
SLED-10-SP3 wpa_supplicant Released
SLED-10-SP4 NetworkManager Released
SLED-10-SP4 wpa_supplicant Released
SLES-10-SP3 NetworkManager Released
SLES-10-SP3 wpa_supplicant Released
SLES-10-SP4 NetworkManager Released
SLES-10-SP4 wpa_supplicant Released
SLES_LTSS-10-SP4 NetworkManager Released
SLES_LTSS-10-SP4 wpa_supplicant Released
SUSE Linux Enterprise Desktop 11 SP1 NetworkManager Released
SUSE Linux Enterprise Desktop 11 SP1 NetworkManager-gnome Released
SUSE Linux Enterprise Desktop 11 SP1 NetworkManager-kde4 Affected
SUSE Linux Enterprise Desktop 11 SP1 wpa_supplicant Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search NetworkManager Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search NetworkManager-gnome Released
SUSE Linux Enterprise Enterprise Server 11 SP1 for SAP Enterprise Search wpa_supplicant Released
SUSE Linux Enterprise Server 11 SP1 NetworkManager Released
SUSE Linux Enterprise Server 11 SP1 NetworkManager-gnome Released
SUSE Linux Enterprise Server 11 SP1 NetworkManager-kde4 Affected
SUSE Linux Enterprise Server 11 SP1 wpa_supplicant Released
SUSE Linux Enterprise Server 11 SP1 LTSS NetworkManager Released
SUSE Linux Enterprise Server 11 SP1 LTSS NetworkManager-gnome Released
SUSE Linux Enterprise Server 11 SP1 LTSS NetworkManager-kde4 Affected
SUSE Linux Enterprise Server 11 SP1 LTSS wpa_supplicant Released
SUSE Linux Enterprise Server for SAP Business All-in-One NetworkManager Released
SUSE Linux Enterprise Server for SAP Business All-in-One NetworkManager-gnome Released
SUSE Linux Enterprise Server for SAP Business All-in-One NetworkManager-kde4 Affected
SUSE Linux Enterprise Server for SAP Business All-in-One wpa_supplicant Released
SUSE Linux Enterprise Software Development Kit 11 SP1 NetworkManager Released