SUSE Support

Here When You Need Us

After booting the system with Xen, kdump service is failing

This document (7018393) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12 Service Pack 2 (SLES 12 SP2)

Situation

After a new installation of SLES12 SP2, kdump is failing to load the crash kernel.
systemctl status kdump shows the following errors.
 kdump.service - Load kdump kernel on startup
 Loaded: loaded (/usr/lib/systemd/system/kdump.service; enabled; vendor preset: disabled)
 Active: failed (Result: exit-code) since Wed 2016-11-09 20:14:32 JST; 4min 56s ago
 Process: 2995 ExecStart=/lib/kdump/load.sh (code=exited, status=1/FAILURE)
 Main PID: 2995 (code=exited, status=1/FAILURE)
 
 Nov 09 20:14:31 linux-rw6w systemd[1]: Starting Load kdump kernel on startup...
 Nov 09 20:14:32 linux-rw6w load.sh[2995]: Cannot load /boot/vmlinuz-4.4.21-6...t
 Nov 09 20:14:32 linux-rw6w systemd[1]: kdump.service: Main process exited, ...RE
 Nov 09 20:14:32 linux-rw6w systemd[1]: Failed to start Load kdump kernel on...p.
 Nov 09 20:14:32 linux-rw6w systemd[1]: kdump.service: Unit entered failed state.
 Nov 09 20:14:32 linux-rw6w systemd[1]: kdump.service: Failed with result 'e...'.



Resolution

Please open a service request (SR) and request a PTF for this problem.
As a temporary workaround you can edit the file /etc/default/grub and change the line:

GRUB_CMDLINE_LINUX_XEN="crashkernel=XXX"
to
GRUB_CMDLINE_XEN_DEFAULT="crashkernel=XXX"

where XXX is a placeholder for the size of the crash kernel.

After saving this file you need to run grub2-mkconfig(8)


Cause

This is a known bug and will be fixed in the next maintenance update of rubygem-cfa_grub2.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7018393
  • Creation Date: 15-Dec-2016
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.