SUSE Support

Here When You Need Us

Cannot login as root at the console, login incorrect

This document (7014706) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server 10
 

Situation

At the text console login screen, the error message "Login incorrect" is displayed when attempting to login as any user, including the root user. No user is allowed to login.

The root user and all other users can login to a graphical login. They can also ssh into the server.

The following error message(s) is displayed in the system log (/var/log/messages).

"login: pam_securetty(login:auth): /etc/securetty is either world writable or not a normal file"
"login[3452]: FAILED LOGIN 1 FROM /dev/tty2 FOR root, Authentication failure"

Reviewing a supportconfig pam.txt or running rpm -V pam shows:

.M.......  c /etc/securetty
 

Resolution

Change the /etc/securetty permissions.

1. Login to a graphical login, or ssh into the server as root
2. Run chmod 644 /etc/securetty
3. Run rpm -V pam to confirm the errors have been resolved for /etc/securetty

If unsuccessful, you might also consider reinstalling the pam RPM package.

 

Cause

The pam authentication mechanism is designed to fail for security purposes if the /etc/securetty file has invalid permissions.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7014706
  • Creation Date: 06-Mar-2014
  • Modified Date:28-Sep-2022
    • SUSE Linux Enterprise Desktop
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.