Upstream information

CVE-2024-34397 at MITRE

Description

An issue was discovered in GNOME GLib before 2.78.5, and 2.79.x and 2.80.x before 2.80.1. When a GDBus-based client subscribes to signals from a trusted system service such as NetworkManager on a shared computer, other users of the same computer can send spoofed D-Bus signals that the GDBus-based client will wrongly interpret as having been sent by the trusted system service. This could lead to the GDBus-based client behaving incorrectly, with an application-dependent impact.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v3 Scores
  SUSE
Base Score 3.8
Vector CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N
Attack Vector Local
Attack Complexity Low
Privileges Required Low
User Interaction None
Scope Changed
Confidentiality Impact None
Integrity Impact Low
Availability Impact None
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1224044 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container bci/openjdk-devel:11-16.17
Container bci/openjdk:11-18.10
Container suse/ltss/sle15.4/sle15:15.4.3.36
Container suse/manager/4.3/proxy-salt-broker:4.3.12.9.42.16
Container suse/sle-micro/base-5.5:2.0.4-5.8.9
Container suse/sle15:15.5.36.11.38
Image SLES15-SP4-CHOST-BYOS
Image SLES15-SP4-CHOST-BYOS-Aliyun
Image SLES15-SP4-CHOST-BYOS-Azure
Image SLES15-SP4-CHOST-BYOS-EC2
Image SLES15-SP4-CHOST-BYOS-GCE
Image SLES15-SP5-CHOST-BYOS-Aliyun
Image SLES15-SP5-CHOST-BYOS-Azure
Image SLES15-SP5-CHOST-BYOS-EC2
Image SLES15-SP5-CHOST-BYOS-GCE
  • libglib-2_0-0 >= 2.70.5-150400.3.11.1
Container bci/spack:0.21.2-2.1
Container suse/hpc/warewulf4-x86_64/sle-hpc-node:15.6.17.5.5
Container suse/manager/5.0/x86_64/server:latest
Image SLES15-SP6
Image SLES15-SP6-Azure-Basic
Image SLES15-SP6-Azure-Standard
Image SLES15-SP6-BYOS
Image SLES15-SP6-BYOS-Azure
Image SLES15-SP6-BYOS-EC2
Image SLES15-SP6-BYOS-GCE
Image SLES15-SP6-CHOST-BYOS
Image SLES15-SP6-CHOST-BYOS-Aliyun
Image SLES15-SP6-CHOST-BYOS-Azure
Image SLES15-SP6-CHOST-BYOS-EC2
Image SLES15-SP6-CHOST-BYOS-GCE
Image SLES15-SP6-EC2
Image SLES15-SP6-EC2-ECS-HVM
Image SLES15-SP6-GCE
Image SLES15-SP6-HPC
Image SLES15-SP6-HPC-Azure
Image SLES15-SP6-HPC-BYOS
Image SLES15-SP6-HPC-BYOS-Azure
Image SLES15-SP6-HPC-BYOS-EC2
Image SLES15-SP6-HPC-BYOS-GCE
Image SLES15-SP6-HPC-EC2
Image SLES15-SP6-HPC-GCE
Image SLES15-SP6-Hardened-BYOS
Image SLES15-SP6-Hardened-BYOS-Azure
Image SLES15-SP6-Hardened-BYOS-EC2
Image SLES15-SP6-Hardened-BYOS-GCE
  • gio-branding-SLE >= 15-150600.35.2.1
  • glib2-tools >= 2.78.6-150600.4.3.1
  • libgio-2_0-0 >= 2.78.6-150600.4.3.1
  • libglib-2_0-0 >= 2.78.6-150600.4.3.1
  • libgmodule-2_0-0 >= 2.78.6-150600.4.3.1
  • libgobject-2_0-0 >= 2.78.6-150600.4.3.1
Container suse/ltss/sle15.3/sle15:15.3.4.70
Container suse/sle15:15.2.9.8.11
  • libglib-2_0-0 >= 2.62.6-150200.3.18.1
Container suse/manager/4.3/proxy-httpd:4.3.12.9.52.8
Container suse/sle-micro-rancher/5.3:latest
Container suse/sle-micro-rancher/5.4:latest
Container suse/sle-micro/5.5:2.0.4-5.5.15
Container suse/sle-micro/kvm-5.5:2.0.4-3.5.19
Container suse/sle-micro/rt-5.5:2.0.4-4.5.21
Image SLES15-SP4-Manager-Proxy-4-3-BYOS
Image SLES15-SP4-Manager-Proxy-4-3-BYOS-EC2
Image SLES15-SP4-Manager-Proxy-4-3-BYOS-GCE
Image SLES15-SP4-Manager-Server-4-3
Image SLES15-SP4-Manager-Server-4-3-Azure-llc
Image SLES15-SP4-Manager-Server-4-3-Azure-ltd
Image SLES15-SP4-Manager-Server-4-3-BYOS
Image SLES15-SP4-Manager-Server-4-3-BYOS-Azure
Image SLES15-SP4-Manager-Server-4-3-BYOS-EC2
Image SLES15-SP4-Manager-Server-4-3-BYOS-GCE
Image SLES15-SP4-Manager-Server-4-3-EC2-llc
Image SLES15-SP4-Manager-Server-4-3-EC2-ltd
Image SLES15-SP4-Micro-5-3
Image SLES15-SP4-Micro-5-3-BYOS
Image SLES15-SP4-Micro-5-3-BYOS-Azure
Image SLES15-SP4-Micro-5-3-BYOS-EC2
Image SLES15-SP4-Micro-5-3-BYOS-GCE
Image SLES15-SP4-Micro-5-3-EC2
Image SLES15-SP4-Micro-5-4
Image SLES15-SP4-Micro-5-4-BYOS
Image SLES15-SP4-Micro-5-4-BYOS-Azure
Image SLES15-SP4-Micro-5-4-EC2
Image SLES15-SP5-BYOS-EC2
Image SLES15-SP5-BYOS-GCE
Image SLES15-SP5-EC2
Image SLES15-SP5-GCE
Image SLES15-SP5-HPC-BYOS-EC2
Image SLES15-SP5-Hardened-BYOS-GCE
Image SLES15-SP5-Micro-5-5
Image SLES15-SP5-Micro-5-5-BYOS
Image SLES15-SP5-Micro-5-5-BYOS-EC2
Image SLES15-SP5-Micro-5-5-BYOS-GCE
Image SLES15-SP5-Micro-5-5-EC2
Image SLES15-SP5-Micro-5-5-GCE
  • glib2-tools >= 2.70.5-150400.3.11.1
  • libgio-2_0-0 >= 2.70.5-150400.3.11.1
  • libglib-2_0-0 >= 2.70.5-150400.3.11.1
  • libgmodule-2_0-0 >= 2.70.5-150400.3.11.1
  • libgobject-2_0-0 >= 2.70.5-150400.3.11.1
Container suse/manager/5.0/x86_64/server-attestation:5.0.0.4.5
Container suse/sle15:15.6.47.5.4
  • libglib-2_0-0 >= 2.78.6-150600.4.3.1
Container suse/sle-micro-rancher/5.2:latest
  • libglib-2_0-0 >= 2.62.6-150200.3.18.1
  • libgmodule-2_0-0 >= 2.62.6-150200.3.18.1
  • libgobject-2_0-0 >= 2.62.6-150200.3.18.1
Container suse/sle-micro/5.3/toolbox:13.2-6.8.35
Container suse/sle-micro/5.4/toolbox:13.2-5.15.34
Container suse/sle-micro/5.5/toolbox:13.2-2.2.244
  • libglib-2_0-0 >= 2.70.5-150400.3.11.1
  • libgmodule-2_0-0 >= 2.70.5-150400.3.11.1
Image SLES12-SP5-Azure-BYOS
Image SLES12-SP5-Azure-Basic-On-Demand
Image SLES12-SP5-Azure-Standard-On-Demand
Image SLES12-SP5-EC2-BYOS
Image SLES12-SP5-EC2-ECS-On-Demand
Image SLES12-SP5-EC2-On-Demand
Image SLES12-SP5-GCE-On-Demand
  • glib2-tools >= 2.48.2-12.37.1
  • libgio-2_0-0 >= 2.48.2-12.37.1
  • libglib-2_0-0 >= 2.48.2-12.37.1
  • libgmodule-2_0-0 >= 2.48.2-12.37.1
  • libgobject-2_0-0 >= 2.48.2-12.37.1
Image SLES12-SP5-Azure-SAP-BYOS
Image SLES12-SP5-SAP-Azure-LI-BYOS-Production
Image SLES12-SP5-SAP-Azure-VLI-BYOS-Production
  • glib2-tools >= 2.48.2-12.37.1
  • libgio-2_0-0 >= 2.48.2-12.37.1
  • libglib-2_0-0 >= 2.48.2-12.37.1
  • libgmodule-2_0-0 >= 2.48.2-12.37.1
  • libgobject-2_0-0 >= 2.48.2-12.37.1
  • libgthread-2_0-0 >= 2.48.2-12.37.1
Image SLES15-SP4-CHOST-BYOS-SAP-CCloud
Image SLES15-SP5-CHOST-BYOS-SAP-CCloud
  • libglib-2_0-0 >= 2.70.5-150400.3.11.1
  • libgmodule-2_0-0 >= 2.70.5-150400.3.11.1
  • libgobject-2_0-0 >= 2.70.5-150400.3.11.1
Image SLES15-SP4-SAP-Azure-LI-BYOS
Image SLES15-SP4-SAP-Azure-LI-BYOS-Production
Image SLES15-SP4-SAP-Azure-VLI-BYOS
Image SLES15-SP4-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP5-SAP-Azure-LI-BYOS
Image SLES15-SP5-SAP-Azure-LI-BYOS-Production
Image SLES15-SP5-SAP-Azure-VLI-BYOS
Image SLES15-SP5-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP5-SAP-BYOS-EC2
  • glib2-tools >= 2.70.5-150400.3.11.1
  • libgio-2_0-0 >= 2.70.5-150400.3.11.1
  • libglib-2_0-0 >= 2.70.5-150400.3.11.1
  • libgmodule-2_0-0 >= 2.70.5-150400.3.11.1
  • libgobject-2_0-0 >= 2.70.5-150400.3.11.1
  • libgthread-2_0-0 >= 2.70.5-150400.3.11.1
Image SLES15-SP5-SAPCAL-EC2
Image SLES15-SP5-SAPCAL-GCE
  • glib2-devel >= 2.70.5-150400.3.11.1
  • glib2-tools >= 2.70.5-150400.3.11.1
  • libgio-2_0-0 >= 2.70.5-150400.3.11.1
  • libglib-2_0-0 >= 2.70.5-150400.3.11.1
  • libgmodule-2_0-0 >= 2.70.5-150400.3.11.1
  • libgobject-2_0-0 >= 2.70.5-150400.3.11.1
  • libgthread-2_0-0 >= 2.70.5-150400.3.11.1
Image SLES15-SP6-SAP-Azure-LI-BYOS
Image SLES15-SP6-SAP-Azure-LI-BYOS-Production
Image SLES15-SP6-SAP-Azure-VLI-BYOS
Image SLES15-SP6-SAP-Azure-VLI-BYOS-Production
Image SLES15-SP6-SAP-BYOS
Image SLES15-SP6-SAP-BYOS-Azure
Image SLES15-SP6-SAP-BYOS-EC2
Image SLES15-SP6-SAP-BYOS-GCE
Image SLES15-SP6-SAP-Hardened
Image SLES15-SP6-SAP-Hardened-Azure
Image SLES15-SP6-SAP-Hardened-BYOS
Image SLES15-SP6-SAP-Hardened-BYOS-Azure
Image SLES15-SP6-SAP-Hardened-BYOS-EC2
Image SLES15-SP6-SAP-Hardened-BYOS-GCE
Image SLES15-SP6-SAP-Hardened-EC2
Image SLES15-SP6-SAP-Hardened-GCE
  • gio-branding-SLE >= 15-150600.35.2.1
  • glib2-tools >= 2.78.6-150600.4.3.1
  • libgio-2_0-0 >= 2.78.6-150600.4.3.1
  • libglib-2_0-0 >= 2.78.6-150600.4.3.1
  • libgmodule-2_0-0 >= 2.78.6-150600.4.3.1
  • libgobject-2_0-0 >= 2.78.6-150600.4.3.1
  • libgthread-2_0-0 >= 2.78.6-150600.4.3.1
Image SLES15-SP6-SAP-GCE
Image SLES15-SP6-SAPCAL-GCE
  • gio-branding-SLE >= 15-150600.35.2.1
  • glib2-devel >= 2.78.6-150600.4.3.1
  • glib2-tools >= 2.78.6-150600.4.3.1
  • libgio-2_0-0 >= 2.78.6-150600.4.3.1
  • libglib-2_0-0 >= 2.78.6-150600.4.3.1
  • libgmodule-2_0-0 >= 2.78.6-150600.4.3.1
  • libgobject-2_0-0 >= 2.78.6-150600.4.3.1
  • libgthread-2_0-0 >= 2.78.6-150600.4.3.1
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Basesystem 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • glib2-devel >= 2.70.5-150400.3.11.1
  • glib2-lang >= 2.70.5-150400.3.11.1
  • glib2-tools >= 2.70.5-150400.3.11.1
  • libgio-2_0-0 >= 2.70.5-150400.3.11.1
  • libgio-2_0-0-32bit >= 2.70.5-150400.3.11.1
  • libglib-2_0-0 >= 2.70.5-150400.3.11.1
  • libglib-2_0-0-32bit >= 2.70.5-150400.3.11.1
  • libgmodule-2_0-0 >= 2.70.5-150400.3.11.1
  • libgmodule-2_0-0-32bit >= 2.70.5-150400.3.11.1
  • libgobject-2_0-0 >= 2.70.5-150400.3.11.1
  • libgobject-2_0-0-32bit >= 2.70.5-150400.3.11.1
  • libgthread-2_0-0 >= 2.70.5-150400.3.11.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP5-2024-1830
SUSE Linux Enterprise Desktop 15 SP6
SUSE Linux Enterprise High Performance Computing 15 SP6
SUSE Linux Enterprise Module for Basesystem 15 SP6
SUSE Linux Enterprise Server 15 SP6
SUSE Linux Enterprise Server for SAP Applications 15 SP6
  • gio-branding-SLE >= 15-150600.35.2.1
  • glib2-devel >= 2.78.6-150600.4.3.1
  • glib2-lang >= 2.78.6-150600.4.3.1
  • glib2-tools >= 2.78.6-150600.4.3.1
  • libgio-2_0-0 >= 2.78.6-150600.4.3.1
  • libgio-2_0-0-32bit >= 2.78.6-150600.4.3.1
  • libglib-2_0-0 >= 2.78.6-150600.4.3.1
  • libglib-2_0-0-32bit >= 2.78.6-150600.4.3.1
  • libgmodule-2_0-0 >= 2.78.6-150600.4.3.1
  • libgmodule-2_0-0-32bit >= 2.78.6-150600.4.3.1
  • libgobject-2_0-0 >= 2.78.6-150600.4.3.1
  • libgobject-2_0-0-32bit >= 2.78.6-150600.4.3.1
  • libgthread-2_0-0 >= 2.78.6-150600.4.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP6-2024-1950
SUSE Linux Enterprise Micro 5.1
  • glib2-tools >= 2.62.6-150200.3.18.1
  • libgio-2_0-0 >= 2.62.6-150200.3.18.1
  • libglib-2_0-0 >= 2.62.6-150200.3.18.1
  • libgmodule-2_0-0 >= 2.62.6-150200.3.18.1
  • libgobject-2_0-0 >= 2.62.6-150200.3.18.1
Patchnames:
SUSE-SUSE-MicroOS-5.1-2024-2247
SUSE Linux Enterprise Micro 5.2
  • glib2-tools >= 2.62.6-150200.3.18.1
  • libgio-2_0-0 >= 2.62.6-150200.3.18.1
  • libglib-2_0-0 >= 2.62.6-150200.3.18.1
  • libgmodule-2_0-0 >= 2.62.6-150200.3.18.1
  • libgobject-2_0-0 >= 2.62.6-150200.3.18.1
Patchnames:
SUSE-SUSE-MicroOS-5.2-2024-2247
SUSE Linux Enterprise Micro 5.3
  • glib2-tools >= 2.70.5-150400.3.11.1
  • libgio-2_0-0 >= 2.70.5-150400.3.11.1
  • libglib-2_0-0 >= 2.70.5-150400.3.11.1
  • libgmodule-2_0-0 >= 2.70.5-150400.3.11.1
  • libgobject-2_0-0 >= 2.70.5-150400.3.11.1
Patchnames:
SUSE-SLE-Micro-5.3-2024-1830
SUSE Linux Enterprise Micro 5.4
  • glib2-tools >= 2.70.5-150400.3.11.1
  • libgio-2_0-0 >= 2.70.5-150400.3.11.1
  • libglib-2_0-0 >= 2.70.5-150400.3.11.1
  • libgmodule-2_0-0 >= 2.70.5-150400.3.11.1
  • libgobject-2_0-0 >= 2.70.5-150400.3.11.1
Patchnames:
SUSE-SLE-Micro-5.4-2024-1830
SUSE Linux Enterprise Micro 5.5
  • glib2-tools >= 2.70.5-150400.3.11.1
  • libgio-2_0-0 >= 2.70.5-150400.3.11.1
  • libglib-2_0-0 >= 2.70.5-150400.3.11.1
  • libgmodule-2_0-0 >= 2.70.5-150400.3.11.1
  • libgobject-2_0-0 >= 2.70.5-150400.3.11.1
Patchnames:
SUSE-SLE-Micro-5.5-2024-1830
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • glib2-devel >= 2.48.2-12.37.1
  • glib2-devel-static >= 2.48.2-12.37.1
  • glib2-lang >= 2.48.2-12.37.1
  • glib2-tools >= 2.48.2-12.37.1
  • libgio-2_0-0 >= 2.48.2-12.37.1
  • libgio-2_0-0-32bit >= 2.48.2-12.37.1
  • libgio-fam >= 2.48.2-12.37.1
  • libglib-2_0-0 >= 2.48.2-12.37.1
  • libglib-2_0-0-32bit >= 2.48.2-12.37.1
  • libgmodule-2_0-0 >= 2.48.2-12.37.1
  • libgmodule-2_0-0-32bit >= 2.48.2-12.37.1
  • libgobject-2_0-0 >= 2.48.2-12.37.1
  • libgobject-2_0-0-32bit >= 2.48.2-12.37.1
  • libgthread-2_0-0 >= 2.48.2-12.37.1
  • libgthread-2_0-0-32bit >= 2.48.2-12.37.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2024-1833
SUSE-SLE-SERVER-12-SP5-2024-1833
SUSE-SLE-WE-12-SP5-2024-1833
SUSE Linux Enterprise Software Development Kit 12 SP5
  • glib2-devel >= 2.48.2-12.37.1
  • glib2-devel-static >= 2.48.2-12.37.1
  • libgio-fam >= 2.48.2-12.37.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2024-1833
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libgio-fam >= 2.48.2-12.37.1
Patchnames:
SUSE-SLE-WE-12-SP5-2024-1833
openSUSE Leap 15.5
  • gio-branding-upstream >= 2.70.5-150400.3.11.1
  • glib2-devel >= 2.70.5-150400.3.11.1
  • glib2-devel-32bit >= 2.70.5-150400.3.11.1
  • glib2-devel-static >= 2.70.5-150400.3.11.1
  • glib2-doc >= 2.70.5-150400.3.11.1
  • glib2-lang >= 2.70.5-150400.3.11.1
  • glib2-tests-devel >= 2.70.5-150400.3.11.1
  • glib2-tools >= 2.70.5-150400.3.11.1
  • glib2-tools-32bit >= 2.70.5-150400.3.11.1
  • libgio-2_0-0 >= 2.70.5-150400.3.11.1
  • libgio-2_0-0-32bit >= 2.70.5-150400.3.11.1
  • libglib-2_0-0 >= 2.70.5-150400.3.11.1
  • libglib-2_0-0-32bit >= 2.70.5-150400.3.11.1
  • libgmodule-2_0-0 >= 2.70.5-150400.3.11.1
  • libgmodule-2_0-0-32bit >= 2.70.5-150400.3.11.1
  • libgobject-2_0-0 >= 2.70.5-150400.3.11.1
  • libgobject-2_0-0-32bit >= 2.70.5-150400.3.11.1
  • libgthread-2_0-0 >= 2.70.5-150400.3.11.1
  • libgthread-2_0-0-32bit >= 2.70.5-150400.3.11.1
Patchnames:
openSUSE-SLE-15.5-2024-1830
openSUSE Leap 15.6
  • gio-branding-SLE >= 15-150600.35.2.1
  • gio-branding-upstream >= 2.78.6-150600.4.3.1
  • glib2-devel >= 2.78.6-150600.4.3.1
  • glib2-devel-32bit >= 2.78.6-150600.4.3.1
  • glib2-devel-static >= 2.78.6-150600.4.3.1
  • glib2-doc >= 2.78.6-150600.4.3.1
  • glib2-lang >= 2.78.6-150600.4.3.1
  • glib2-tests-devel >= 2.78.6-150600.4.3.1
  • glib2-tools >= 2.78.6-150600.4.3.1
  • glib2-tools-32bit >= 2.78.6-150600.4.3.1
  • libgio-2_0-0 >= 2.78.6-150600.4.3.1
  • libgio-2_0-0-32bit >= 2.78.6-150600.4.3.1
  • libglib-2_0-0 >= 2.78.6-150600.4.3.1
  • libglib-2_0-0-32bit >= 2.78.6-150600.4.3.1
  • libgmodule-2_0-0 >= 2.78.6-150600.4.3.1
  • libgmodule-2_0-0-32bit >= 2.78.6-150600.4.3.1
  • libgobject-2_0-0 >= 2.78.6-150600.4.3.1
  • libgobject-2_0-0-32bit >= 2.78.6-150600.4.3.1
  • libgthread-2_0-0 >= 2.78.6-150600.4.3.1
  • libgthread-2_0-0-32bit >= 2.78.6-150600.4.3.1
Patchnames:
openSUSE-SLE-15.6-2024-1950
openSUSE Leap Micro 5.3
  • glib2-tools >= 2.70.5-150400.3.11.1
  • libgio-2_0-0 >= 2.70.5-150400.3.11.1
  • libglib-2_0-0 >= 2.70.5-150400.3.11.1
  • libgmodule-2_0-0 >= 2.70.5-150400.3.11.1
  • libgobject-2_0-0 >= 2.70.5-150400.3.11.1
Patchnames:
openSUSE-Leap-Micro-5.3-2024-1830
openSUSE Leap Micro 5.4
  • glib2-tools >= 2.70.5-150400.3.11.1
  • libgio-2_0-0 >= 2.70.5-150400.3.11.1
  • libglib-2_0-0 >= 2.70.5-150400.3.11.1
  • libgmodule-2_0-0 >= 2.70.5-150400.3.11.1
  • libgobject-2_0-0 >= 2.70.5-150400.3.11.1
Patchnames:
openSUSE-Leap-Micro-5.4-2024-1830
openSUSE Leap Micro 5.5
  • glib2-tools >= 2.70.5-150400.3.11.1
  • libgio-2_0-0 >= 2.70.5-150400.3.11.1
  • libglib-2_0-0 >= 2.70.5-150400.3.11.1
  • libgmodule-2_0-0 >= 2.70.5-150400.3.11.1
  • libgobject-2_0-0 >= 2.70.5-150400.3.11.1
Patchnames:
openSUSE-Leap-Micro-5.5-2024-1830
openSUSE Tumbleweed
  • gio-branding-upstream >= 2.80.2-1.1
  • glib2-devel >= 2.80.2-1.1
  • glib2-devel-32bit >= 2.80.2-1.1
  • glib2-devel-static >= 2.80.2-1.1
  • glib2-lang >= 2.80.2-1.1
  • glib2-tests-devel >= 2.80.2-1.1
  • glib2-tools >= 2.80.2-1.1
  • glib2-tools-32bit >= 2.80.2-1.1
  • libgio-2_0-0 >= 2.80.2-1.1
  • libgio-2_0-0-32bit >= 2.80.2-1.1
  • libgirepository-2_0-0 >= 2.80.2-1.1
  • libglib-2_0-0 >= 2.80.2-1.1
  • libglib-2_0-0-32bit >= 2.80.2-1.1
  • libgmodule-2_0-0 >= 2.80.2-1.1
  • libgmodule-2_0-0-32bit >= 2.80.2-1.1
  • libgobject-2_0-0 >= 2.80.2-1.1
  • libgobject-2_0-0-32bit >= 2.80.2-1.1
  • libgthread-2_0-0 >= 2.80.2-1.1
  • libgthread-2_0-0-32bit >= 2.80.2-1.1
  • typelib-1_0-GIRepository-3_0 >= 2.80.2-1.1
  • typelib-1_0-GLib-2_0 >= 2.80.2-1.1
  • typelib-1_0-GLibUnix-2_0 >= 2.80.2-1.1
  • typelib-1_0-GModule-2_0 >= 2.80.2-1.1
  • typelib-1_0-GObject-2_0 >= 2.80.2-1.1
  • typelib-1_0-Gio-2_0 >= 2.80.2-1.1
Patchnames:
openSUSE-Tumbleweed-2024-13970


First public cloud image revisions this CVE is fixed in:


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 glib2 Affected
SUSE Linux Enterprise Desktop 15 SP5 glib2 Released
SUSE Linux Enterprise Desktop 15 SP6 glib2 Released
SUSE Linux Enterprise Desktop 15 SP6 glib2-branding-SLE Released
SUSE Linux Enterprise High Performance Computing 12 SP5 glib2 Released
SUSE Linux Enterprise High Performance Computing 15 SP5 glib2 Released
SUSE Linux Enterprise High Performance Computing 15 SP6 glib2 Released
SUSE Linux Enterprise High Performance Computing 15 SP6 glib2-branding-SLE Released
SUSE Linux Enterprise Micro 5.1 glib2 Released
SUSE Linux Enterprise Micro 5.2 glib2 Released
SUSE Linux Enterprise Micro 5.3 glib2 Released
SUSE Linux Enterprise Micro 5.4 glib2 Released
SUSE Linux Enterprise Micro 5.5 glib2 Released
SUSE Linux Enterprise Micro 6.0 glib2 Affected
SUSE Linux Enterprise Micro for Rancher 5.2 glib2 Released
SUSE Linux Enterprise Micro for Rancher 5.3 glib2 Released
SUSE Linux Enterprise Micro for Rancher 5.4 glib2 Released
SUSE Linux Enterprise Module for Basesystem 15 SP5 glib2 Released
SUSE Linux Enterprise Module for Basesystem 15 SP6 glib2 Released
SUSE Linux Enterprise Module for Basesystem 15 SP6 glib2-branding-SLE Released
SUSE Linux Enterprise Server 12 SP5 glib2 Released
SUSE Linux Enterprise Server 15 SP5 glib2 Released
SUSE Linux Enterprise Server 15 SP6 glib2 Released
SUSE Linux Enterprise Server 15 SP6 glib2-branding-SLE Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 glib2 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 glib2 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP6 glib2 Released
SUSE Linux Enterprise Server for SAP Applications 15 SP6 glib2-branding-SLE Released
SUSE Linux Enterprise Software Development Kit 12 SP5 glib2 Released
SUSE Linux Enterprise Workstation Extension 12 SP5 glib2 Released
SUSE Manager Proxy 4.3 glib2 Affected
SUSE Manager Retail Branch Server 4.3 glib2 Affected
SUSE Manager Server 4.3 glib2 Affected
openSUSE Leap 15.5 glib2 Released
openSUSE Leap 15.6 glib2 Released
openSUSE Leap Micro 5.5 glib2 Affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 glib2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2 glib2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS glib2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS glib2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3 glib2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS glib2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS glib2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4 glib2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS glib2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS glib2 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP2 glib2 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP3 glib2 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP4 glib2 Affected
SUSE Linux Enterprise Server 15 SP2 glib2 Affected
SUSE Linux Enterprise Server 15 SP2-LTSS glib2 Affected
SUSE Linux Enterprise Server 15 SP3 glib2 Affected
SUSE Linux Enterprise Server 15 SP3-LTSS glib2 Affected
SUSE Linux Enterprise Server 15 SP4 glib2 Affected
SUSE Linux Enterprise Server 15 SP4-LTSS glib2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 glib2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 glib2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 glib2 Affected
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 glib2 Affected
SUSE CaaS Platform 3.0 glib2 Affected
SUSE CaaS Platform 4.0 glib2 Affected
SUSE Enterprise Storage 6 glib2 Affected
SUSE Enterprise Storage 7 glib2 Affected
SUSE Linux Enterprise Desktop 11 SP2 glib2 Not affected
SUSE Linux Enterprise Desktop 11 SP3 glib2 Not affected
SUSE Linux Enterprise Desktop 11 SP4 glib2 Not affected
SUSE Linux Enterprise Desktop 12 SP2 glib2 Affected
SUSE Linux Enterprise Desktop 12 SP3 glib2 Affected
SUSE Linux Enterprise Desktop 12 SP4 glib2 Affected
SUSE Linux Enterprise Desktop 15 glib2 Affected
SUSE Linux Enterprise Desktop 15 SP1 glib2 Affected
SUSE Linux Enterprise Desktop 15 SP2 glib2 Affected
SUSE Linux Enterprise Desktop 15 SP3 glib2 Affected
SUSE Linux Enterprise High Performance Computing 15 glib2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1 glib2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS glib2 Affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS glib2 Affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS glib2 Affected
SUSE Linux Enterprise High Performance Computing 15-LTSS glib2 Affected
SUSE Linux Enterprise Micro 5.0 glib2 Affected
SUSE Linux Enterprise Module for Basesystem 15 glib2 Affected
SUSE Linux Enterprise Module for Basesystem 15 SP1 glib2 Affected
SUSE Linux Enterprise Module for Package Hub 15 glib2 Affected
SUSE Linux Enterprise Point of Sale 11 SP3 glib2 Not affected
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT glib2 Affected
SUSE Linux Enterprise Real Time 15 SP2 glib2 Affected
SUSE Linux Enterprise Real Time 15 SP3 glib2 Affected
SUSE Linux Enterprise Real Time 15 SP4 glib2 Affected
SUSE Linux Enterprise Server 11 SP1-LTSS glib2 Not affected
SUSE Linux Enterprise Server 11 SP2 glib2 Not affected
SUSE Linux Enterprise Server 11 SP2-LTSS glib2 Not affected
SUSE Linux Enterprise Server 11 SP3 glib2 Not affected
SUSE Linux Enterprise Server 11 SP3-LTSS glib2 Not affected
SUSE Linux Enterprise Server 11 SP4 glib2 Not affected
SUSE Linux Enterprise Server 11 SP4 LTSS glib2 Not affected
SUSE Linux Enterprise Server 11 SP4-LTSS glib2 Not affected
SUSE Linux Enterprise Server 12 SP2 glib2 Affected
SUSE Linux Enterprise Server 12 SP2-BCL glib2 Affected
SUSE Linux Enterprise Server 12 SP2-ESPOS glib2 Affected
SUSE Linux Enterprise Server 12 SP2-LTSS glib2 Affected
SUSE Linux Enterprise Server 12 SP3 glib2 Affected
SUSE Linux Enterprise Server 12 SP3-BCL glib2 Affected
SUSE Linux Enterprise Server 12 SP3-ESPOS glib2 Affected
SUSE Linux Enterprise Server 12 SP3-LTSS glib2 Affected
SUSE Linux Enterprise Server 12 SP4 glib2 Affected
SUSE Linux Enterprise Server 12 SP4-ESPOS glib2 Affected
SUSE Linux Enterprise Server 12 SP4-LTSS glib2 Affected
SUSE Linux Enterprise Server 15 glib2 Affected
SUSE Linux Enterprise Server 15 SP1 glib2 Affected
SUSE Linux Enterprise Server 15 SP1-BCL glib2 Affected
SUSE Linux Enterprise Server 15 SP1-LTSS glib2 Affected
SUSE Linux Enterprise Server 15 SP2-BCL glib2 Affected
SUSE Linux Enterprise Server 15 SP3-BCL glib2 Affected
SUSE Linux Enterprise Server 15-LTSS glib2 Affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 glib2 Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 glib2 Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 glib2 Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 glib2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 glib2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 glib2 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 glib2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 glib2 Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 glib2 Affected
SUSE Linux Enterprise Software Development Kit 11 SP2 glib2 Not affected
SUSE Linux Enterprise Software Development Kit 11 SP3 glib2 Not affected
SUSE Linux Enterprise Software Development Kit 11 SP4 glib2 Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 glib2 Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 glib2 Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 glib2 Affected
SUSE Linux Enterprise Workstation Extension 12 SP2 glib2 Affected
SUSE Linux Enterprise Workstation Extension 12 SP3 glib2 Affected
SUSE Linux Enterprise Workstation Extension 12 SP4 glib2 Affected
SUSE Manager Proxy 4.0 glib2 Affected
SUSE Manager Proxy 4.1 glib2 Affected
SUSE Manager Proxy 4.2 glib2 Affected
SUSE Manager Retail Branch Server 4.0 glib2 Affected
SUSE Manager Retail Branch Server 4.1 glib2 Affected
SUSE Manager Retail Branch Server 4.2 glib2 Affected
SUSE Manager Server 4.0 glib2 Affected
SUSE Manager Server 4.1 glib2 Affected
SUSE Manager Server 4.2 glib2 Affected
SUSE OpenStack Cloud 7 glib2 Affected
SUSE OpenStack Cloud 8 glib2 Affected
SUSE OpenStack Cloud 9 glib2 Affected
SUSE OpenStack Cloud Crowbar 8 glib2 Affected
SUSE OpenStack Cloud Crowbar 9 glib2 Affected
SUSE Studio Onsite 1.3 glib2 Not affected
openSUSE Leap 15.3 glib2 Affected
openSUSE Leap 15.4 glib2 Released
openSUSE Leap Micro 5.2 glib2 Affected
openSUSE Leap Micro 5.3 glib2 Released
openSUSE Leap Micro 5.4 glib2 Released
Products at an unknown state of their lifecycle.
SUSE CaaS Platform Toolchain 3 glib2 Affected


SUSE Timeline for this CVE

CVE page created: Tue May 7 22:00:04 2024
CVE page last modified: Tue Jul 23 00:57:00 2024