Upstream information

CVE-2024-32662 at MITRE

Description

FreeRDP is a free implementation of the Remote Desktop Protocol. FreeRDP based clients prior to version 3.5.1 are vulnerable to out-of-bounds read. This occurs when `WCHAR` string is read with twice the size it has and converted to `UTF-8`, `base64` decoded. The string is only used to compare against the redirection server certificate. Version 3.5.1 contains a patch for the issue. No known workarounds are available.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  SUSE
Base Score 5.4
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact Low
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1223350 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Desktop 15 SP5 freerdp Not affected
SUSE Linux Enterprise Desktop 15 SP6 freerdp Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP5 freerdp Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP6 freerdp Not affected
SUSE Linux Enterprise Server 12 SP5 freerdp Not affected
SUSE Linux Enterprise Server 15 SP5 freerdp Not affected
SUSE Linux Enterprise Server 15 SP6 freerdp Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP5 freerdp Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 freerdp Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP6 freerdp Not affected
SUSE Linux Enterprise Software Development Kit 12 SP5 freerdp Not affected
SUSE Linux Enterprise Workstation Extension 12 SP5 freerdp Not affected
SUSE Linux Enterprise Workstation Extension 15 SP5 freerdp Not affected
SUSE Linux Enterprise Workstation Extension 15 SP6 freerdp Not affected
openSUSE Leap 15.5 freerdp Not affected
openSUSE Leap 15.6 freerdp Not affected
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 freerdp Not affected
SUSE Linux Enterprise Server 15 SP4 freerdp Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 freerdp Not affected
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 12 SP2 freerdp Not affected
SUSE Linux Enterprise Desktop 12 SP3 freerdp Not affected
SUSE Linux Enterprise Desktop 12 SP4 freerdp Not affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 freerdp Not affected
SUSE Linux Enterprise Server 12 SP2 freerdp Not affected
SUSE Linux Enterprise Server 12 SP3 freerdp Not affected
SUSE Linux Enterprise Server 12 SP4 freerdp Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 freerdp Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 freerdp Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 freerdp Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 freerdp Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 freerdp Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 freerdp Not affected
SUSE Linux Enterprise Workstation Extension 12 SP2 freerdp Not affected
SUSE Linux Enterprise Workstation Extension 12 SP3 freerdp Not affected
SUSE Linux Enterprise Workstation Extension 12 SP4 freerdp Not affected
SUSE Linux Enterprise Workstation Extension 15 SP4 freerdp Not affected


SUSE Timeline for this CVE

CVE page created: Wed Apr 24 00:00:08 2024
CVE page last modified: Sat Jun 1 16:41:53 2024