Upstream information

CVE-2023-35936 at MITRE

Description

Pandoc is a Haskell library for converting from one markup format to another, and a command-line tool that uses this library. Starting in version 1.13 and prior to version 3.1.4, Pandoc is susceptible to an arbitrary file write vulnerability, which can be triggered by providing a specially crafted image element in the input when generating files using the `--extract-media` option or outputting to PDF format. This vulnerability allows an attacker to create or overwrite arbitrary files on the system ,depending on the privileges of the process running pandoc. It only affects systems that pass untrusted user input to pandoc and allow pandoc to be used to produce a PDF or with the `--extract-media` option. The fix is to unescape the percent-encoding prior to checking that the resource is not above the working directory, and prior to extracting the extension. Some code for checking that the path is below the working directory was flawed in a similar way and has also been fixed. Note that the `--sandbox` option, which only affects IO done by readers and writers themselves, does not block this vulnerability. The vulnerability is patched in pandoc 3.1.4. As a workaround, audit the pandoc command and disallow PDF output and the `--extract-media` option.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5 5.3
Vector CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:L CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:N/I:H/A:N
Attack Vector Local Local
Attack Complexity High High
Privileges Required Low Low
User Interaction Required Required
Scope Unchanged Changed
Confidentiality Impact None None
Integrity Impact High High
Availability Impact Low None
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entries: 1213066 [RESOLVED / FIXED], 1213622 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • ghc-pandoc >= 3.1.3-2.1
  • ghc-pandoc-devel >= 3.1.3-2.1
  • ghc-pandoc-doc >= 3.1.3-2.1
  • ghc-pandoc-prof >= 3.1.3-2.1
Patchnames:
openSUSE Tumbleweed GA ghc-pandoc-3.1.3-2.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Module for Package Hub 15 SP5 pandoc Already fixed
SUSE Linux Enterprise Module for Package Hub 15 SP6 pandoc Already fixed


SUSE Timeline for this CVE

CVE page created: Thu Jul 6 00:04:20 2023
CVE page last modified: Thu Jun 13 16:42:01 2024