Upstream information

CVE-2023-25563 at MITRE


GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, multiple out-of-bounds reads when decoding NTLM fields can trigger a denial of service. A 32-bit integer overflow condition can lead to incorrect checks of consistency of length of internal buffers. Although most applications will error out before accepting a singe input buffer of 4GB in length this could theoretically happen. This vulnerability can be triggered via the main `gss_accept_sec_context` entry point if the application allows tokens greater than 4GB in length. This can lead to a large, up to 65KB, out-of-bounds read which could cause a denial-of-service if it reads from unmapped memory. Version 1.2.0 contains a patch for the out-of-bounds reads.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database
Base Score 5.9
Vector CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network
Attack Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
CVSSv3 Version 3.1
SUSE Bugzilla entry: 1208278 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Liberty Linux 8
  • gssntlmssp >= 1.2.0-1.el8_8
SUSE Package Hub 15 SP4
  • gssntlmssp >= 1.2.0-bp154.2.3.1
  • gssntlmssp-devel >= 1.2.0-bp154.2.3.1
openSUSE Leap 15.4
  • gssntlmssp >= 1.2.0-bp154.2.3.1
  • gssntlmssp-devel >= 1.2.0-bp154.2.3.1
openSUSE Tumbleweed
  • gssntlmssp >= 1.2.0-1.1
  • gssntlmssp-devel >= 1.2.0-1.1
openSUSE Tumbleweed GA gssntlmssp-1.2.0-1.1

SUSE Timeline for this CVE

CVE page created: Tue Feb 14 21:00:58 2023
CVE page last modified: Mon Oct 30 18:18:59 2023