Upstream information

CVE-2022-2211 at MITRE

Description

A vulnerability was found in libguestfs. This issue occurs while calculating the greatest possible number of matching keys in the get_keys() function. This flaw leads to a denial of service, either by mistake or malicious actor.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 6.5 5.5
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Attack Vector Network Local
Attack Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1201064 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Container suse/sles/15.5/libguestfs-tools:0.58.0.17.143
  • guestfs-data >= 1.44.2-150400.3.3.1
  • guestfs-winsupport >= 1.44.2-150400.3.3.1
SUSE Liberty Linux 8
  • hivex >= 1.3.18-23.module+el8.7.0+16689+53d59bc2
  • hivex-devel >= 1.3.18-23.module+el8.7.0+16689+53d59bc2
  • libguestfs >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-appliance >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-bash-completion >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-devel >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-gfs2 >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-gobject >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-gobject-devel >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-inspect-icons >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-java >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-java-devel >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-javadoc >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-man-pages-ja >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-man-pages-uk >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-rescue >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-rsync >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-tools >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-tools-c >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libguestfs-winsupport >= 8.6-1.module+el8.7.0+16689+53d59bc2
  • libguestfs-xfs >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • libiscsi >= 1.18.0-8.module+el8.7.0+16689+53d59bc2
  • libiscsi-devel >= 1.18.0-8.module+el8.7.0+16689+53d59bc2
  • libiscsi-utils >= 1.18.0-8.module+el8.7.0+16689+53d59bc2
  • libnbd >= 1.6.0-5.module+el8.7.0+16689+53d59bc2
  • libnbd-bash-completion >= 1.6.0-5.module+el8.7.0+16689+53d59bc2
  • libnbd-devel >= 1.6.0-5.module+el8.7.0+16689+53d59bc2
  • libtpms >= 0.9.1-1.20211126git1ff6fe1f43.module+el8.7.0+16689+53d59bc2
  • libtpms-devel >= 0.9.1-1.20211126git1ff6fe1f43.module+el8.7.0+16689+53d59bc2
  • libvirt >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-client >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-config-network >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-config-nwfilter >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-interface >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-network >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-nodedev >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-nwfilter >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-qemu >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-secret >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-storage >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-storage-core >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-storage-disk >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-storage-gluster >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-storage-iscsi >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-storage-iscsi-direct >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-storage-logical >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-storage-mpath >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-storage-rbd >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-driver-storage-scsi >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-daemon-kvm >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-dbus >= 1.3.0-2.module+el8.7.0+16689+53d59bc2
  • libvirt-devel >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-docs >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-libs >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-lock-sanlock >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-nss >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • libvirt-wireshark >= 8.0.0-10.module+el8.7.0+16689+53d59bc2
  • lua-guestfs >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • nbdfuse >= 1.6.0-5.module+el8.7.0+16689+53d59bc2
  • nbdkit >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-bash-completion >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-basic-filters >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-basic-plugins >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-curl-plugin >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-devel >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-example-plugins >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-gzip-filter >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-gzip-plugin >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-linuxdisk-plugin >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-nbd-plugin >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-python-plugin >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-server >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-ssh-plugin >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-tar-filter >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-tar-plugin >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-tmpdisk-plugin >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-vddk-plugin >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • nbdkit-xz-filter >= 1.24.0-4.module+el8.7.0+16689+53d59bc2
  • netcf >= 0.2.8-12.module+el8.7.0+16689+53d59bc2
  • netcf-devel >= 0.2.8-12.module+el8.7.0+16689+53d59bc2
  • netcf-libs >= 0.2.8-12.module+el8.7.0+16689+53d59bc2
  • perl-Sys-Guestfs >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • perl-Sys-Virt >= 8.0.0-1.module+el8.7.0+16689+53d59bc2
  • perl-hivex >= 1.3.18-23.module+el8.7.0+16689+53d59bc2
  • python3-hivex >= 1.3.18-23.module+el8.7.0+16689+53d59bc2
  • python3-libguestfs >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • python3-libnbd >= 1.6.0-5.module+el8.7.0+16689+53d59bc2
  • python3-libvirt >= 8.0.0-2.module+el8.7.0+16689+53d59bc2
  • qemu-guest-agent >= 6.2.0-20.module+el8.7.0+16689+53d59bc2.1
  • qemu-img >= 6.2.0-20.module+el8.7.0+16689+53d59bc2.1
  • qemu-kvm >= 6.2.0-20.module+el8.7.0+16689+53d59bc2.1
  • qemu-kvm-block-curl >= 6.2.0-20.module+el8.7.0+16689+53d59bc2.1
  • qemu-kvm-block-gluster >= 6.2.0-20.module+el8.7.0+16689+53d59bc2.1
  • qemu-kvm-block-iscsi >= 6.2.0-20.module+el8.7.0+16689+53d59bc2.1
  • qemu-kvm-block-rbd >= 6.2.0-20.module+el8.7.0+16689+53d59bc2.1
  • qemu-kvm-block-ssh >= 6.2.0-20.module+el8.7.0+16689+53d59bc2.1
  • qemu-kvm-common >= 6.2.0-20.module+el8.7.0+16689+53d59bc2.1
  • qemu-kvm-core >= 6.2.0-20.module+el8.7.0+16689+53d59bc2.1
  • qemu-kvm-docs >= 6.2.0-20.module+el8.7.0+16689+53d59bc2.1
  • qemu-kvm-hw-usbredir >= 6.2.0-20.module+el8.7.0+16689+53d59bc2.1
  • qemu-kvm-ui-opengl >= 6.2.0-20.module+el8.7.0+16689+53d59bc2.1
  • qemu-kvm-ui-spice >= 6.2.0-20.module+el8.7.0+16689+53d59bc2.1
  • ruby-hivex >= 1.3.18-23.module+el8.7.0+16689+53d59bc2
  • ruby-libguestfs >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • seabios >= 1.16.0-3.module+el8.7.0+16689+53d59bc2
  • seabios-bin >= 1.16.0-3.module+el8.7.0+16689+53d59bc2
  • seavgabios-bin >= 1.16.0-3.module+el8.7.0+16689+53d59bc2
  • sgabios >= 0.20170427git-3.module+el8.7.0+16689+53d59bc2
  • sgabios-bin >= 0.20170427git-3.module+el8.7.0+16689+53d59bc2
  • supermin >= 5.2.1-2.module+el8.7.0+16689+53d59bc2
  • supermin-devel >= 5.2.1-2.module+el8.7.0+16689+53d59bc2
  • swtpm >= 0.7.0-4.20211109gitb79fd91.module+el8.7.0+16689+53d59bc2
  • swtpm-devel >= 0.7.0-4.20211109gitb79fd91.module+el8.7.0+16689+53d59bc2
  • swtpm-libs >= 0.7.0-4.20211109gitb79fd91.module+el8.7.0+16689+53d59bc2
  • swtpm-tools >= 0.7.0-4.20211109gitb79fd91.module+el8.7.0+16689+53d59bc2
  • swtpm-tools-pkcs11 >= 0.7.0-4.20211109gitb79fd91.module+el8.7.0+16689+53d59bc2
  • virt-dib >= 1.44.0-9.module+el8.7.0+16689+53d59bc2
  • virt-v2v >= 1.42.0-21.module+el8.7.0+16689+53d59bc2
  • virt-v2v-bash-completion >= 1.42.0-21.module+el8.7.0+16689+53d59bc2
  • virt-v2v-man-pages-ja >= 1.42.0-21.module+el8.7.0+16689+53d59bc2
  • virt-v2v-man-pages-uk >= 1.42.0-21.module+el8.7.0+16689+53d59bc2
Patchnames:
ESSA-2022:0193
SUSE Liberty Linux 9
  • guestfs-tools >= 1.48.2-5.el9
  • libguestfs >= 1.48.4-2.el9
  • libguestfs-appliance >= 1.48.4-2.el9
  • libguestfs-bash-completion >= 1.48.4-2.el9
  • libguestfs-devel >= 1.48.4-2.el9
  • libguestfs-gobject >= 1.48.4-2.el9
  • libguestfs-gobject-devel >= 1.48.4-2.el9
  • libguestfs-inspect-icons >= 1.48.4-2.el9
  • libguestfs-man-pages-ja >= 1.48.4-2.el9
  • libguestfs-man-pages-uk >= 1.48.4-2.el9
  • libguestfs-rescue >= 1.48.4-2.el9
  • libguestfs-rsync >= 1.48.4-2.el9
  • libguestfs-xfs >= 1.48.4-2.el9
  • lua-guestfs >= 1.48.4-2.el9
  • ocaml-libguestfs >= 1.48.4-2.el9
  • ocaml-libguestfs-devel >= 1.48.4-2.el9
  • perl-Sys-Guestfs >= 1.48.4-2.el9
  • php-libguestfs >= 1.48.4-2.el9
  • python3-libguestfs >= 1.48.4-2.el9
  • ruby-libguestfs >= 1.48.4-2.el9
  • virt-v2v >= 2.0.7-6.el9
  • virt-v2v-bash-completion >= 2.0.7-6.el9
  • virt-v2v-man-pages-ja >= 2.0.7-6.el9
  • virt-v2v-man-pages-uk >= 2.0.7-6.el9
  • virt-win-reg >= 1.48.2-5.el9
Patchnames:
RHSA-2022:7958
RHSA-2022:7959
RHSA-2022:7968
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Module for Development Tools 15 SP4
  • ocaml-libguestfs-devel >= 1.44.2-150400.3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP4-2022-2581
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • guestfs-data >= 1.44.2-150400.3.3.1
  • guestfs-tools >= 1.44.2-150400.3.3.1
  • guestfs-winsupport >= 1.44.2-150400.3.3.1
  • guestfsd >= 1.44.2-150400.3.3.1
  • libguestfs-devel >= 1.44.2-150400.3.3.1
  • libguestfs0 >= 1.44.2-150400.3.3.1
  • ocaml-libguestfs-devel >= 1.44.2-150400.3.3.1
  • perl-Sys-Guestfs >= 1.44.2-150400.3.3.1
  • python3-libguestfs >= 1.44.2-150400.3.3.1
  • virt-v2v >= 1.44.2-150400.3.3.1
  • virt-v2v-bash-completion >= 1.44.2-150400.3.3.1
  • virt-v2v-man-pages-ja >= 1.44.2-150400.3.3.1
  • virt-v2v-man-pages-uk >= 1.44.2-150400.3.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-SP4-2022-2581
SUSE-SLE-Module-Server-Applications-15-SP4-2022-2581
SUSE-SLE-Module-Server-Applications-15-SP4-2022-4308
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Server Applications 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • virt-v2v >= 1.44.2-150400.3.3.1
  • virt-v2v-bash-completion >= 1.44.2-150400.3.3.1
  • virt-v2v-man-pages-ja >= 1.44.2-150400.3.3.1
  • virt-v2v-man-pages-uk >= 1.44.2-150400.3.3.1
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 SP5 GA virt-v2v-1.44.2-150400.3.3.1
SUSE Linux Enterprise Micro 5.3
  • guestfs-data >= 1.44.2-150400.3.3.1
  • guestfs-tools >= 1.44.2-150400.3.3.1
  • libguestfs0 >= 1.44.2-150400.3.3.1
  • perl-Sys-Guestfs >= 1.44.2-150400.3.3.1
Patchnames:
SUSE Linux Enterprise Micro 5.3 GA guestfs-data-1.44.2-150400.3.3.1
SUSE Linux Enterprise Micro 5.4
  • guestfs-data >= 1.44.2-150400.3.3.1
  • guestfs-tools >= 1.44.2-150400.3.3.1
  • libguestfs0 >= 1.44.2-150400.3.3.1
  • perl-Sys-Guestfs >= 1.44.2-150400.3.3.1
Patchnames:
SUSE Linux Enterprise Micro 5.4 GA guestfs-data-1.44.2-150400.3.3.1
SUSE Linux Enterprise Micro 6.0
  • guestfs-tools >= 1.52.0-1.2
  • libguestfs0 >= 1.52.0-1.3
Patchnames:
SUSE Linux Enterprise Micro 6.0 GA guestfs-tools-1.52.0-1.2
SUSE Linux Enterprise Micro 6.0 GA libguestfs0-1.52.0-1.3
SUSE Linux Enterprise Module for Server Applications 15 SP4
  • guestfs-data >= 1.44.2-150400.3.3.1
  • guestfs-tools >= 1.44.2-150400.3.3.1
  • guestfs-winsupport >= 1.44.2-150400.3.3.1
  • guestfsd >= 1.44.2-150400.3.3.1
  • libguestfs-devel >= 1.44.2-150400.3.3.1
  • libguestfs0 >= 1.44.2-150400.3.3.1
  • perl-Sys-Guestfs >= 1.44.2-150400.3.3.1
  • python3-libguestfs >= 1.44.2-150400.3.3.1
  • virt-v2v >= 1.44.2-150400.3.3.1
  • virt-v2v-bash-completion >= 1.44.2-150400.3.3.1
  • virt-v2v-man-pages-ja >= 1.44.2-150400.3.3.1
  • virt-v2v-man-pages-uk >= 1.44.2-150400.3.3.1
Patchnames:
SUSE-SLE-Module-Server-Applications-15-SP4-2022-2581
SUSE-SLE-Module-Server-Applications-15-SP4-2022-4308
openSUSE Leap 15.4
  • guestfs-data >= 1.44.2-150400.3.3.1
  • guestfs-tools >= 1.44.2-150400.3.3.1
  • guestfs-winsupport >= 1.44.2-150400.3.3.1
  • guestfsd >= 1.44.2-150400.3.3.1
  • libguestfs-devel >= 1.44.2-150400.3.3.1
  • libguestfs-test >= 1.44.2-150400.3.3.1
  • libguestfs0 >= 1.44.2-150400.3.3.1
  • lua-libguestfs >= 1.44.2-150400.3.3.1
  • ocaml-libguestfs >= 1.44.2-150400.3.3.1
  • ocaml-libguestfs-devel >= 1.44.2-150400.3.3.1
  • perl-Sys-Guestfs >= 1.44.2-150400.3.3.1
  • python3-libguestfs >= 1.44.2-150400.3.3.1
  • rubygem-libguestfs >= 1.44.2-150400.3.3.1
  • virt-v2v >= 1.44.2-150400.3.3.1
  • virt-v2v-bash-completion >= 1.44.2-150400.3.3.1
  • virt-v2v-man-pages-ja >= 1.44.2-150400.3.3.1
  • virt-v2v-man-pages-uk >= 1.44.2-150400.3.3.1
Patchnames:
openSUSE-SLE-15.4-2022-2581
openSUSE-SLE-15.4-2022-4308
openSUSE Tumbleweed
  • guestfs-tools >= 1.48.2-2.1
  • guestfs-tools-bash-completion >= 1.48.2-2.1
  • guestfs-tools-man-pages-ja >= 1.48.2-2.1
  • guestfs-tools-man-pages-uk >= 1.48.2-2.1
  • libguestfs >= 1.48.3-3.1
  • libguestfs-appliance >= 1.48.3-3.1
  • libguestfs-bash-completion >= 1.48.3-3.1
  • libguestfs-devel >= 1.48.3-3.1
  • libguestfs-gobject-1_0 >= 1.48.3-3.1
  • libguestfs-gobject-devel >= 1.48.3-3.1
  • libguestfs-inspect-icons >= 1.48.3-3.1
  • libguestfs-man-pages-ja >= 1.48.3-3.1
  • libguestfs-man-pages-uk >= 1.48.3-3.1
  • libguestfs-rescue >= 1.48.3-3.1
  • libguestfs-rsync >= 1.48.3-3.1
  • libguestfs-typelib-Guestfs-1_0 >= 1.48.3-3.1
  • libguestfs-winsupport >= 1.48.3-3.1
  • libguestfs-xfs >= 1.48.3-3.1
  • libguestfs0 >= 1.48.3-3.1
  • libguestfsd >= 1.48.3-3.1
  • lua-libguestfs >= 1.48.3-3.1
  • ocaml-libguestfs >= 1.48.3-3.1
  • ocaml-libguestfs-devel >= 1.48.3-3.1
  • perl-Sys-Guestfs >= 1.48.3-3.1
  • python3-libguestfs >= 1.48.3-3.1
  • rubygem-libguestfs >= 1.48.3-3.1
  • virt-v2v >= 2.0.6-2.1
  • virt-v2v-bash-completion >= 2.0.6-2.1
  • virt-v2v-man-pages-ja >= 2.0.6-2.1
  • virt-v2v-man-pages-uk >= 2.0.6-2.1
  • virt-win-reg >= 1.48.2-2.1
Patchnames:
openSUSE Tumbleweed GA guestfs-tools-1.48.2-2.1
openSUSE Tumbleweed GA libguestfs-1.48.3-3.1
openSUSE Tumbleweed GA virt-v2v-2.0.6-2.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Enterprise Storage 7.1 libguestfs Not affected
SUSE Linux Enterprise High Performance Computing 12 SP5 libguestfs Not affected
SUSE Linux Enterprise High Performance Computing 15 SP5 guestfs-tools Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP5 libguestfs Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP5 virt-v2v Released
SUSE Linux Enterprise High Performance Computing 15 SP6 guestfs-tools Already fixed
SUSE Linux Enterprise High Performance Computing 15 SP6 virt-v2v Already fixed
SUSE Linux Enterprise Micro 5.1 libguestfs Not affected
SUSE Linux Enterprise Micro 5.2 libguestfs Not affected
SUSE Linux Enterprise Micro 5.3 libguestfs Released
SUSE Linux Enterprise Micro 5.4 libguestfs Affected
SUSE Linux Enterprise Micro 5.5 guestfs-tools Already fixed
SUSE Linux Enterprise Micro 5.5 libguestfs Already fixed
SUSE Linux Enterprise Module for Server Applications 15 SP5 guestfs-tools Already fixed
SUSE Linux Enterprise Module for Server Applications 15 SP5 libguestfs Already fixed
SUSE Linux Enterprise Module for Server Applications 15 SP5 virt-v2v Released
SUSE Linux Enterprise Module for Server Applications 15 SP6 guestfs-tools Already fixed
SUSE Linux Enterprise Module for Server Applications 15 SP6 virt-v2v Already fixed
SUSE Linux Enterprise Server 12 SP5 libguestfs Not affected
SUSE Linux Enterprise Server 15 SP5 guestfs-tools Already fixed
SUSE Linux Enterprise Server 15 SP5 libguestfs Already fixed
SUSE Linux Enterprise Server 15 SP5 virt-v2v Released
SUSE Linux Enterprise Server 15 SP6 guestfs-tools Already fixed
SUSE Linux Enterprise Server 15 SP6 virt-v2v Already fixed
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libguestfs Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP5 guestfs-tools Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP5 libguestfs Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP5 virt-v2v Released
SUSE Linux Enterprise Server for SAP Applications 15 SP6 guestfs-tools Already fixed
SUSE Linux Enterprise Server for SAP Applications 15 SP6 virt-v2v Already fixed
SUSE Linux Enterprise Software Development Kit 12 SP5 libguestfs Not affected
SUSE Manager Proxy 4.3 libguestfs Released
SUSE Manager Proxy 4.3 virt-v2v Released
SUSE Manager Retail Branch Server 4.3 libguestfs Released
SUSE Manager Retail Branch Server 4.3 virt-v2v Released
SUSE Manager Server 4.3 libguestfs Released
SUSE Manager Server 4.3 virt-v2v Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 libguestfs Released
SUSE Linux Enterprise High Performance Computing 15 SP2 libguestfs Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-ESPOS libguestfs Not affected
SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS libguestfs Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3 libguestfs Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-ESPOS libguestfs Not affected
SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS libguestfs Not affected
SUSE Linux Enterprise High Performance Computing 15 SP4 libguestfs Released
SUSE Linux Enterprise High Performance Computing 15 SP4 virt-v2v Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS libguestfs Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS virt-v2v Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS libguestfs Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS virt-v2v Affected
SUSE Linux Enterprise Module for Development Tools 15 SP2 libguestfs Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP3 libguestfs Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP4 libguestfs Released
SUSE Linux Enterprise Module for Server Applications 15 SP2 libguestfs Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP3 libguestfs Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP4 libguestfs Released
SUSE Linux Enterprise Module for Server Applications 15 SP4 virt-v2v Released
SUSE Linux Enterprise Server 15 SP2 libguestfs Not affected
SUSE Linux Enterprise Server 15 SP2-LTSS libguestfs Not affected
SUSE Linux Enterprise Server 15 SP3 libguestfs Not affected
SUSE Linux Enterprise Server 15 SP3-LTSS libguestfs Not affected
SUSE Linux Enterprise Server 15 SP4 libguestfs Released
SUSE Linux Enterprise Server 15 SP4 virt-v2v Released
SUSE Linux Enterprise Server 15 SP4-LTSS libguestfs Affected
SUSE Linux Enterprise Server 15 SP4-LTSS virt-v2v Affected
SUSE Linux Enterprise Server 15-ESPOS libguestfs Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP1 libguestfs Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP2 libguestfs Not affected
SUSE Linux Enterprise Server Business Critical Linux 15 SP3 libguestfs Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libguestfs Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libguestfs Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libguestfs Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 virt-v2v Released
Products past their end of life and not receiving proactive updates anymore.
HPE Helion OpenStack 8 libguestfs Not affected
SUSE CaaS Platform 4.0 libguestfs Not affected
SUSE Enterprise Storage 6 libguestfs Not affected
SUSE Enterprise Storage 7 libguestfs Not affected
SUSE Linux Enterprise Desktop 12 SP2 libguestfs Not affected
SUSE Linux Enterprise Desktop 12 SP3 libguestfs Not affected
SUSE Linux Enterprise Desktop 12 SP4 libguestfs Not affected
SUSE Linux Enterprise Desktop 15 libguestfs Not affected
SUSE Linux Enterprise Desktop 15 SP1 libguestfs Not affected
SUSE Linux Enterprise Desktop 15 SP2 libguestfs Not affected
SUSE Linux Enterprise Desktop 15 SP3 libguestfs Not affected
SUSE Linux Enterprise High Performance Computing 15 libguestfs Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1 libguestfs Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-ESPOS libguestfs Not affected
SUSE Linux Enterprise High Performance Computing 15 SP1-LTSS libguestfs Not affected
SUSE Linux Enterprise High Performance Computing 15-ESPOS libguestfs Not affected
SUSE Linux Enterprise High Performance Computing 15-LTSS libguestfs Not affected
SUSE Linux Enterprise Micro 5.0 libguestfs Not affected
SUSE Linux Enterprise Module for Development Tools 15 libguestfs Not affected
SUSE Linux Enterprise Module for Development Tools 15 SP1 libguestfs Not affected
SUSE Linux Enterprise Module for Server Applications 15 libguestfs Not affected
SUSE Linux Enterprise Module for Server Applications 15 SP1 libguestfs Not affected
SUSE Linux Enterprise Real Time 15 SP2 libguestfs Not affected
SUSE Linux Enterprise Real Time 15 SP3 libguestfs Not affected
SUSE Linux Enterprise Real Time 15 SP4 libguestfs Affected
SUSE Linux Enterprise Real Time 15 SP4 virt-v2v Affected
SUSE Linux Enterprise Server 12 SP2 libguestfs Not affected
SUSE Linux Enterprise Server 12 SP2-BCL libguestfs Not affected
SUSE Linux Enterprise Server 12 SP2-ESPOS libguestfs Not affected
SUSE Linux Enterprise Server 12 SP2-LTSS libguestfs Not affected
SUSE Linux Enterprise Server 12 SP3 libguestfs Not affected
SUSE Linux Enterprise Server 12 SP3-BCL libguestfs Not affected
SUSE Linux Enterprise Server 12 SP3-ESPOS libguestfs Not affected
SUSE Linux Enterprise Server 12 SP3-LTSS libguestfs Not affected
SUSE Linux Enterprise Server 12 SP4 libguestfs Not affected
SUSE Linux Enterprise Server 12 SP4-ESPOS libguestfs Not affected
SUSE Linux Enterprise Server 12 SP4-LTSS libguestfs Not affected
SUSE Linux Enterprise Server 15 libguestfs Not affected
SUSE Linux Enterprise Server 15 SP1 libguestfs Not affected
SUSE Linux Enterprise Server 15 SP1-BCL libguestfs Not affected
SUSE Linux Enterprise Server 15 SP1-LTSS libguestfs Not affected
SUSE Linux Enterprise Server 15 SP2-BCL libguestfs Not affected
SUSE Linux Enterprise Server 15 SP3-BCL libguestfs Not affected
SUSE Linux Enterprise Server 15-LTSS libguestfs Not affected
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 libguestfs Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libguestfs Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libguestfs Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libguestfs Not affected
SUSE Linux Enterprise Server for SAP Applications 15 libguestfs Not affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libguestfs Not affected
SUSE Linux Enterprise Software Development Kit 12 SP2 libguestfs Not affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libguestfs Not affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libguestfs Not affected
SUSE Manager Proxy 4.0 libguestfs Not affected
SUSE Manager Proxy 4.1 libguestfs Not affected
SUSE Manager Proxy 4.2 libguestfs Not affected
SUSE Manager Retail Branch Server 4.0 libguestfs Not affected
SUSE Manager Retail Branch Server 4.1 libguestfs Not affected
SUSE Manager Retail Branch Server 4.2 libguestfs Not affected
SUSE Manager Server 4.0 libguestfs Not affected
SUSE Manager Server 4.1 libguestfs Not affected
SUSE Manager Server 4.2 libguestfs Not affected
SUSE OpenStack Cloud 7 libguestfs Not affected
SUSE OpenStack Cloud 8 libguestfs Not affected
SUSE OpenStack Cloud 9 libguestfs Not affected
SUSE OpenStack Cloud Crowbar 8 libguestfs Not affected
SUSE OpenStack Cloud Crowbar 9 libguestfs Not affected
openSUSE Leap 15.4 virt-v2v Released
Container Status
suse/sles/15.5/libguestfs-tools:0.58.0
suse/sles/15.6/libguestfs-tools:1.1.1
guestfs-toolsAlready fixed
suse/sles/15.5/libguestfs-tools:0.58.0 libguestfsAlready fixed


SUSE Timeline for this CVE

CVE page created: Thu Jun 30 18:45:08 2022
CVE page last modified: Fri Jun 7 17:19:59 2024