Upstream information

CVE-2021-32142 at MITRE

Description

Buffer Overflow vulnerability in LibRaw linux/unix v0.20.0 allows attacker to escalate privileges via the LibRaw_buffer_datastream::gets(char*, int) in /src/libraw/src/libraw_datastream.cpp.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 6.3
Vector CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
Attack Vector Local Local
Attack Complexity Low Low
Privileges Required None Low
User Interaction Required None
Scope Unchanged Changed
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1208470 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Liberty Linux 7
  • LibRaw >= 0.19.4-2.el7_9
  • LibRaw-devel >= 0.19.4-2.el7_9
  • LibRaw-static >= 0.19.4-2.el7_9
Patchnames:
RHSA-2024:0343
SUSE Liberty Linux 9
  • LibRaw >= 0.20.2-6.el9
  • LibRaw-devel >= 0.20.2-6.el9
Patchnames:
RHSA-2023:6343
SUSE Linux Enterprise Desktop 15 SP4
SUSE Linux Enterprise Server 15 SP4
SUSE Linux Enterprise Server for SAP Applications 15 SP4
  • libraw-devel >= 0.20.2-150400.3.3.1
  • libraw16 >= 0.18.9-150000.3.17.1
  • libraw20 >= 0.20.2-150400.3.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP4-2023-512
SUSE-SLE-Product-WE-15-SP4-2023-511
SUSE-SLE-Product-WE-15-SP4-2023-512
SUSE Linux Enterprise Desktop 15 SP5
SUSE Linux Enterprise Server 15 SP5
SUSE Linux Enterprise Server for SAP Applications 15 SP5
  • libraw-devel >= 0.20.2-150400.3.3.1
  • libraw16 >= 0.18.9-150000.3.17.1
  • libraw20 >= 0.20.2-150400.3.3.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 GA libraw-0.20.2-150400.3.6.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 GA libraw20-0.20.2-150400.3.6.1
SUSE Linux Enterprise Workstation Extension 15 SP5 GA libraw-0.18.9-150000.3.20.1
SUSE Linux Enterprise Workstation Extension 15 SP5 GA libraw-0.20.2-150400.3.6.1
SUSE Linux Enterprise High Performance Computing 15 SP4
SUSE Linux Enterprise Module for Desktop Applications 15 SP4
SUSE Manager Proxy 4.3
SUSE Manager Retail Branch Server 4.3
SUSE Manager Server 4.3
  • libraw20 >= 0.20.2-150400.3.3.1
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-SP4-2023-512
SUSE Linux Enterprise High Performance Computing 15 SP5
SUSE Linux Enterprise Module for Desktop Applications 15 SP5
  • libraw20 >= 0.20.2-150400.3.3.1
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 GA libraw-0.20.2-150400.3.6.1
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 GA libraw20-0.20.2-150400.3.6.1
SUSE Linux Enterprise Module for Package Hub 15 SP5
  • libraw-devel >= 0.20.2-150400.3.3.1
  • libraw-devel-static >= 0.20.2-150400.3.3.1
  • libraw-tools >= 0.20.2-150400.3.3.1
Patchnames:
SUSE Linux Enterprise Module for Package Hub 15 SP5 GA libraw-0.20.2-150400.3.6.1
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libraw-devel >= 0.15.4-36.1
  • libraw-devel-static >= 0.15.4-36.1
  • libraw9 >= 0.15.4-36.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2023-510
SUSE-SLE-WE-12-SP5-2023-510
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libraw-devel >= 0.15.4-36.1
  • libraw-devel-static >= 0.15.4-36.1
  • libraw9 >= 0.15.4-36.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2023-510
SUSE Linux Enterprise Workstation Extension 12 SP5
  • libraw9 >= 0.15.4-36.1
Patchnames:
SUSE-SLE-WE-12-SP5-2023-510
SUSE Linux Enterprise Workstation Extension 15 SP4
  • libraw-devel >= 0.20.2-150400.3.3.1
  • libraw16 >= 0.18.9-150000.3.17.1
Patchnames:
SUSE-SLE-Product-WE-15-SP4-2023-511
SUSE-SLE-Product-WE-15-SP4-2023-512
SUSE Linux Enterprise Workstation Extension 15 SP5
  • libraw-devel >= 0.20.2-150400.3.3.1
  • libraw16 >= 0.18.9-150000.3.17.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 SP5 GA libraw-0.18.9-150000.3.20.1
SUSE Linux Enterprise Workstation Extension 15 SP5 GA libraw-0.20.2-150400.3.6.1
openSUSE Leap 15.4
  • libraw-devel >= 0.20.2-150400.3.3.1
  • libraw-devel-static >= 0.20.2-150400.3.3.1
  • libraw-tools >= 0.20.2-150400.3.3.1
  • libraw16 >= 0.18.9-150000.3.17.1
  • libraw20 >= 0.20.2-150400.3.3.1
  • libraw20-32bit >= 0.20.2-150400.3.3.1
Patchnames:
openSUSE-SLE-15.4-2023-511
openSUSE-SLE-15.4-2023-512


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification. The updates are grouped by state of their lifecycle. SUSE product lifecycles are documented on the lifecycle page.

Product(s) Source package State
Products under general support and receiving all security fixes.
SUSE Linux Enterprise Desktop 15 SP5 libraw Released
SUSE Linux Enterprise High Performance Computing 15 SP5 libraw Released
SUSE Linux Enterprise Module for Desktop Applications 15 SP5 libraw Released
SUSE Linux Enterprise Module for Package Hub 15 SP5 libraw Released
SUSE Linux Enterprise Server 12 SP5 libraw Released
SUSE Linux Enterprise Server 15 SP5 libraw Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libraw Released
SUSE Linux Enterprise Server for SAP Applications 15 SP4 libraw Released
SUSE Linux Enterprise Server for SAP Applications 15 SP5 libraw Released
SUSE Linux Enterprise Software Development Kit 12 SP5 libraw Released
SUSE Linux Enterprise Workstation Extension 12 SP5 libraw Released
SUSE Linux Enterprise Workstation Extension 15 SP5 libraw Released
SUSE Manager Proxy 4.3 libraw Released
SUSE Manager Retail Branch Server 4.3 libraw Released
SUSE Manager Server 4.3 libraw Released
Products under Long Term Service Pack support and receiving important and critical security fixes.
SUSE Linux Enterprise Desktop 15 SP4 libraw Released
SUSE Linux Enterprise High Performance Computing 15 SP4 libraw Released
SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS libraw Affected
SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS libraw Affected
SUSE Linux Enterprise Module for Desktop Applications 15 SP4 libraw Released
SUSE Linux Enterprise Server 15 SP2 libraw Affected
SUSE Linux Enterprise Server 15 SP3 libraw Affected
SUSE Linux Enterprise Server 15 SP4 libraw Released
SUSE Linux Enterprise Server 15 SP4-LTSS libraw Affected
SUSE Linux Enterprise Server for SAP Applications 15 libraw Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP1 libraw Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP2 libraw Affected
SUSE Linux Enterprise Server for SAP Applications 15 SP3 libraw Affected
Products past their end of life and not receiving proactive updates anymore.
SUSE Linux Enterprise Desktop 12 libraw Affected
SUSE Linux Enterprise Desktop 12 SP1 libraw Affected
SUSE Linux Enterprise Desktop 12 SP2 libraw Affected
SUSE Linux Enterprise Desktop 12 SP3 libraw Affected
SUSE Linux Enterprise Desktop 12 SP4 libraw Affected
SUSE Linux Enterprise Desktop 15 libraw Affected
SUSE Linux Enterprise Desktop 15 SP1 libraw Affected
SUSE Linux Enterprise Desktop 15 SP2 libraw Affected
SUSE Linux Enterprise Desktop 15 SP3 libraw Affected
SUSE Linux Enterprise Module for Package Hub 15 SP4 libraw Affected
SUSE Linux Enterprise Real Time 15 SP4 libraw Affected
SUSE Linux Enterprise Server 12 libraw Affected
SUSE Linux Enterprise Server 12 SP1 libraw Affected
SUSE Linux Enterprise Server 12 SP2 libraw Affected
SUSE Linux Enterprise Server 12 SP3 libraw Affected
SUSE Linux Enterprise Server 12 SP4 libraw Affected
SUSE Linux Enterprise Server 15 libraw Affected
SUSE Linux Enterprise Server 15 SP1 libraw Affected
SUSE Linux Enterprise Server for SAP Applications 12 libraw Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 libraw Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 libraw Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 libraw Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 libraw Affected
SUSE Linux Enterprise Software Development Kit 12 libraw Affected
SUSE Linux Enterprise Software Development Kit 12 SP1 libraw Affected
SUSE Linux Enterprise Software Development Kit 12 SP2 libraw Affected
SUSE Linux Enterprise Software Development Kit 12 SP3 libraw Affected
SUSE Linux Enterprise Software Development Kit 12 SP4 libraw Affected
SUSE Linux Enterprise Workstation Extension 12 libraw Affected
SUSE Linux Enterprise Workstation Extension 12 SP1 libraw Affected
SUSE Linux Enterprise Workstation Extension 12 SP2 libraw Affected
SUSE Linux Enterprise Workstation Extension 12 SP3 libraw Affected
SUSE Linux Enterprise Workstation Extension 12 SP4 libraw Affected
SUSE Linux Enterprise Workstation Extension 15 libraw Affected
SUSE Linux Enterprise Workstation Extension 15 SP1 libraw Affected
SUSE Linux Enterprise Workstation Extension 15 SP2 libraw Affected
SUSE Linux Enterprise Workstation Extension 15 SP3 libraw Affected
SUSE Linux Enterprise Workstation Extension 15 SP4 libraw Released
openSUSE Leap 15.4 libraw Released


SUSE Timeline for this CVE

CVE page created: Fri Feb 17 21:00:21 2023
CVE page last modified: Fri Apr 19 18:41:18 2024