Upstream information

CVE-2019-3825 at MITRE

Description

A vulnerability was discovered in gdm before 3.31.4. When timed login is enabled in configuration, an attacker could bypass the lock screen by selecting the timed login user and waiting for the timer to expire, at which time they would gain access to the logged-in user's session.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1124628 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • gdm >= 3.26.2.1-13.19.2
  • gdm-devel >= 3.26.2.1-13.19.2
  • gdm-lang >= 3.26.2.1-13.19.2
  • gdmflexiserver >= 3.26.2.1-13.19.2
  • libgdm1 >= 3.26.2.1-13.19.2
  • typelib-1_0-Gdm-1_0 >= 3.26.2.1-13.19.2
SUSE Linux Enterprise Module for Desktop Applications 15
  • gdm >= 3.26.2.1-13.19.2
  • gdm-devel >= 3.26.2.1-13.19.2
  • gdm-lang >= 3.26.2.1-13.19.2
  • gdmflexiserver >= 3.26.2.1-13.19.2
  • libgdm1 >= 3.26.2.1-13.19.2
  • typelib-1_0-Gdm-1_0 >= 3.26.2.1-13.19.2
Patchnames:
SUSE-SLE-Module-Desktop-Applications-15-2019-527
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • gdm >= 3.26.2.1-13.19.2
  • gdm-branding-upstream >= 3.26.2.1-13.19.2
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-527
openSUSE Leap 15.0
  • gdm >= 3.26.2.1-lp150.11.9.1
  • gdm-branding-upstream >= 3.26.2.1-lp150.11.9.1
  • gdm-debuginfo >= 3.26.2.1-lp150.11.9.1
  • gdm-debugsource >= 3.26.2.1-lp150.11.9.1
  • gdm-devel >= 3.26.2.1-lp150.11.9.1
  • gdm-lang >= 3.26.2.1-lp150.11.9.1
  • gdmflexiserver >= 3.26.2.1-lp150.11.9.1
  • libgdm1 >= 3.26.2.1-lp150.11.9.1
  • libgdm1-debuginfo >= 3.26.2.1-lp150.11.9.1
  • typelib-1_0-Gdm-1_0 >= 3.26.2.1-lp150.11.9.1
Patchnames:
openSUSE-2019-310


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES for SAP Applications gdm Analysis
SUSE Linux Enterprise 15 Module for Desktop Applications gdm Released
SUSE Linux Enterprise 15-SP1 Module for Desktop Applications gdm Released
SUSE Linux Enterprise Desktop 12 SP3 gdm Analysis
SUSE Linux Enterprise Desktop 12 SP4 gdm Analysis
SUSE Linux Enterprise High Performance Computing 12 SP4 gdm Analysis
SUSE Linux Enterprise Server 11 SP1 gdm Analysis
SUSE Linux Enterprise Server 11 SP3 gdm Analysis
SUSE Linux Enterprise Server 11 SP3 LTSS gdm Analysis
SUSE Linux Enterprise Server 11 SP4 gdm Analysis
SUSE Linux Enterprise Server 12 LTSS gdm Analysis
SUSE Linux Enterprise Server 12 SP1 LTSS gdm Analysis
SUSE Linux Enterprise Server 12 SP2 LTSS gdm Analysis
SUSE Linux Enterprise Server 12 SP3 gdm Analysis
SUSE Linux Enterprise Server 12 SP4 gdm Analysis
SUSE Linux Enterprise Server for SAP Applications 12 gdm Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP2 gdm Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP3 gdm Analysis
SUSE Linux Enterprise Server for SAP Applications 12 SP4 gdm Analysis
SUSE Linux Enterprise Software Development Kit 12 SP3 gdm Analysis
SUSE Linux Enterprise Software Development Kit 12 SP4 gdm Analysis