Upstream information

CVE-2018-8001 at MITRE

Description

In PoDoFo 0.9.5, there exists a heap-based buffer over-read vulnerability in UnescapeName() in PdfName.cpp. Remote attackers could leverage this vulnerability to cause a denial-of-service or possibly unspecified other impact via a crafted pdf file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.8 5.3
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Access Vector Local Local
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
SUSE Bugzilla entry: 1084894 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Build System Kit 12 SP3
  • libpodofo-devel >= 0.9.2-3.3.1
  • podofo >= 0.9.2-3.3.1
Patchnames:
SUSE-SLE-BSK-12-SP3-2018-1744
SUSE Linux Enterprise Desktop 12 SP3
  • libpodofo0_9_2 >= 0.9.2-3.3.1
  • podofo >= 0.9.2-3.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1744
SUSE Linux Enterprise Desktop 12 SP4
  • libpodofo0_9_2 >= 0.9.2-3.3.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libpodofo0_9_2
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libpodofo-devel >= 0.9.2-3.3.1
  • podofo >= 0.9.2-3.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1744
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libpodofo-devel >= 0.9.2-3.3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libpodofo-devel
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libpodofo0_9_2 >= 0.9.2-3.3.1
  • podofo >= 0.9.2-3.3.1
Patchnames:
SUSE-SLE-WE-12-SP3-2018-1744
SUSE Linux Enterprise Workstation Extension 12 SP4
  • libpodofo0_9_2 >= 0.9.2-3.3.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP4 GA libpodofo0_9_2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise BSK 12 SP2 podofo Unsupported
SUSE Linux Enterprise BSK 12 SP3 podofo Released
SUSE Linux Enterprise Desktop 12 SP2 podofo Unsupported
SUSE Linux Enterprise Desktop 12 SP3 podofo Released
SUSE Linux Enterprise SDK 12 SP2 podofo Unsupported
SUSE Linux Enterprise SDK 12 SP3 podofo Released
SUSE Linux Enterprise Workstation Extension 12 SP2 podofo Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP3 podofo Released