Upstream information

CVE-2018-3157 at MITRE

Description

Vulnerability in the Java SE component of Oracle Java SE (subcomponent: Sound). The supported version that is affected is Java SE: 11. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE. Successful attacks of this vulnerability can result in unauthorized read access to a subset of Java SE accessible data. Note: This vulnerability applies to Java deployments that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.0 Base Score 3.7 (Confidentiality impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N).

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 3.7 3.7
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Access Vector Network Network
Access Complexity High High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact Low Low
Integrity Impact None None
Availability Impact None None
CVSSv3 Version 3.0 3.0
SUSE Bugzilla entry: 1112149 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • java-11-openjdk >= 11.0.3.0-3.24.1
  • java-11-openjdk-demo >= 11.0.3.0-3.24.1
  • java-11-openjdk-devel >= 11.0.3.0-3.24.1
  • java-11-openjdk-headless >= 11.0.3.0-3.24.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA java-11-openjdk
openSUSE Leap 15.0
  • java-11-openjdk >= 11.0.1.0-lp150.2.6.1
  • java-11-openjdk-accessibility >= 11.0.1.0-lp150.2.6.1
  • java-11-openjdk-accessibility-debuginfo >= 11.0.1.0-lp150.2.6.1
  • java-11-openjdk-debuginfo >= 11.0.1.0-lp150.2.6.1
  • java-11-openjdk-debugsource >= 11.0.1.0-lp150.2.6.1
  • java-11-openjdk-demo >= 11.0.1.0-lp150.2.6.1
  • java-11-openjdk-devel >= 11.0.1.0-lp150.2.6.1
  • java-11-openjdk-headless >= 11.0.1.0-lp150.2.6.1
  • java-11-openjdk-javadoc >= 11.0.1.0-lp150.2.6.1
  • java-11-openjdk-jmods >= 11.0.1.0-lp150.2.6.1
  • java-11-openjdk-src >= 11.0.1.0-lp150.2.6.1
Patchnames:
openSUSE-2019-818


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Performance Computing 12 java-1_7_1-ibm Affected
SUSE Linux Enterprise SDK 12 SP3 java-1_7_1-ibm Affected
SUSE Linux Enterprise SDK 12 SP4 java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 GA LTSS java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 SP1 LTSS java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 SP2 LTSS java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 SP3 java-1_7_1-ibm Affected
SUSE Linux Enterprise Server 12 SP4 java-1_7_1-ibm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 java-1_7_1-ibm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 java-1_7_1-ibm Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 java-1_7_1-ibm Affected